You are not logged in.

#1 2021-04-16 12:17:05

redsearch
Member
Registered: 2015-11-17
Posts: 18

GPG error on apt update

This happens on multiple computers even after fresh install.

sb@blackbox:~$ sudo -i
[sudo] password for jsb:
root@blackbox:~# apt update
Hit:1 https://deb.debian.org/debian buster InRelease
Hit:2 https://deb.debian.org/debian-security buster/updates InRelease    
Hit:3 https://deb.debian.org/debian buster-updates InRelease              
Hit:4 https://deb.debian.org/debian buster-backports InRelease            
Get:5 http://eu.pkg.bunsenlabs.org/debian lithium InRelease [6,362 B]        
Get:6 https://eu.pkg.bunsenlabs.org/debian buster-backports InRelease [5,154 B]
Err:5 http://eu.pkg.bunsenlabs.org/debian lithium InRelease
  The following signatures were invalid: EXPKEYSIG A0673F72FE62D9C5 Jens John (BunsenLabs Repository Signing Key) <dev@2ion.de>
Err:6 https://eu.pkg.bunsenlabs.org/debian buster-backports InRelease
  The following signatures were invalid: EXPKEYSIG A0673F72FE62D9C5 Jens John (BunsenLabs Repository Signing Key) <dev@2ion.de>
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://eu.pkg.bunsenlabs.org/debian lithium InRelease: The following signatures were invalid: EXPKEYSIG A0673F72FE62D9C5 Jens John (BunsenLabs Repository Signing Key) <dev@2ion.de>
W: GPG error: https://eu.pkg.bunsenlabs.org/debian buster-backports InRelease: The following signatures were invalid: EXPKEYSIG A0673F72FE62D9C5 Jens John (BunsenLabs Repository Signing Key) <dev@2ion.de>
E: The repository 'https://pkg.bunsenlabs.org/debian buster-backports InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@blackbox:~#

Last edited by redsearch (2021-04-16 12:18:11)

Offline

#2 2021-04-16 12:26:53

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,034

Re: GPG error on apt update

Are you using latst isos from https://www.bunsenlabs.org/installation.html? that is lithium-2.1-amd64.hybrid.iso or  lithium-2.1-cd-i386.hybrid.iso

If so, follow the instructions on https://www.bunsenlabs.org/repositories.html, to install latest apt-key or key-ring package.


// Regards rbh

Offline

#3 2021-04-18 00:54:47

redsearch
Member
Registered: 2015-11-17
Posts: 18

Re: GPG error on apt update

That worked, this is solved.

Offline

Board footer

Powered by FluxBB