You are not logged in.

#1 2021-04-01 18:19:16

corey.taylor
Member
From: Dresden
Registered: 2020-04-14
Posts: 28
Website

Making a keyboard layout stay

Hey dudes,

So I'm having issues with making my keyboard work the way it should. For your information, I was using an English keyboard but the new one is a German keyboard.

I have tried:

sudo dpkg-reconfigure locales

sudo dpkg-reconfigure keyboard-configuration

service keyboard-setup restart

They all appear setup as they should, even after a reboot.

I have tried setting it up in initramfs and my /etc/default/keyboard file looks like this:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT=""
XKBOPTIONS="terminate:ctrl_alt_bksp"

BACKSPACE="guess"

The odd part is that when I log in, the German layout is working but reverts back to the English layout straight away. So some setting change is not filtering its way through the whole system. The only thing that works is setxkbmap de but this doesn't survive a reboot.

Any clue what I'm missing/text file I need to edit? I'm running Bunsen Lithium (Deb 10.6, 4.19.0-12-amd64) and the keyboard is a Logitech G513 Carbon but I doubt that's terribly relevant.

Last edited by corey.taylor (2021-04-01 18:34:41)

Offline

#2 2021-04-06 21:08:23

ohnonot
...again
Registered: 2015-09-29
Posts: 5,568

Re: Making a keyboard layout stay

The easiest way is to add

setxkbmap de

to your bunsen autostart file, and make sure that no other keyboard layout manipulating directives are present there.


Give to COVAX! Here or here. (explanation)
My Repos: notabug | framagit

Offline

#3 2021-04-11 17:31:12

AndrewSmart
Member
Registered: 2019-06-10
Posts: 29

Re: Making a keyboard layout stay

corey.taylor wrote:

The odd part is that when I log in, the German layout is working but reverts back to the English layout straight away. So some setting change is not filtering its way through the whole system. The only thing that works is setxkbmap de but this doesn't survive a reboot.

Any clue what I'm missing/text file I need to edit?

I have a vague recollection of also experiencing this. I think I also wasn't able to figure out where it was being set. I think I had also tried editing that file you mentioned, which didn't work as expected after logging in somewhere/somehow. I don't recall where, maybe it was lightdm, a virtual console, or both. I use the Programmer Dvorak keyboard layout.

I think that this worked around the problem, setting these kernel parameters in grub.cfg:

$ cat /proc/cmdline 
BOOT_IMAGE=(hd0,gpt1)/live/vmlinuz-4.19.0-13-amd64 boot=live config quiet noeject toram keyboard-layouts=us,us keyboard-variants=dvp,

Again, I'm very fuzzy on the memory working backwards from why I did this.

Last edited by AndrewSmart (2021-04-11 20:47:55)

Offline

Board footer

Powered by FluxBB