You are not logged in.

#1 2018-12-24 14:16:40

sikrion
New Member
Registered: 2018-12-24
Posts: 1

loud popping when changing audio source

New clean install of BunsenLabs. Got audio set up and working but I have one issue,

Changing the source of the audio (i.e. spotify to browser or to game) causes a popping sound as if the audio is turning itself off and on again.

It seems to be related to a powersaving setting based on my searches but I couldn't find a fix for it.

-------

Bonus question:
Mute and volume keys work fine but my play stop skip keys dont [Keyboard], how can I add these hotkeys to pn mixer? The volume and mute buttons were already there.
XF86AudioPlay

Offline

#2 2021-02-23 21:16:45

christopherisnow
Member
Registered: 2018-05-19
Posts: 47

Re: loud popping when changing audio source

Did you ever fix this loud popping problem? I have the same problem after a Helium install on a ThinkPad x270.

Offline

#3 2021-02-24 03:04:18

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,034
Website

Re: loud popping when changing audio source

If it's an intel sound card it might be this issue: https://brontosaurusrex.github.io/2019/ … nd-clicks/


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#4 2021-02-24 10:18:07

christopherisnow
Member
Registered: 2018-05-19
Posts: 47

Re: loud popping when changing audio source

Indeed it is an intel sound card. In the meantime I found an even easier solution -- just open `/etc/pulse/default.pa` and comment out this line:

load-module module-suspend-on-idle

Props to https://bbs.archlinux.org/viewtopic.php?id=223064

Offline

Board footer

Powered by FluxBB