You are not logged in.

#1 2020-12-30 04:14:29

Eon
Member
From: Earth
Registered: 2015-09-29
Posts: 76

[SOLVED] How to prevent maximised windows to overlap tint2 area?

So, whenever I maximise an application window, the windows also intrudes the tint2 area? At first it used to go below tint2 but after some research on internet and reading tint2 docs, I found 2 settings which now makes maximised windows go over tint2 overlapping it:

strut_policy = follow_size
panel_layer = bottom

This is how it looks like when maximised:
JPGIUzDt.png

also I don't understand why there's a padding on right side of window where maximised window wouldn't even go even if I try to drag them over there:
q8jHMFTt.png

anyone know how do I prevent maximised windows from going over or below tint2 panel? Here's my tint2rc:

#-------------------------------------
# Panel
panel_items = PTSCB
panel_size = 100% 30
panel_margin = 0 0
panel_padding = 6 0 0
panel_background_id = 1
wm_menu = 1
panel_dock = 0
panel_position = left center vertical
panel_layer = top
panel_monitor = 1
panel_shrink = 0
# reserve_space = 1
autohide = 0
autohide_show_timeout = 0.3
autohide_hide_timeout = 1.5
autohide_height = 3
strut_policy = follow_size
panel_window_name = tint2
disable_transparency = 0
# enable mouse_hover
mouse_effects = 1
font_shadow = 1
mouse_hover_icon_asb = 100 0 10
mouse_pressed_icon_asb = 100 0 0
scale_relative_to_dpi = 0
scale_relative_to_screen_height = 0

Last edited by Eon (2020-12-30 13:27:37)

Offline

#2 2020-12-30 12:26:49

MALsPa
Member
From: albuquerque
Registered: 2016-06-20
Posts: 214

Re: [SOLVED] How to prevent maximised windows to overlap tint2 area?

Hm, I can't quite figure out what the problem is. My maximized windows don't overlap the tint2 panel -- they simply open up to share an edge with the panel like they're supposed to. Panel settings from my tint2rc:

# Panel
panel_monitor = all
panel_position = top left vertical
panel_items = CTLSB
panel_size = 60% 60
panel_margin = 0 0
panel_padding = 0 0
panel_dock = 0
wm_menu = 1
panel_layer = bottom
panel_background_id = 1

# Panel Autohide
autohide = 0
autohide_show_timeout = 0.3
autohide_hide_timeout = 2
autohide_height = 2
strut_policy = follow_size

Offline

#3 2020-12-30 13:20:50

Eon
Member
From: Earth
Registered: 2015-09-29
Posts: 76

Re: [SOLVED] How to prevent maximised windows to overlap tint2 area?

MALsPa wrote:

Hm, I can't quite figure out what the problem is. My maximized windows don't overlap the tint2 panel -- they simply open up to share an edge with the panel like they're supposed to. ...

I replaced it with your settings and it got magically fixed lol. idk how but many thanks. <3

Offline

#4 2020-12-30 15:51:54

damo
....moderator....
Registered: 2015-08-20
Posts: 6,498

Re: [SOLVED] How to prevent maximised windows to overlap tint2 area?

Possibly it was the position order in your code. From man tint2

• panel_position = vertical_position horizontal_position orientation

You had

panel_position = left center vertical

Try

panel_position = center left vertical

Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

Board footer

Powered by FluxBB