You are not logged in.

#1 2020-12-15 10:54:31

anon66
New Member
Registered: 2020-12-15
Posts: 1

Nvidia Geforce GT 1030 drivers for Lithium?

Hi!

When running Debian 10 - Buster there was acctuly no problems installing the drivers for Nvidia 1030. But in Bunsenlabs the same drivers wont work.

Is there someone how can help me?

I realy like the look and the feeling of Bunsenlabs, but i would like for the drivers for the graphics card to work.

Maby someone can give me a instruction for the exact terminal commands to run?

Best regards

Offline

#2 2020-12-15 12:24:20

damo
....moderator....
Registered: 2015-08-20
Posts: 6,498

Re: Nvidia Geforce GT 1030 drivers for Lithium?

How do you know the driver doesn't work? Is it installed and running instead of nouveau?

Anyway, install and run nvidia-detect, then install the recommended driver.

sudo apt-get install nvidia-detect

Here is the output I get when running it:

$ nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM204M [GeForce GTX 970M] [10de:1618] (rev ff)

Checking card:  NVIDIA Corporation GM204M [GeForce GTX 970M] (rev ff)
Your card is supported by the default drivers and legacy driver series 390.
It is recommended to install the
    nvidia-driver
package.

Then do

sudo apt-get install nvidia-driver

Follow any on-screen prompts to set it up and run instead of nouveau.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2020-12-15 12:31:36

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 912

Re: Nvidia Geforce GT 1030 drivers for Lithium?

anon66 wrote:

When running Debian 10 - Buster there was acctuly no problems installing the drivers for Nvidia 1030. But in Bunsenlabs the same drivers wont work.

What drivers worked in Buster but not in Lithium?Was there som more difference maybe?

Acording to this old link: http://phoronix.com/scan.php?page=news_ … ux-Drivers, you need to install Nvidias proprietory drivers.

Often when using drivers from debian repo, is it nessesary to use non fre backported drivers.

Last edited by rbh (2020-12-15 12:33:55)


// Regards rbh

Offline

Board footer

Powered by FluxBB