You are not logged in.

#1 2020-08-25 16:32:26

angryjenkins
Member
Registered: 2020-05-13
Posts: 7

Lithium bl-welcome error - 'This script should be run only on Buster'

Hello all!

I've been running Lithium RC3 on my minipc for awhile now. Love it.

I am lending a laptop to a friend, so I spent last night shifting drives among my active laptops and installing Windows (bleh) on the loaner. This left me with one Dell Latitude laptop with no OS on it and I decided to install a fresh download of Lithium.

Everything is running fine so far EXCEPT one weird issue - I noticed on first boot the 'bl-welcome' script did not run. When I type 'bl-welcome' in the terminal I get this error:

Error: This script should be run only on Debian Buster.

`uname -a` returns among other things ... Debian 4.19.132-1 (2020-07-24) ...

'lsb_release -cs' returns 'lithium'

I was able to run 'bunsen-meta-bluetooth' as well as 'bunsen-meta-printer-support' to get bluetooth audio and wifi printing working, but the bl-welcome script won't run. Any idea what would prevent? I am open to re-installs with different methods as I only set the laptop up yesterday.

Some troubleshooting I did - my desktop PC runs Ubuntu 20.04, I used this system to create the Lithium Live USB. The first time, I used the ubuntu 'startup disk creator' app. Thinking this may have been the issue, I remade the startup disk with dd and reinstalled - still getting the same error.

Thanks!

Offline

#2 2020-08-25 16:42:28

damo
....moderator....
Registered: 2015-08-20
Posts: 6,406

Re: Lithium bl-welcome error - 'This script should be run only on Buster'

I now see the same thing - I bet this is a regression after the recent bugfix for bunsen-os-release.

We will have to wait until @twoion sees this...


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#3 2020-08-25 16:55:54

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,035

Re: Lithium bl-welcome error - 'This script should be run only on Buster'

I tested it and see the same error.


Real Men Use Linux

Offline

#4 2020-08-25 19:33:59

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 758

Re: Lithium bl-welcome error - 'This script should be run only on Buster'

Run bl-welcome on two productive machines. Got error:

This script is not meant to be run in a live session.

It is not a live session, but live tools is installed...

Loged in to the file server. Ok tu run bl-welcome. For some reason bunsen-os-release, was not installed...

Started a vm. bunsen-os-release old version. Run Bl-welcome and after that, with new bunsen-os-release, got the error message:

Error: This script should be run only on Debian Buster.

So, yes it is confirmed.

Last edited by rbh (2020-08-25 19:34:49)


// Regards rbh

Offline

#5 2020-08-26 02:40:17

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,419
Website

Re: Lithium bl-welcome error - 'This script should be run only on Buster'

@damo started a bug report for the "only on Debian Buster" error here:
https://forums.bunsenlabs.org/viewtopic.php?id=6935

And I've just started one for the "live session" error:
https://forums.bunsenlabs.org/viewtopic.php?id=6936

Any help or comments on either issue will be most welcome. smile


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Online

#6 2020-08-30 21:25:33

twoion
ほやほや
Registered: 2015-08-10
Posts: 3,027

Re: Lithium bl-welcome error - 'This script should be run only on Buster'

johnraff wrote:

@damo started a bug report for the "only on Debian Buster" error here:
https://forums.bunsenlabs.org/viewtopic.php?id=6935

And I've just started one for the "live session" error:
https://forums.bunsenlabs.org/viewtopic.php?id=6936

Any help or comments on either issue will be most welcome. smile

The problem of the change I introduced was that lsb_release -sc started correctly outputting "lithium" after I added the VERSION_CODENAME key to the os-release file from which lsb_release now derives its information. This breaks our checks in bl-welcome and possibly things in other places. I've reverted that change and pushed an update removing the key again so that'll be fixed. The fix for bl-welcome regarding the live session detection is still open and separate from this.


Per aspera ad astra.

Online

Board footer

Powered by FluxBB