You are not logged in.

#1 2015-12-02 18:06:49

vorwart
Member
Registered: 2015-11-03
Posts: 14

[SOLVED] Authentication required to mount secondary drives, Grrr !

Can someone help me return to the the old behavior of auto-mounting external & secondary drives at startup? Or at least automount on demand without needing to type in my password? It's very inconvenient to say the least. Thanks in advance.

Last edited by vorwart (2015-12-03 01:03:21)

Offline

#2 2015-12-02 21:38:45

ohnonot
...again
Registered: 2015-09-29
Posts: 5,568

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

works here.
what have you done since installing bunsenlabs?
do you still have the lines with gnome-keyring and polkit in your autostart?


Give to COVAX! Here or here. (explanation)
My Repos: notabug | framagit

Offline

#3 2015-12-02 21:39:58

pvsage
Internal Affairs
Registered: 2015-09-29
Posts: 1,433

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

@vorwart:  This is relatively new in debian and has to do with the polkits used by systemd vs sysvinit.  You can add the volumes to your /etc/fstab if you want them auto-mounted.  You'll only want to do this with permanently-connected volumes.

Are hot-plugged volumes (thumbdrives etc.) still being automatically mounted without authentication?

Last edited by pvsage (2015-12-02 21:40:32)


Be excellent to each other, and...party on, dudes!
BunsenLabs Forum Rules
Tending and defending the Flame since 2009

Offline

#4 2015-12-02 22:33:41

vorwart
Member
Registered: 2015-11-03
Posts: 14

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

It's a fresh install of BLRC1 on a T61 Thinkpad. All drives, both secondary (my /data partition or others) & external (usb) are requiring authentication.

I haven't changed anything. Autostart is showing:
______________________________________________________________
## GNOME PolicyKit and Keyring
eval $(gnome-keyring-daemon -s --components=pkcs11,secrets,ssh,gpg) &

## for authentication
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &
______________________________________________________________

So, in sum, everything is asking for authentication right from a fresh install. I've set my /data to automount, but it's still a big inconvenience to need a password just to mount a thumbdive or access other partitions. I appreciate your insights here.

Offline

#5 2015-12-02 22:57:56

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,841

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

Shot in the dark as this is not one of my strong points:

http://crunchbang.org/forums/viewtopic. … 43#p376843

On my BL RC1:

/etc/polkit-1/localauthority/50-local.d/10-udisks.pkla

[Local Users]
Identity=unix-group:*
Action=org.freedesktop.udisks2.*
ResultAny=no
ResultInactive=no
ResultActive=yes

Do you have that?

Also, are "thunar-volman", "udev" and "udisks2" installed?


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#6 2015-12-03 01:00:19

vorwart
Member
Registered: 2015-11-03
Posts: 14

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

Sector11, "thunar-volman", "udev" and "udisks2" are installed.

I did not have that file: /etc/polkit-1/localauthority/50-local.d/ was empty. Is that not odd?

After creating that file, everything concerning automounting drives seems to be "normal".

Thank you very much.

Offline

#7 2015-12-03 01:25:07

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,841

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

Edited it to read: thunar-volman

I read your opening post ... I had the same problem in the past so I went searching.  And my thread and it posted in 'hopes' it would help.

So glad I did, and you are welcome.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#8 2015-12-03 01:31:26

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,057

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

Mine was missing as well. Fortunately I have a version of the one I use backed up so I was able to copy it in and get stuff working again.

Offline

#9 2015-12-03 02:47:27

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,841

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

Two  smile  smile are better than one.  Made my day.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#10 2015-12-03 07:41:16

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

Props Sector11!
cool

This thread is bookmarked for future reference -- I didn't know that .pkla stuff smile


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#11 2015-12-03 12:43:43

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,841

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

Thanks but I can't take the credit ... as seen in the other thread.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#12 2015-12-04 01:56:29

dhalgren
Member
Registered: 2015-10-01
Posts: 101

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

I have not that problem, in that any device mounts when plugged in, but, irritatingly, I have to open it as root in order to write to it.

Does anyone have a solution to this?

Offline

#13 2015-12-04 06:01:49

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,424
Website

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

That /etc/polkit-1/localauthority/50-local.d/10-udisks.pkla was present on #! Waldorf (referring to udisks instead of udisks2) but we don't install it on BL at the moment. It looks as though we should put it in - maybe in bunsen-configs?

Discussion with pvsage about default permissions for drives and plugin devices on the "Wally" thread, eg
http://crunchbang.org/forums/viewtopic. … 11#p419111
http://crunchbang.org/forums/viewtopic. … 78#p419578
http://crunchbang.org/forums/viewtopic. … 84#p419584
http://crunchbang.org/forums/viewtopic. … 82#p419982
and on to post 205.
Then start here: http://crunchbang.org/forums/viewtopic. … 62#p420462
and check posts following.

We could think about offering options in bl-welcome (password or not) or just set more restrictive permissions on laptops...

EDIT perhaps BL settings should go in 10-vendor.d instead of 50-local.d? http://www.freedesktop.org/software/pol … ity.8.html

Last edited by johnraff (2015-12-04 08:02:45)


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#14 2015-12-04 14:51:26

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,057

Re: [SOLVED] Authentication required to mount secondary drives, Grrr !

This is the polkit file that I use. I usually name it auto-mount.plka and stick it in /etc/polkit-1/50-local.d, though the name doesn't really matter. This allows for mounting, unmounting and ejecting media without running too loose restrictions on other stuff.

[Allow Automount]
Identity=unix-group:plugdev
Action=org.freedesktop.udisks2.filesystem-mount*
ResultAny=yes
ResultInactive=yes
ResultActive=yes
[Allow Eject]
Identity=unix-group:plugdev
Action=org.freedesktop.udisks2.eject-media*
ResultAny=yes
ResultInactive=yes
ResultActive=yes
[Allow Unmount]
Identity=unix-group:plugdev
Action=org.freedesktop.udisks2.filesystem-unmount*
ResultAny=yes
ResultInactive=yes
ResultActive=yes

The full list can be found in /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy. Not everything in this list is something I would be comfortable running out of an administrator context, so I use a bit more restrictive rules than simply enabling it all.

Offline

Board footer

Powered by FluxBB