You are not logged in.

#1 2020-04-12 08:58:02

ZurAz
New Member
Registered: 2020-04-02
Posts: 4

minimal bugs so far

When I start the system the login interface is not displayed, all I can see is the pointer on a gray colored screen, what I have to do is to push the mouse’s left button or  discovered also that when pushing F10 function key then the login is shown, so it happens when I lock the computer.

Other bug is with the numerical keypad, when from booting the system this keypad does not work, when I push any key from it (part of my pass is numbers), it’s heard a sound similar in cases like when you push any key on a specific interface and is an invalid function at that moment, in this case I just turn off with the Bloq Num key (that one does work) and turn on back and then it works, that also happens after blocking the screen. The number keys which are above the main typing keys do work with no problem, the keyboard is an Argon ARG-KB-7414.

Tank you for any help.


4x Intel(R) Atom(TM) CPU D525 @ 1.80GHz

Memory
4040MB (875MB used)
Operating System
BunsenLabs GNU/Linux 9.8 (Helium)
User Name
laboratory3 (Laboratory3)
Date/Time
Sun 12 Apr 2020 02:48:37 AM CST
Display
Resolution
1366x768 pixels
OpenGL Renderer
Mesa DRI Intel(R) Pineview
X11 Vendor
The X.Org Foundation
Multimedia
Audio Adapter
HDA-Intel - HDA Intel
Audio Adapter
USB-Audio - USB Device 0x46d
Audio Adapter
USB-Audio - Plantronics C325-M

Last edited by ZurAz (2020-04-12 08:59:55)

Offline

#2 2020-04-12 09:27:09

damo
....moderator....
Registered: 2015-08-20
Posts: 5,988

Re: minimal bugs so far

You can't use the numpad because your system hasn't enabled it at boot. If you don't have a bios setting for it, then try this solution:

Install numlockx:

sudo apt-get install numlockx

Then edit /usr/share/lightdm/lightdm.conf.d/01_debian.conf...

sudo nano /usr/share/lightdm/lightdm.conf.d/01_debian.conf

and add

greeter-setup-script=/usr/bin/numlockx on

Ctrl-O to save, then restart.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2020-04-12 09:51:19

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 407

Re: minimal bugs so far

ZurAz wrote:

When I start the system the login interface is not displayed, all I can see is the pointer on a gray colored screen, what I have to do is to [...]

Is it a new installation? It has newer worked as thought for you? I think it is some misconfigurtion, not a bug. I've newer encounted that on physical BL, but on misconfigured VNC-clients... I dont have any Helium installation left. SomeOne migt help you track down the rigt settings.

Other bug is with the numerical keypad, when from booting the system this keypad does not work,[...] The number keys which are above the main typing keys do work with no problem,

"Num lock" is a user config. Should not be set to on as default! Many bios, has a setting for that. Could also be set by software, lika "Caps Lock" on and so on. If it was on as default, people using laptops, were Num pad is part of regular keys, it would be difficult to login...

Here is a thread: Helium: enable numlock at boot
Probably there is other solutions too.


// Regards rbh

Offline

#4 2020-04-12 10:55:12

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 407

Re: minimal bugs so far

I forgot: To set numlock on, to be effective before login, you have to edit /etc/lightdm/lightdm.conf:

[Seat:*]
greeter-setup-script=/usr/bin/numlockx on

https://wiki.archlinux.org/index.php/Li … by_default


// Regards rbh

Offline

Board footer

Powered by FluxBB