You are not logged in.

#1 2016-01-06 13:28:06

New Member
Registered: 2016-01-06
Posts: 1

HP 2133 Only Works When Wi-Fi is Disabled.

I have a 14e4:4315 (rev 01) BroadCom 4312 on this machine. When I first installed using the basic way, everything worked out-of-box. But the minute I boot everything up and go to see the log-in screen, unless I turn of my Wi-Fi off immediately, everything freezes. I even tried this in recovery mode and still the same issue. I can connect to Ethernet but that would render the netbook useless for portability. The house has a WPA2 key on the router that I rather not change or else that would cause problems with the owner of the router. I tried searching for this problem and have tried many OSes but I would prefer to use this OS because of the lightweight design. Any help is appreciated


#2 2016-01-06 13:59:49

From: London
Registered: 2015-09-29
Posts: 8,759

Re: HP 2133 Only Works When Wi-Fi is Disabled.

Hello & welcome smile

According to the Debian wiki, you should be using the wl driver.

You can check which driver is in use with:

lspci -k|grep -iA2 net

As for your freezing problem, can we see the output of:

dmesg|egrep 'wl|firmw|dhc'

When you say that the system "freezes", can you switch to a console screen (TTY) with <Ctrl>+<Alt>+F2?

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks


Board footer

Powered by FluxBB