You are not logged in.

#1 2015-09-30 21:25:15

timoskouros
New Member
Registered: 2015-09-30
Posts: 4

Problem with soundcard

Hello all.Im using a USB soundcard (Focusrite scarlet 2i2) and when I go to Preferences by right clicking on the speaker on the right top corner, I dont see my soundcard, only PCH.

When I open VLC, at settings I can choose what card to use.
I have founded a way to fix it by going somewhere at some settings but I dont remember how I went there and I cant find it now.I restarted my PC and then the change on the setting I did was gone.

Any help ? smile

Offline

#2 2015-09-30 21:50:08

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problem with soundcard

Hello & welcome to BunsenLabs smile

You can try installing and using pavucontrol to set the default output device.

Details here:
http://crunchbang.org/forums/viewtopic. … 53#p435553


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2015-09-30 23:02:47

timoskouros
New Member
Registered: 2015-09-30
Posts: 4

Re: Problem with soundcard

Well, I still have the same problem.

When I go to the configuration tab it shows me 4 devices.
The first one is Cedar HDMI Audio which I want to set it off.

The next is my soundcard that I want to use, but the profile is at Analog Stereo Duplex.I have to set it to Analog Stereo Output to hear sound.

But in order to hear sound I have to set the profile of Built-in audio to Off.

Is there anyway to make those settings I did permament ?

Offline

#4 2015-10-01 01:27:17

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: Problem with soundcard

Do you have a sound icon on your tint2 bar? If not, check ~/.xsession-errors for something like this:

volumeicon: alsa_backend.c:86: asound_get_volume: Assertion `m_elem != ((void *)0)' failed.

I honestly don't remember which volume icon is the default for BL any more as we have been back and forth on it so many times.
Also you might try:

sudo alsactl init

and see if that gets things working

Offline

#5 2015-10-01 01:31:37

timoskouros
New Member
Registered: 2015-09-30
Posts: 4

Re: Problem with soundcard

Yes I have the icon and everything.I just need to save the changes I've made.

Offline

#6 2015-10-01 05:23:58

timoskouros
New Member
Registered: 2015-09-30
Posts: 4

Re: Problem with soundcard

And an other problem I have is that i change my resolution to maximum and I disable my second monitor.
After restart, the settings are going back hmm

Offline

#7 2015-10-01 06:47:07

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problem with soundcard

timoskouros wrote:

I just need to save the changes I've made.

Whenever I use pavucontrol, the settings are persistent between boots hmm

Are you running in the live environment?

You could try:

sudo alsactl store
timoskouros wrote:

And an other problem I have is that i change my resolution to maximum and I disable my second monitor.
After restart, the settings are going back

Please open a new thread for this problem (be sure to use a descriptive title).


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#8 2015-10-02 16:12:49

synkka_maan
New Member
Registered: 2015-10-02
Posts: 4

Re: Problem with soundcard

If you have Alsa installed try running the command,
aplay -l

If the soundcard isn't coming up, here is what worked for me, for my onboard soundcard, but you may have to modprobe a different file,
sudo modprobe snd-hda-intel

Offline

#9 2015-10-02 16:13:59

synkka_maan
New Member
Registered: 2015-10-02
Posts: 4

Re: Problem with soundcard

If the soundcard does come up with aplay -l,
Pull up the Volume Control Preferences, and see if you can find the correct Port listed in Output Devices.

Offline

Board footer

Powered by FluxBB