You are not logged in.

#1 2022-01-23 04:18:53

hhh
Colonel Robert Neville
From: That honky paradise, brother.
Registered: 2015-09-17
Posts: 13,069
Website

Disable Overlay (hidden) Scrollbars

Posting this for posterity because it's actually tricky to find the simple solution online.

In ~/.confif/gtk-3.0/settings.ini, add this to the bottom of the file, save it, and logout...

gtk-overlay-scrolling=false

Whoever approved the idea of partially hiding the scrollbars by default is, well, I won't say.

---
There is also the option to set specific parameters for the scrollbar in ~/.config/gtk-3.0/gtk.css (create it if needed). This works for the theme I'm using, and is much more usable than the default narrow and hidden scrollbar...

scrollbar, scrollbar button, scrollbar slider {
    -GtkScrollbar-has-backward-stepper: true;
    -GtkScrollbar-has-forward-stepper: true;
    min-width: 8px;
    min-height: 32px;
    border-radius: 10;
}

CSMSCgCt.png

Last edited by johnraff (2022-01-24 08:10:18)


You know, you used to be a nice guy once.

Offline

#2 2022-01-23 04:55:09

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,959
Website

Re: Disable Overlay (hidden) Scrollbars

Was also wondering about this.
https://wiki.archlinux.org/title/GTK#Di … scrollbars

Alternative method is to add this to ~/.xsessionrc or ~/.config/bunsen/environment:

# Disable overlay scrollbars
export GTK_OVERLAY_SCROLLING=0

Last edited by johnraff (2022-01-24 08:09:04)


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Online

Board footer

Powered by FluxBB