You are not logged in.

#1 2015-12-01 23:03:01

Pouletic
Member
Registered: 2015-10-25
Posts: 18

3d acceleration and xorg.conf

Good evening my fellow bunsen burners. I'm wondering about the 3d acceleration set up by the installer. I have an AMD video card (god help me) and realized when i fired up UT2004 from an old drive today that i was getting 10 fps... with an 11 year old game!

There is a mesa driver and i checked that the proprietary blob was installed, etc, from here:
https://wiki.debian.org/AtiHowTo

One thing that has me puzzled, though, is that i apparently have no xorg.conf file, or at least there's not anything in /usr/share/X11/xorg.conf.d that defines a screen or graphics card. As a result, i'm not sure where/how to tweak.

There's of course the proprietary driver, but i want to see what i can get out of the OSS driver before going that route.

Can anyone please give me an idea how to procede?

PS Hearthstone and Starcraft2 both work in wine but i get a bit woozy trying to play with the low framerate.

Last edited by Pouletic (2015-12-01 23:06:59)

Offline

#2 2015-12-02 07:33:44

ohnonot
...again
Registered: 2015-09-29
Posts: 3,909
Website

Re: 3d acceleration and xorg.conf

are you sure Xorg actually uses the proprietary driver?
have a look at

lspci -k|grep -iA5 -E 'vga|3d'

to literally answer your question, you can create a config file in /etc/X11/xorg.conf.d (not /usr/share).

and the debian wiki you linked is for the open source driver.
see here instead: https://wiki.archlinux.org/index.php/AMD_Catalyst

Offline

#3 2015-12-02 07:42:26

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: 3d acceleration and xorg.conf

The non-proprietary driver should be just fine -- I prefer it on my AMD laptop as it uses much less memory and is more stable.

You should not need an xorg.conf unless you wish to tune the driver.

Please also post the output of:

apt-cache policy firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati
grep -R blacklist /etc/modprobe.d

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#4 2015-12-02 14:03:45

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: 3d acceleration and xorg.conf

If using the ATI proprietary driver you can do

sudo aticonfig --initial

to setup an xorg.conf file for you.

Offline

#5 2015-12-02 18:10:56

Pouletic
Member
Registered: 2015-10-25
Posts: 18

Re: 3d acceleration and xorg.conf

ohnonot wrote:

are you sure Xorg actually uses the proprietary driver?
have a look at

lspci -k|grep -iA5 -E 'vga|3d'

to literally answer your question, you can create a config file in /etc/X11/xorg.conf.d (not /usr/share).

and the debian wiki you linked is for the open source driver.
see here instead: https://wiki.archlinux.org/index.php/AMD_Catalyst

$ lspci -k|grep -iA5 -E 'vga|3d'
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks PRO [Radeon HD 6570/7570/8550]
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 2502
	Kernel driver in use: radeon

Sorry i meant i could always resort to that if i can't get decent performance with the open source, which is what it's using.

I have no xorg.conf.d directory in /etc/X11, but in /usr/share/X11 there's an xorg.conf.d with several files (dealing with input devices, mostly:
10-evdev.conf  10-quirks.conf  50-synaptics.conf  50-vmmouse.conf), but none of them define a monitor or gpu. Is this location dependent on graphics driver? I would expect all BL installations to have the X11 configuration files in the same location...

So i added 30-3d_accel to the above directory with the suggested tweaks from the debian wiki.

Section "Device"
 Driver "radeon"
 Identifier "My GPU"
 Option "AccelMethod" "XAA"
 # XAA/EXA
 Option "AccelDFS"    "1"
 # 1/0 On for PCIE, off for AGP
 # Manpage: Use  or  don't  use accelerated EXA DownloadFromScreen hook
 # when possible.
 Option "GARTSize" "64"
 # 0-64 Megabytes of gart (system) memory used.
 # Wrongly defaults to 8MB sometimes, see your logfile.
 # Bigger seems better.
 Option "EnablePageFlip" "1"
 # 1/0 Increases 3D performance substantially
 # seemingly in XAA mode only
 Option "ColorTiling" "1"
 # 1/0 Increases 3D performance substantially
 # affected stability only positively on my system
EndSection

I don't even know if this is doing anything but my gfx performance has improved. One thing i did notice is this message in the log:
*ERROR* rv770_set_sw_state failed
A search brought up cases where this was leading to decreased 3d performance after a standby, so maybe my improved performance is from a reboot.

Still investigating...


ETA:

pouletic@llanobox:/usr/share/X11/xorg.conf.d$ apt-cache policy firmware-linux-nonfree libgl1-mesa-dri xserver-xorg-video-ati
firmware-linux-nonfree:
  Installed: 0.43
  Candidate: 0.43
  Version table:
 *** 0.43 0
        500 [url]http://httpredir.debian.org/debian/[/url] jessie/non-free amd64 Packages
        100 /var/lib/dpkg/status
libgl1-mesa-dri:
  Installed: 10.3.2-1+deb8u1
  Candidate: 10.3.2-1+deb8u1
  Version table:
 *** 10.3.2-1+deb8u1 0
        500 [url]http://httpredir.debian.org/debian/[/url] jessie/main amd64 Packages
        100 /var/lib/dpkg/status
xserver-xorg-video-ati:
  Installed: 1:7.5.0-1
  Candidate: 1:7.5.0-1
  Version table:
 *** 1:7.5.0-1 0
        500 [url]http://httpredir.debian.org/debian/[/url] jessie/main amd64 Packages
        100 /var/lib/dpkg/status


grep -R blacklist /etc/modprobe.d
/etc/modprobe.d/amd64-microcode-blacklist.conf:blacklist microcode
/etc/modprobe.d/fbdev-blacklist.conf:# This file blacklists most old-style PCI framebuffer drivers.
/etc/modprobe.d/fbdev-blacklist.conf:blacklist arkfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist aty128fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist atyfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist radeonfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist cirrusfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist cyber2000fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist kyrofb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist matroxfb_base
/etc/modprobe.d/fbdev-blacklist.conf:blacklist mb862xxfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist neofb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist pm2fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist pm3fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist s3fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist savagefb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist sisfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist tdfxfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist tridentfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist vt8623fb
/etc/modprobe.d/intel-microcode-blacklist.conf:blacklist microcode

Last edited by Pouletic (2015-12-02 18:25:05)

Offline

#6 2015-12-02 21:23:20

ohnonot
...again
Registered: 2015-09-29
Posts: 3,909
Website

Re: 3d acceleration and xorg.conf

Xorg is indeed reading config files from /usr/share/X11: https://wiki.archlinux.org/index.php/Xorg#Configuration
however it is not recommended practice to put your config there.

Offline

#7 2015-12-02 21:50:39

Pouletic
Member
Registered: 2015-10-25
Posts: 18

Re: 3d acceleration and xorg.conf

ohnonot wrote:

Xorg is indeed reading config files from /usr/share/X11: https://wiki.archlinux.org/index.php/Xorg#Configuration
however it is not recommended practice to put your config there.

Okay. Should i submit that as a bug report for bl installation?


ETA: Back to super-slow 3d acceleration. Will try rebooting to see if it resolves temporarily again.

Last edited by Pouletic (2015-12-02 21:53:33)

Offline

#8 2015-12-02 22:01:00

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: 3d acceleration and xorg.conf

Pouletic wrote:
ohnonot wrote:

Xorg is indeed reading config files from /usr/share/X11: https://wiki.archlinux.org/index.php/Xorg#Configuration
however it is not recommended practice to put your config there.

Okay. Should i submit that as a bug report for bl installation?

No, the locations are all correct.

The X server auto-configures these days so any overrides are kept in $BLAH/xorg.conf.d in numbered files.

/usr/share/X11 is for the files supplied by packages (these should not be modified as they may be overwritten on updates) and /etc/X11 is for general system administration.

See xorg.conf(5)


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#9 2015-12-02 22:59:02

Pouletic
Member
Registered: 2015-10-25
Posts: 18

Re: 3d acceleration and xorg.conf

Head_on_a_Stick wrote:
Pouletic wrote:
ohnonot wrote:

Xorg is indeed reading config files from /usr/share/X11: https://wiki.archlinux.org/index.php/Xorg#Configuration
however it is not recommended practice to put your config there.

Okay. Should i submit that as a bug report for bl installation?

No, the locations are all correct.

The X server auto-configures these days so any overrides are kept in $BLAH/xorg.conf.d in numbered files.

/usr/share/X11 is for the files supplied by packages (these should not be modified as they may be overwritten on updates) and /etc/X11 is for general system administration.

See xorg.conf(5)

Okay i get it now, thanks. I moved my file to /etc/X11/.

So i've intermittently been getting no video output (requiring a hard reset) when starting 3D games since i installed BL. It just happened several more times and then i tried disabling compositing before starting one up and it worked. I had turned off compositing the other day thinking that would help but i didn't realize that it turns itself back on until i noticed the transparency in the conky window. So, it may be the compositor causing the huge hit on framerate. Is it normal for it to cause such a heavy load on the GPU?

Last edited by Pouletic (2015-12-02 23:00:03)

Offline

#10 2015-12-02 23:05:37

damo
....moderator....
Registered: 2015-08-20
Posts: 5,057

Re: 3d acceleration and xorg.conf

Do a search for compton settings (`man compton` to start with) - you might find a good setup for your system.

The compositor is started with `bl-compositor` in your autostart, so no wonder it started up again. Comment out the line if you want to only start/stop it manually.


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#11 2015-12-04 03:56:39

ohnonot
...again
Registered: 2015-09-29
Posts: 3,909
Website

Re: 3d acceleration and xorg.conf

Pouletic wrote:

may be the compositor causing the huge hit on framerate. Is it normal for it to cause such a heavy load on the GPU?

it is normal to have some inpact on graphics performance, but not huge.
i'm not sure about your hardware specs; on older systems and/or improper functioning 3d accel, the impact could be critical.
maybe you should reconsider using the proprietary driver; at least on nvidia that is the alround-solution.

Offline

Board footer

Powered by FluxBB