You are not logged in.

#1 2015-11-29 04:31:02

stevo1977
New Member
From: Pacific NW
Registered: 2015-11-29
Posts: 2

Switching runlevel to use smxi fails

Greetings!

I have been using the latest Bunsen for almost a week now, and have been very pleased; pretty seamless transition from #!. Makes my old Macbook 5.1 usable again, which is great!

So my problem is two-fold: when I shut the lid, the computer suspends, but when I open the lid, even though the computer wakes up, the display never does.

To address this, I attempted to the smxi script to update the video drivers. Unfortunately, I am unable to exit my x-session successfully. If I switch to super-user and attempt to run smxi, it prompts me to "shutdown-your-desktop". When I do this, the screen briefly goes blank, and then the cursor blinks in the upper-left corner indefinitely.

If instead I run "sudo init 3" from the terminal, the same thing happens: the screen briefly goes blank, then the cursor blinks in the upper-left corner indefinitely.

Any idea what's preventing me from exiting my session successfully? Thanks!

Cheers,
stevo


Bunsen Hydrogen
Debian 8 (64bit)
Kernel: 3.16.0-4
Macbook 5.1

Offline

#2 2015-11-29 04:45:39

twoion
一期一会
Registered: 2015-08-10
Posts: 3,317

Re: Switching runlevel to use smxi fails

You switch to a tty (ctrl+alt+f1), log in as root and run htop as well as inspect the syslog and logfile of the display manager.

Are you using systemd or sysvinit? In Debian, runlevels 2 through 5 are by default equivalent to each other.

Instead of switching runlevels, try stopping the display manager service:

service stop xdm # sysvinit
systemctl stop xdm.service # systemd

Of course, you need to replace `xdm` with the display manager service that is running on your system, for example `lightdm` (and systemd) is the default in BL.

Offline

#3 2015-11-29 06:04:37

stevo1977
New Member
From: Pacific NW
Registered: 2015-11-29
Posts: 2

Re: Switching runlevel to use smxi fails

Thanks for the quick response!

I'm running systemd. I tried stopping the display manager, like so:

sudo systemctl stop lightdm.service

Unfortunately all that happened was the screen went blank. This time there wasn't even a blinking cursor.


Bunsen Hydrogen
Debian 8 (64bit)
Kernel: 3.16.0-4
Macbook 5.1

Offline

#4 2015-11-29 07:14:09

twoion
一期一会
Registered: 2015-08-10
Posts: 3,317

Re: Switching runlevel to use smxi fails

stevo1977 wrote:

Thanks for the quick response!

I'm running systemd. I tried stopping the display manager, like so:

sudo systemctl stop lightdm.service

Unfortunately all that happened was the screen went blank. This time there wasn't even a blinking cursor.

Interesting, there are no other TTY sessions? Try going through all of them first:

Ctrl+Alt+F1
Ctrl+Alt+F2
...
Ctrl+Alt+F12

Offline

#5 2015-11-29 08:23:54

ohnonot
...again
Registered: 2015-09-29
Posts: 5,554

Re: Switching runlevel to use smxi fails

good work folks, keep going, you will figure it out eventually! devil

as to this part of the problem:

stevo1977 wrote:

when I open the lid, even though the computer wakes up, the display never does.

it could be that bunsenlab's screen locker (an app called light-locker) works in a confusing way.
try blindly entering your password.
if you find that is what's ailing you, you can disable it partly or completely.
a few people have had problems with it and there's already more than one solved thread about it on the forums.
in other words, search.


Give to COVAX! Here or here. (explanation)

Offline

#6 2015-11-29 12:27:10

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Switching runlevel to use smxi fails

Runlevels are meaningless under systemd.

To drop directly to a console, use:

sudo systemctl isolate multi-user.target

I think ohnonot's right about the "blank" screen -- type your password and press return to see if that clears the screen.

However, now that you have handed your machine over to sxmi I think you will have to try booting with one of these kernel command line parameters (depending on your hardware, details of which you have failed to provide):

nommodeset

Or:

nomodeset nouveau.modeset=o

Or:

nomodeset i915.modeset=0 nouveau.modeset=0

https://www.kernel.org/doc/Documentatio … meters.txt

Parameters should be added to /etc/default/grub on the GRUB_CMDLINE_LINUX line, between the quotation marks.

Be sure to run `sudo update-grub` after modifying the file.

You can test the individual parameters temporarily by pressing "e" with the BunsenLabs GRUB menu entry highlighted and adding the parameters to the end of the line that starts with "linux" (use <Ctrk>+x to boot the entry).


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

Board footer

Powered by FluxBB