You are not logged in.

#1 2021-04-15 08:25:36

serialschoenberg
Member
Registered: 2020-04-01
Posts: 26

[SOLVED] dont suspend!

Hello,

I use Helium on a Lenovo laptop. When I put down the screen, the laptop enters in "suspend" mode (this is very nice in most case).

Is it possible to avoid that by putting a # at the beginning of a line in some script?

Thanks:

rb

Last edited by serialschoenberg (2021-04-16 16:04:27)

Offline

#2 2021-04-15 09:25:34

damo
....moderator....
Registered: 2015-08-20
Posts: 6,599

Re: [SOLVED] dont suspend!

serialschoenberg wrote:

Hello,

I use Helium on a Lenovo laptop. When I put down the screen, the laptop enters in "suspend" mode (this is very nice in most case).

Is it possible to avoid that by putting a # at the beginning of a line in some script?

Thanks:

rb

There should be a "Laptop Lid" section in xfce4-power-manager...
Menu > Preferences > Power Management


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2021-04-15 12:57:43

serialschoenberg
Member
Registered: 2020-04-01
Posts: 26

Re: [SOLVED] dont suspend!

Thanks for your reply, but Menu > Preferences > Power Management has no option Do nothing. Another idea?

Offline

#4 2021-04-15 13:31:10

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,034

Re: [SOLVED] dont suspend!

serialschoenberg wrote:

Thanks for your reply, but Menu > Preferences > Power Management has no option Do nothing.

Highly curious!

If you start from an terminal, with command

$ xfce4-power-manager

You should then get an graphical application:


JCa0p6el.png


If it does not show up, any errors?

Another idea?

I'm quite stunned...

Last edited by rbh (2021-04-15 13:33:13)


// Regards rbh

Offline

#5 2021-04-15 13:36:00

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,034

Re: [SOLVED] dont suspend!

rbh wrote:
serialschoenberg wrote:

Thanks for your reply, but Menu > Preferences > Power Management has no option Do nothing.

Highly curious!

If you start from an terminal, with command

$ xfce4-power-manager

You should then get an graphical application:


https://imgur.com/JCa0p6el.png


If it does not show up, any errors?

Another idea?

I'm quite stunned...

Edit; check if xfce4-power-manager is installed, else install it.


// Regards rbh

Offline

#6 2021-04-15 14:42:11

damo
....moderator....
Registered: 2015-08-20
Posts: 6,599

Re: [SOLVED] dont suspend!

serialschoenberg wrote:

Thanks for your reply, but Menu > Preferences > Power Management has no option Do nothing. Another idea?

Just choose Switch off display?


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#7 2021-04-15 14:44:25

trilobite
Member
From: Saskatchewan, Canada
Registered: 2017-06-27
Posts: 81

Re: [SOLVED] dont suspend!

I did xfce4-power-manager from a terminal also, it doesn't do anything, comes back with a prompt.  This is also on a Helium install. So I'm replicating @serialschoenberg.  The power manager icon on the taskbar brings up the graphic interface.

xfce4-power-manager just makes it run I think.  This is the basic page about it: https://docs.xfce.org/xfce/xfce4-power- … ng-started

perhaps do
$ xfce4-power-manager --customize

This brings it up for me.


{Linux-using people I haven't met are friends yet to be made.}

Offline

#8 2021-04-15 14:48:43

serialschoenberg
Member
Registered: 2020-04-01
Posts: 26

Re: [SOLVED] dont suspend!

$ xfce4-power-manager

$ rien/nada/nihil/nix/nothing

NB: I wont use; I prefer BL+openbox smile

Offline

#9 2021-04-15 15:18:49

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,034

Re: [SOLVED] dont suspend!

I do not have any Helium / Stretch boxes left. So, I can't test on Helium. Is there a specific reason you are running helium/Stretch? Else, why not upgrade or reinstall?

When starting xfce4-power-manager on my laptop, I get the message: "Xfce Power Manager: Another power manager is already running". When running

$ xfce4-power-manager --customize

the gui-setting program shows upp.


// Regards rbh

Offline

#10 2021-04-15 18:49:09

damo
....moderator....
Registered: 2015-08-20
Posts: 6,599

Re: [SOLVED] dont suspend!

serialschoenberg wrote:

$ xfce4-power-manager

$ rien/nada/nihil/nix/nothing

NB: I wont use; I prefer BL+openbox smile

BL uses xfce4-power-manager as the default power manager. NB Many xfce4, LXDE, Mint etc applications work fine with Debian OS's


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#11 2021-04-15 19:41:42

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,034

Re: [SOLVED] dont suspend!

I forgot to mention, the command on the jgmenu => Preferences => Power Managment, is "xfce4-power-manager-settings". That command starts the gui-setting application for power managment in BL Lithium and Beryllium.


// Regards rbh

Offline

#12 2021-04-16 12:48:11

serialschoenberg
Member
Registered: 2020-04-01
Posts: 26

Re: [SOLVED] dont suspend!

Hello,

By some trials I get a quasi-solution. The option "Do nothing" is hidden by "Éteindre l'écran" (== Erase the screen/Lösche den Schirm/...).

The trouble comes from the fact that an external screen (by HDMI) is an enlargement an not a new screen or window.

Many thanks for your help and proposals.

rené b.

Offline

#13 2021-04-16 13:01:18

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,034

Re: [SOLVED] dont suspend!

So, you could launch xfce4-powermanager gui, but you could not find the setting you needed...

Do you mark the thread as [SOLVED]?


// Regards rbh

Offline

#14 2021-04-16 16:07:30

serialschoenberg
Member
Registered: 2020-04-01
Posts: 26

Re: [SOLVED] dont suspend!

it is done!

Offline

Board footer

Powered by FluxBB