You are not logged in.

#1 2021-03-17 00:06:31

ahillio
Member
Registered: 2021-03-13
Posts: 18

caps2esc -- mapping CapsLock to ctrl/esc [solved]

I was previously able to get this awesome package:

https://gitlab.com/interception/linux/plugins/caps2esc

..working on my Kubuntu installation.

I followed the instructions https://askubuntu.com/a/979606/693219 and it worked fine.

I'm pretty sure I followed them identically.  All binaries seem to be in place.  I've checked the contents of the config files multiple times.

So....

Is there anything about BunsenLabs that would require something different than what that post suggests?  The technology here is a bit beyond me: systemd, systemctl, etc.  So I don't know if there's something obvious I'm missing.

Last edited by ahillio (2021-03-17 16:19:54)

Offline

#2 2021-03-17 01:22:26

damo
....moderator....
Registered: 2015-08-20
Posts: 6,572

Re: caps2esc -- mapping CapsLock to ctrl/esc [solved]

Did you also install the dependencies that others seem to have needed? eg Interception Tools?


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2021-03-17 09:24:07

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 2,258
Website

Re: caps2esc -- mapping CapsLock to ctrl/esc [solved]

Perhaps adding

setxkbmap -option caps:escape

or

setxkbmap -option caps:swapescape

to appropriate openbox autostart (.config/openbox/autostart in my case) might be enough? (not as deep as adding interception/systemd service I guess).

Last edited by brontosaurusrex (2021-03-17 10:10:15)

Offline

#4 2021-03-17 15:27:15

ahillio
Member
Registered: 2021-03-13
Posts: 18

Re: caps2esc -- mapping CapsLock to ctrl/esc [solved]

How do I determine whether I'm using *bunsenlabs-session* or *openbox-session*?

Oh.... I guess the "guess and check" method works... apparently I'm using openbox-session...

setxkbmap -option caps:swapescape

is a great quickfix for the dire scenario of having my Ctrl/Esc key turned into CapsLock, thanks!

But it doesn't provide the *Ctrl* functionality when it's pressed in combination with another key.  That's the magic smile

A lower-level solution would be more optimal, but I'd gladly settle for autostart config right now.  Is there a way to do what caps2esc does via openbox autostart config?

Offline

#5 2021-03-17 16:18:37

ahillio
Member
Registered: 2021-03-13
Posts: 18

Re: caps2esc -- mapping CapsLock to ctrl/esc [solved]

Oh nice smile
udevmon was in a different location here, /usr/local/bin/udevmon instead of /usr/bin/udevmon.  Updating /etc/systemd/system/udevmon.service to find udevmon at proper path makes it work.
Yay <3

Last edited by ahillio (2021-03-17 16:21:05)

Offline

#6 2021-03-18 02:21:48

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,851
Website

Re: caps2esc -- mapping CapsLock to ctrl/esc [solved]

ahillio wrote:

How do I determine whether I'm using *bunsenlabs-session* or *openbox-session*?

Oh.... I guess the "guess and check" method works... apparently I'm using openbox-session...

How did you determine that?
BunsenLabs systems use the bunsenlabs-session in fact.

When you logout, the little icon on the top right of the lightdm login should show the bunsenlabs flame. There's a drop-down menu offering openbox-session too but that's a much simpler thing which you have to configure yourself.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#7 2021-03-18 16:28:37

ahillio
Member
Registered: 2021-03-13
Posts: 18

Re: caps2esc -- mapping CapsLock to ctrl/esc [solved]

Well I could certainly be mistaken about that.  What led me to believe I'm using openbox-session was because putting `setxkbmap -option caps:swapescape` into `~/.config/bunsen/autostart` didn't work but it did work to put that in `~/.config/openbox/autosart`.  I don't believe I've done anything to configure openbox or switch from the default session manager.

Offline

#8 2021-03-19 01:40:23

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,851
Website

Re: caps2esc -- mapping CapsLock to ctrl/esc [solved]

ahillio wrote:

What led me to believe I'm using openbox-session was because putting `setxkbmap -option caps:swapescape` into `~/.config/bunsen/autostart` didn't work but it did work to put that in `~/.config/openbox/autosart`.

Yes, that's pretty good evidence (assuming you mistyped the filename in your post). smile
~/.config/openbox/autostart is ignored in a BunsenLabs session.

But now I'm wondering if you're using BunsenLabs at all? Are you getting the normal BunsenLabs desktop with wallpaper, tint2 and conky?

Maybe you could post the output of these commands?

cat /etc/debian_version
cat /etc/bunsen/bunsen_install
cat ~/.config/openbox/autostart

And then, could you try logging out, and checking the third icon from the right, at the top of the LightDM login screen? It's a dropdown menu which should offer 'BunsenLabs' 'Default Xsession' and 'Openbox'
Choose 'BunsenLabs', log in and see if things have changed.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

Board footer

Powered by FluxBB