You are not logged in.

#1 2021-01-20 08:17:04

callusedfingers
New Member
Registered: 2021-01-20
Posts: 4

[SOLVED] Problem with using apps installed with Snap.

I tried installing an app from Snapstore and it didn't show up in jgmenu (after refreshing). I tried it for the first time in Helium, but I think I tried in Lithium also. It too gave the same result.

I couldn't find any solution in the internet.

I am also a noob(newb) in the operating system.

Last edited by callusedfingers (2021-01-20 13:13:14)


Linux newb.

Offline

#2 2021-01-20 09:12:29

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,304

Re: [SOLVED] Problem with using apps installed with Snap.

Run command

$ snap list

to list what program you have installed

Run command

$ snap run [program]

for example, cherrytree is only available in snapstore. I start it with

$ snap run cherrytree

I have some snaps, none in the menu. Quite content with starting them from the terminal or gmrun.

this is wellknown problem. See https://askubuntu.com/questions/910821/ … n-launcher

Last edited by rbh (2021-01-20 09:13:18)


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Online

#3 2021-01-20 10:48:56

callusedfingers
New Member
Registered: 2021-01-20
Posts: 4

Re: [SOLVED] Problem with using apps installed with Snap.

Thanks! It worked. Other than that, the command line showed some error.

(electron) 'systemPreferences.isDarkMode()' is deprecated and will be removed. Please use 'nativeTheme.shouldUseDarkColors' instead.
18:55:12.177 › Checking for update
18:55:12.279 › Error: Error: ENOENT: no such file or directory, open '/snap/pomatez/2/resources/app-update.yml'
(node:3435) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, open '/snap/pomatez/2/resources/app-update.yml'
(node:3435) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see [url]https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode)[/url]. (rejection id: 1)
(node:3435) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

Last edited by callusedfingers (2021-01-20 10:55:30)


Linux newb.

Offline

#4 2021-01-20 10:53:06

callusedfingers
New Member
Registered: 2021-01-20
Posts: 4

Re: [SOLVED] Problem with using apps installed with Snap.

Also, I noticed the terminal shouldn't be closed or else the app will close. Otherwise, thank you! It works, God Bless.

Last edited by callusedfingers (2021-01-20 10:53:22)


Linux newb.

Offline

#5 2021-01-20 11:05:54

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,304

Re: [SOLVED] Problem with using apps installed with Snap.

callusedfingers wrote:

Also, I noticed the terminal shouldn't be closed or else the app will close.

Yes. If you start app with gmrun (Alt+F2), you do not need to bother about the terminal. The first error is gtk theme error. Unimportant. The other errors also seems insignificant.

Edit first post, add [Solved] to Subject.


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Online

#6 2021-01-20 13:14:21

callusedfingers
New Member
Registered: 2021-01-20
Posts: 4

Re: [SOLVED] Problem with using apps installed with Snap.

I just paraphrased the title because it cannot fit.


Linux newb.

Offline

#7 2021-08-09 20:49:06

syllamo_1
New Member
Registered: 2021-07-25
Posts: 1

Re: [SOLVED] Problem with using apps installed with Snap.

I edited the tint2 config and added the launchers using the .desktop file for the snap application - just works.

Offline

Board footer

Powered by FluxBB