You are not logged in.

#1 2020-12-25 23:39:10

sleekmason
zoom
Registered: 2018-05-22
Posts: 620
Website

[Solved] Annoying flash on exit in urxvt - in fluxbox

It's pretty bad.  Urxvt flashes white on exit while in Fluxbox. Not sure whether it has something to do with fluxbox or not. Kinda remember something like this from years ago.

I tried:

fbsetroot -solid black

thinking maybe the root window was the issue? didn't seem to matter . .

Urxvt does not do this in other distros with this configuration.

looked through https://www.systutorials.com/docs/linux/man/7-urxvt/
but nothing jumped out at me.  Missing package maybe?

Nothing else seems to do it though I haven't used this build long. Any ideas?

.Xresources:

Xft.autohint: 1
Xft.antialias: 1
Xft.hinting: true
Xft.hintstyle: hintmedium
Xft.dpi: 96
Xft.rgba: rgb
Xft.lcdfilter: lcddefault

!--- Window Settings
Xcursor.size:11
URxvt.buffered:             true
URxvt.geometry:             85x30

!--- Font Size and Controls
URxvt*.font:  xft:DejaVu Sans Mono:autohint=true:pixelsize=12
URxvt.perl-lib:                     ~/.urxvt/ext
URxvt.keysym.C-Up:     font-size:increase
URxvt.keysym.C-Down:   font-size:decrease
URxvt.keysym.C-S-Up:   font-size:incglobal
URxvt.keysym.C-S-Down: font-size:decglobal
URxvt.keysym.C-equal:  font-size:reset
URxvt.keysym.C-slash:  font-size:show
!URxvt.perl-ext-common: font-size,tabbed,matcher
URxvt.perl-ext-common: font-size,matcher

!--- For Tabs
URxvt.tabbed.reopen-on-close: yes
URxvt.keysym.Control-Shift-Left: perl:tabbedex:move_tab_left
URxvt.keysym.Control-Shift-Right: perl:tabbedex:move_tab_right
URxvt.keysym.Control-Shift-R: perl:tabbedex:rename_tab

!---Make url links clickable
URxvt.url-launcher: /usr/bin/firefox-esr
URxvt.matcher.button: 1
URxvt.matcher.rend.0: Uline Bold fg5

!--- Scrolling
URxvt*.scrollTtyOutput:     false
URxvt*.scrollWithBuffer:    false
URxvt*.scrollTtyKeypress:   true
URxvt.secondaryScroll:      true
URxvt*scrollstyle:          plain
URxvt*saveLines:            10000
URxvt.scrollBar_right:      true
URxvt.scrollBar:            false
URxvt.mapAlert:             true

!--- Line spacing
!  URxvt.lineSpace: 12

!---Transparency and effect settings
! URxvt*inheritPixmap:        true
! URxvt*transparent:          true
!---With Compositor enabled:
URxvt.depth: 32
URxvt.background: rgba:0000/0000/0000/bbbb


!---URxvt*shading: 0 to 99 darkens, 101 to 200 lightens
! URxvt*shading:              20
URxvt.blurRadius:           40
URxvt.fading:               0
! URxvt.tintColor:            #ffffff

!--- Tabbing Menu colors

URxvt.tabbed.tabbar-bg:     0
URxvt.tabbed.tabbar-fg:     6
URxvt.tabbed.tab-bg:        0
URxvt.tabbed.tab-fg:        5

!--- Colors

URxvt.cursorColor:          #06D5FF
URxvt.pointerColor:         #15ACCC
! URxvt.background:         #000000
URxvt.foreground:           #6CB1B8
URxvt.underlineColor:       #DE9D00
URxvt.throughColor:         #57AABA
URxvt.highlightColor:       #00526E
URxvt.color0:               #000000
URxvt.color1:               #15ACCC
URxvt.color2:               #15ACCC
URxvt.color3:               #15ACCC
URxvt.color4:               #06D5FF
URxvt.color5:               #15ACCC
URxvt.color6:               #15ACCC
URxvt.color7:               #CEFAF9
URxvt.color8:               #15ACCC
URxvt.color9:               #F5F500

!--prompt(name)
URxvt.color10:              #74EDFA

!--urls
URxvt.color11:              #F439A8

!--folder name
URxvt.color12:              #10C610

URxvt.color13:              #06D5FF

!--uptime top green
URxvt.color14:              #14AA03

!--menuconfig first letter
URxvt.color15:              #023C48

Nothing here as far as I know.

Last edited by sleekmason (2020-12-26 01:46:40)

Offline

#2 2020-12-26 01:30:44

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,465

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

Are you running compton or something similar?
Fluxbox has had issues with compton in the past. If you're running comptopn, disable it and see if the issue persists.


You must unlearn what you have learned.
    -- yoda

Offline

#3 2020-12-26 01:45:53

sleekmason
zoom
Registered: 2018-05-22
Posts: 620
Website

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

Yes! I just now tracked it to something to do with transparency.
Changing

URxvt.depth: 32

To 16 or 24 loses transparency, and the flicker as well.
Same with disabling compton.  Flicker goes away.

So a fluxbox issue? 

My memory of this seems to be setting the root window to black, then feh for the wallpaper, but that doesn't really make any sense I suppose.

Ha! your link gave the answer:)
In Compton.conf

--no-fading-destroyed-argb

Solved!

Offline

#4 2020-12-26 02:32:11

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,465

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

sleekmason wrote:

So a fluxbox issue?

In the context that fluxbox doesn't always play well with compton/picom, yes.


You must unlearn what you have learned.
    -- yoda

Offline

#5 2020-12-26 03:11:04

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,356

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

PackRat wrote:
sleekmason wrote:

So a fluxbox issue?

In the context that fluxbox doesn't always play well with compton/picom, yes.

Yes sometimes Compton messes with even Fluxbox themes as well , so consider themes can also interact with Compton negatively as well.

In addition Fluxbox does not always play well with multiple monitors especially when using a laptop with external monitors.

Last edited by DeepDayze (2020-12-26 03:12:05)


Real Men Use Linux

Offline

#6 2020-12-26 03:54:23

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,308
Website

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

sleekmason wrote:

In Compton.conf

--no-fading-destroyed-argb

Solved!

Would this setting likely be useful (or at least harmless) for other window managers than Fluxbox?
Also, any idea if picom (likely compton successor) would need something like that too?


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#7 2020-12-26 05:33:52

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,465

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

I would think that it would be harmless. The fix was mentioned on a couple threads when I searched for the error sleekmason was describing. Fluxbox wasn't the only window manager to have the issue.


You must unlearn what you have learned.
    -- yoda

Offline

#8 2020-12-26 06:27:18

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,308
Website

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

^If so, I guess we should throw it into the default compton.conf

EDIT: it's already there! roll

@sleekmason, I guess you're not using the BL configs. Maybe some other ideas in that compton file?

Last edited by johnraff (2020-12-26 06:31:32)


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#9 2020-12-26 10:42:18

ohnonot
...again
Registered: 2015-09-29
Posts: 5,568

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

It would be nice if sleekmason could try to reproduce the problem under openbox?


Give to COVAX! Here or here. (explanation)
My Repos: notabug | framagit

Offline

#10 2020-12-26 12:28:11

sleekmason
zoom
Registered: 2018-05-22
Posts: 620
Website

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

DeepDayze wrote:

Yes sometimes Compton messes with even Fluxbox themes as well , so consider themes can also interact with Compton negatively as well.

This is good to know.  I won't freak out if something goes wonky big_smile

johnraff wrote:

^If so, I guess we should throw it into the default compton.conf

EDIT: it's already there!

Figures:) Lol.  If I had known it was a compton issue I would have looked there first for sure.

ohnonot wrote:

It would be nice if sleekmason could try to reproduce the problem under openbox?

I didn't check for this under Openbox (solo).
In Openbox under lxde, there is no issue.
Sounds like it may be a general problem for window managers though?. 

Glad there is a fix, as the white flash is damn near blinding in the dark:)

Offline

#11 2020-12-26 15:15:30

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,465

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

johnraff wrote:
sleekmason wrote:

In Compton.conf

--no-fading-destroyed-argb

Solved!

Would this setting likely be useful (or at least harmless) for other window managers than Fluxbox?
Also, any idea if picom (likely compton successor) would need something like that too?

It's presented as an option in the picom.conf example template:

# Do not fade destroyed ARGB windows with WM frame. Workaround of bugs in Openbox, Fluxbox, etc.
# no-fading-destroyed-argb = false

I actually went scorched earth with:

fading = false;

in my picom.conf. Drop shadows and slightly transparent terminal are enough for me  monkey

Last edited by PackRat (2020-12-26 16:42:54)


You must unlearn what you have learned.
    -- yoda

Offline

#12 2020-12-26 20:44:05

sleekmason
zoom
Registered: 2018-05-22
Posts: 620
Website

Re: [Solved] Annoying flash on exit in urxvt - in fluxbox

PackRat wrote:
johnraff wrote:
sleekmason wrote:

In Compton.conf

--no-fading-destroyed-argb

Solved!

Would this setting likely be useful (or at least harmless) for other window managers than Fluxbox?
Also, any idea if picom (likely compton successor) would need something like that too?

It's presented as an option in the picom.conf example template:

# Do not fade destroyed ARGB windows with WM frame. Workaround of bugs in Openbox, Fluxbox, etc.
# no-fading-destroyed-argb = false

I actually went scorched earth with:

fading = false;

in my picom.conf. Drop shadows and slightly transparent terminal are enough for me  monkey

Of Interest, I had thought to clean up my compton.conf with the line you have from picom because the other arguments are presented in the same manner (true/false), but it would not work in Compton. 
I reverted back to the line from your original link:

--no-fading-destroyed-argb

and it allows for fading with no complaints. Doesn't really make sense, but there it is.

Offline

Board footer

Powered by FluxBB