You are not logged in.

#1 2020-10-20 22:24:42

MidGe
Member
Registered: 2017-06-09
Posts: 11

Screen saver issue [SOLVED]

Hello and thanks to all for the hard work put into this excellent distro.

I have recently come back to Bunsenlabs as I did go to Debian following the end of Crunchbang and before BunsenLabs was into gear.

I  have an issue that I cannot resolve. There seems to be an issue with a default value for the screensaver coming on. It come on after 10 minutes (600 seconds) which a "xset -q" command show as the default.

A "xset s off" as root or as user seems to have no effect at all.
Neither does entering the command in the ~/.config/autostart file.

I am not using xfce and thus xfce-manager is not running.  I am running awesome-wm over openbox.

There are a number of other autostart files on the computer:
/etc/xdg/autostart
/etc/xdg/openbox/autostart
~/.config/autostart
~/.config/bunsen/autostart
~/.config/openbox/autostart
/usr/share/bunsen/skel/.config/autostart
/usr/share/bunsen/skel/.config/bunsen/autostart
/usr/share/bunsen/skel/.config/openbox/autostart

In which order are they used, or which one might be the appropriate one to modify to change default value of screen blanking?

If none, how can I modify the default value?

Thanks for any help you may be able to give to get rid of this hugely annoying issue. smile

Last edited by MidGe (2020-10-22 05:50:56)

Offline

#2 2020-10-20 22:55:51

damo
....moderator....
Registered: 2015-08-20
Posts: 6,404

Re: Screen saver issue [SOLVED]

BL uses xfce4-power-manager. If this is managing your session, you can set values for timeouts using the GUI xfce4-power-manager-settings.

The skel files are the defaults used to populate a new ${USER} directory, and serve no further purpose except as default backups.

Window manager sessions can be chosen from the lightdm login screen:

A bunsenlabs session uses ~/.config/bunsen/autostart. This has a section for adding autostart commands for Awesome.
A pure Openbox session uses ~/.config/openbox/autostart.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#3 2020-10-21 03:10:19

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,414
Website

Re: Screen saver issue [SOLVED]

These hold .desktop files which are conditionally executed by bl-xdg-autostart, run in ~/.config/bunsen/autostart:
(See the output of 'bl-xdg-autostart --list' for more info.)
/etc/xdg/autostart   (Some packages install files here.)
~/.config/autostart   (Users can put files here, which will override /etc/xdg/autostart)

These hold shell commands. Openbox will use one of them, depending on its starting command:
~/.config/bunsen/autostart   (BunsenLabs)
~/.config/openbox/autostart   (Openbox default)

This is a fallback for when openbox can't find a user autostart file, BunsenLabs ignores it though:
/etc/xdg/openbox/autostart

As @damo said, these are not used:
/usr/share/bunsen/skel/.config/autostart
/usr/share/bunsen/skel/.config/bunsen/autostart
/usr/share/bunsen/skel/.config/openbox/autostart


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#4 2020-10-22 03:58:37

MidGe
Member
Registered: 2017-06-09
Posts: 11

Re: Screen saver issue [SOLVED]

Thanks for the info.

It seems that modifying the ~/.config/openbox/autostart has no effect.  I will try ~/.config/bunsen/autostart  next.

Offline

#5 2020-10-22 04:23:06

damo
....moderator....
Registered: 2015-08-20
Posts: 6,404

Re: Screen saver issue [SOLVED]

MidGe wrote:

Thanks for the info.

It seems that modifying the ~/.config/openbox/autostart has no effect.  I will try ~/.config/bunsen/autostart  next.

As @johnraff said, bl-xdg-autostart controls some autostarted applications. If you list them, does it show the power management?

bl-xdg-autostart --list
...
[*] Power Manager
	  File: /etc/xdg/autostart/xfce4-power-manager.desktop
	  Executes: xfce4-power-manager
...

In which case IIRC the default for screen blanking is 10mins:

damo wrote:

BL uses xfce4-power-manager. If this is managing your session, you can set values for timeouts using the GUI xfce4-power-manager-settings.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#6 2020-10-22 04:37:37

MidGe
Member
Registered: 2017-06-09
Posts: 11

Re: Screen saver issue [SOLVED]

Ah! Very interesting.

1) bl-xdg-autostart --list shows the PowerManager as per your post (asterisk et al , whatever that means)

2) trying to execute the gui for settings states that the xfce4-power-manager is "not" running and whether I want to start it. AFAIK I have no need to run xfce4-power-manager since I do not run xfce. But then I am unable to modify the settings and I do not understand why if it not running its settings to blank the screen would still apply? Maybe they are set at boot, or login time and persist when power-manager stops which it obviously does??

Last edited by MidGe (2020-10-22 04:37:55)

Offline

#7 2020-10-22 04:46:58

damo
....moderator....
Registered: 2015-08-20
Posts: 6,404

Re: Screen saver issue [SOLVED]

I have no need to run xfce4-power-manager since I do not run xfce.

Bunsenlabs doesn't run xfce either, but uses various xfce utilities, which work quite happily without an XFCE Desktop Environment.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#8 2020-10-22 05:50:20

MidGe
Member
Registered: 2017-06-09
Posts: 11

Re: Screen saver issue [SOLVED]

OK,

I get it. Had not thought about that.

Thanks a lot for your help.

Offline

#9 2020-10-22 12:30:29

damo
....moderator....
Registered: 2015-08-20
Posts: 6,404

Re: Screen saver issue [SOLVED]

MidGe wrote:

OK,

I get it. Had not thought about that.

Thanks a lot for your help.

So what was the solution?


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#10 2020-10-22 22:27:42

MidGe
Member
Registered: 2017-06-09
Posts: 11

Re: Screen saver issue [SOLVED]

I tried adding "(xset -dpms && xset s off) &"
to .config/openbox/autostart, /etc/xdg/openbox/autostart and /.config/bunsen/autostart. All to no avail.

I used xfce4-power-manager but change there did not persist.

Entering "(xset -dpms && xset s off) &" from the command line is the simplest way to get it working (disabling it). I am setting up a simple alias to do it first thing at startup.

I would be happy to have it set at 30 minutes rather than what seems the default 10 and I know my solution is a hack but at my age I have not got the luxury of time to chase it any further.  smile

Offline

#11 2020-10-22 23:21:28

damo
....moderator....
Registered: 2015-08-20
Posts: 6,404

Re: Screen saver issue [SOLVED]

MidGe wrote:

I tried adding "(xset -dpms && xset s off) &"
to .config/openbox/autostart, /etc/xdg/openbox/autostart and /.config/bunsen/autostart. All to no avail.
...

You said you were using Awesome WM, so perhaps you should be looking at how it deals with autostarting? AFAICS Awesome's autostarted commands should be in ~/.config/awesome/rc.lua
Arch wiki - Awesome#Autostart


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#12 2020-10-22 23:47:08

MidGe
Member
Registered: 2017-06-09
Posts: 11

Re: Screen saver issue [SOLVED]

There are no reference to screen saver of anything like it in the rc.lua.

The issue is related to a default value on the system somewhere, unrelated to awesome-wm, methinks.

Anyway, the CLI hack works for me and is not too onerous to my workflow.

Offline

#13 2020-10-22 23:50:59

damo
....moderator....
Registered: 2015-08-20
Posts: 6,404

Re: Screen saver issue [SOLVED]

Couldn't you put your xset commands in the rc.lua, to save doing it manually?


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#14 2020-10-28 01:08:28

MidGe
Member
Registered: 2017-06-09
Posts: 11

Re: Screen saver issue [SOLVED]

Here is the full solution:

1. to rc.lua add the following:

-- Change DPMS and screen savers settings by running the file
awful.spawn.with_shell("~/.config/awesome/autorun.sh")

2. Create a file autorun.sh with the following content:

#!/usr/bin/env bash
# Stop screen from going black ###
### xset dpms <standby_seconds> <suspend_seconds> <off_seconds>
(xset dpms 1800 0 0 && xset s off) &

3. Give executable properties to the file

If you want to disable the screensaver completely replace:

(xset dpms 1800 0 0 && xset s off) &

with:

(xset -dpms && xset s off) &

You can test it by executing:

xset -q

Restarting awesome from the menu and re-testing with the same command.
The difference of the output will confirm success.

Thanks for all that helped resolve this issue.
And thanks to all contributors for a great Linux distro.

Offline

Board footer

Powered by FluxBB