You are not logged in.

#1 2020-07-10 18:00:51

realtbro92
Member
Registered: 2020-07-04
Posts: 20

Install Gimp 2.8

Is it possible to install gimp 2.8?

I would love that version back.

If it is possible could you help me with the steps. Thanks smile

Offline

#2 2020-07-10 22:29:38

damo
....moderator....
Registered: 2015-08-20
Posts: 6,347

Re: Install Gimp 2.8

Why would you want an inferior version of gimp? 2.10 has so many improvements.

If you are running Helium, then gimp 2.8.18 is the current version.

If you are running Lithium then try adding the stretch repo to your sources, update, and do (at your own risk!):

sudo apt-get install --simulate gimp=2.8.18-1+deb9u1

Use "--simulate" first, to see if there will be any problems. If it looks OK, run the command without that parameter.

I would then put a hold on the gimp package so that you can't accidentally upgrade it the next time you update your system.

sudo apt-mark hold gimp

I suspect may run into trouble if you have newer versions of the gimp, babl and gegl libraries already present.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2020-07-10 22:35:07

realtbro92
Member
Registered: 2020-07-04
Posts: 20

Re: Install Gimp 2.8

Its because am use to gimp 2.8 In don't like the newer version I just use gimp for cropping photo or resizing an a little free use like just touching up a photo I like the older verison because it familiar an that all lol. But I do understand that gimp 2.10 I think its better for other people because it up to date. But I also want to say thanks because i heard of put older packes into a newer version and installing software just did not no how to understand it. I guest you also help with that. So thanks damo

Offline

#4 2020-07-10 22:51:49

damo
....moderator....
Registered: 2015-08-20
Posts: 6,347

Re: Install Gimp 2.8

I like the older verison because it familiar

2.10 behaves exactly the same for crop/resize and "touching up" etc. If it is the looks and layout that bothers you, then set up the old theme and icons in Preferences. It is a lot easier than jumping through hoops to install a non-updateable old version!


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#5 2020-07-10 23:21:39

realtbro92
Member
Registered: 2020-07-04
Posts: 20

Re: Install Gimp 2.8

Will Do

Offline

#6 2020-07-11 03:00:55

realtbro92
Member
Registered: 2020-07-04
Posts: 20

Re: Install Gimp 2.8

Just installed Gimp 2.6 with wine. I know your going to cringe but hey at least I got it to work. https://ibb.co/bm2TLGL

Offline

#7 2020-07-11 05:35:34

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,970

Re: Install Gimp 2.8

I would have thought that this kind of thing should be easy with flatpak or snap but neither is offering old versions of gimp, that's disappointing (granted, gimp 2.8 was 2 years ago but being able to keep old and new versions next to each other was the point of these projects no?).


Per aspera ad astra.

Offline

#8 2020-07-11 07:02:36

damo
....moderator....
Registered: 2015-08-20
Posts: 6,347

Re: Install Gimp 2.8

I looked at the flatpak option, but the download link for gimp-2.8 on gimp.org links to the latest gimp flatpak.

It would also be nice if GIMP did the same thing as Blender, and provided a self-contained portable version for linux. Then you can have whichever version you like without touching your system packages.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#9 2020-07-11 09:35:51

ohnonot
...again
Registered: 2015-09-29
Posts: 4,943
Website

Re: Install Gimp 2.8

realtbro92, I don't see the point either.
GIMP has been very consistent in its behaviour and GUI over the years.
If you want multi-window back, just uncheck this:
gimp-multi-window.png


BL quote proposals to this thread please.
my repos / my repos

Offline

Board footer

Powered by FluxBB