You are not logged in.

#1 2015-11-17 18:20:40

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

No sound... [Solved]

Hi everybody!

Being user of Crunchbang for a while and last week I decided to upgrade to bunsenlabs. Everything went as expected except for the sound. Trying different solutions but nothing work. These are some output

# lspci | grep Audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

# lsmod | grep snd
snd_hda_intel          26327  0 
snd_hda_controller     26646  1 snd_hda_intel
snd_hda_codec         104463  2 snd_hda_intel,snd_hda_controller
snd_hwdep              13148  1 snd_hda_codec
snd_pcm                88662  3 snd_hda_codec,snd_hda_intel,snd_hda_controller
snd_timer              26614  1 snd_pcm
snd                    65244  5 snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore              13026  2 snd,snd_hda_codec


# lspci | grep Audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

# lspci -k|grep -A2 Audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
	Subsystem: Toshiba America Info Systems Device 0001
	Kernel driver in use: snd_hda_intel
	
# aplay -l
aplay: device_list:268: no soundcards found...

The sound card of my laptop is working (laptop has dual boot with fedora, and sound is ok there).

I would appreciate any advice.

Regards

Naddan

Last edited by Naddan (2015-12-01 19:12:25)

Offline

#2 2015-11-17 18:39:56

damo
....moderator....
Registered: 2015-08-20
Posts: 5,058

Re: No sound... [Solved]

Naddan wrote:

... Trying different solutions but nothing work. ...

So to save us playing 20 questions, what have you tried?

Did you read the sticky post at the beginning of this forum? Getting Sound working in BL


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2015-11-17 19:42:49

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: No sound... [Solved]

Naddan wrote:

Being user of Crunchbang for a while and last week I decided to upgrade to bunsenlabs

How exactly did you "upgrade to BunsenLabs"?

What is the output of:

cat /proc/asound/cards

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#4 2015-11-18 09:11:39

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

Re: No sound... [Solved]

Hi thanks for replying

@damo:

damo wrote:
Naddan wrote:

... Trying different solutions but nothing work. ...

So to save us playing 20 questions, what have you tried?

Did you read the sticky post at the beginning of this forum? Getting Sound working in BL


Yes I read the sticky of the forum and try all of what is in there without success (of course).

I have tried:

remove alsa and install pulseaudio
purge and reinstall alsa

Use alsamixer to change Card and Chip options and by default both are set to PulseAudio. Using F6 to select different sound card but there is not any other listed, and trying to add a new device name it complains that there is not such folder.

@Head_on_a_Stick:

I'm sorry for the confusion, by "upgrade to BunsenLabs" I meant fresh installation.

# cat /proc/asound/cards
--- no soundcards ---

Here more clues:

Same laptop:
BunsenLabs fresh installation: no sound
Debian 8 fresh installation: no sound
Centos 7 fresh installation: no sound
Archbang fresh installation: no sound

Fedora 23 (basic X-server with openbox) fresh installation: ... sound! (yes with fedora no problem about sound at all)

There were not sound problems at all with the previous Crunchbang installation I had in the same machin.

Regards

Last edited by Naddan (2015-11-18 09:37:20)

Offline

#5 2015-11-18 12:38:17

Snap
Member
Registered: 2015-10-02
Posts: 465

Re: No sound... [Solved]

Maybe a driver is missing. Have you tried the settings in Fedora in any of the other systems?

Offline

#6 2015-11-18 18:22:27

ohnonot
...again
Registered: 2015-09-29
Posts: 3,911
Website

Re: No sound... [Solved]

Snap wrote:

Maybe a driver is missing.

looks like it.
please post output of

lspci -k | grep -iA5 audio

Offline

#7 2015-11-18 20:05:51

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

Re: No sound... [Solved]

Snap wrote:

Have you tried the settings in Fedora in any of the other systems?

No, because sometimes different distributions do the same thing slightly different.

ohnonot wrote:

please post output of

lspci -k | grep -iA5 audio

Here is the output:

$ lspci -k | grep -iA5 audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
	Subsystem: Toshiba America Info Systems Device 0001
	Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
	Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 02)

and here is the output of the same comand but from fedora (sound working)

lspci -k | grep -iA5 audio
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
	Subsystem: Toshiba America Info Systems Device 0001
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel <<<---------------------
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
	Kernel driver in use: pcieport

the line with the arrow is missing in the BunsenLabs output and the last line from the output in fist command is missing in the fedora output.

Another fact I just noticed when booting the system is some messages that say something like:

hda-intel 0000:00:1b.0: no AFG or MFG found
hda-intel 0000:00:1b.0: no codecs initialized

(I am not sure if it is exactly '0000:00:1b.0:')... It seems some codes are missing.

Last edited by Naddan (2015-11-18 20:08:31)

Offline

#8 2015-11-18 22:01:04

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: No sound... [Solved]

What is the output of:

grep -R blacklist /etc/modprobe.d
dmesg|grep firmware
cat /proc/cmdline

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#9 2015-11-19 07:18:07

ohnonot
...again
Registered: 2015-09-29
Posts: 3,911
Website

Re: No sound... [Solved]

Naddan wrote:

and here is the output of the same comand but from fedora (sound working)

different kernel versions?

Offline

#10 2015-11-19 19:34:39

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

Re: No sound... [Solved]

@ohnonot:

fedora is using the kernel 4.1.6...

@head_on_a_stick

# grep -R blacklist /etc/modprobe.d
/etc/modprobe.d/amd64-microcode-blacklist.conf:blacklist microcode
/etc/modprobe.d/fbdev-blacklist.conf:# This file blacklists most old-style PCI framebuffer drivers.
/etc/modprobe.d/fbdev-blacklist.conf:blacklist arkfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist aty128fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist atyfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist radeonfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist cirrusfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist cyber2000fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist kyrofb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist matroxfb_base
/etc/modprobe.d/fbdev-blacklist.conf:blacklist mb862xxfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist neofb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist pm2fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist pm3fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist s3fb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist savagefb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist sisfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist tdfxfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist tridentfb
/etc/modprobe.d/fbdev-blacklist.conf:blacklist vt8623fb
/etc/modprobe.d/intel-microcode-blacklist.conf:blacklist microcode

# dmesg | grep firmware
[   24.318066] iwl3945 0000:02:00.0: firmware: direct-loading firmware iwlwifi-3945-2.ucode
[   24.318143] iwl3945 0000:02:00.0: loaded firmware version 15.32.2.9

# cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=14133e1d-907e-4cfa-b017-ee059bd208d6 ro initrd=/install/gtk/initrd.gz quiet

Offline

#11 2015-11-20 00:42:29

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: No sound... [Solved]

This may help https://bbs.archlinux.org/viewtopic.php?id=175110

It appears there have been a number of issues with this particular sound card and it likely got hit with a kernel regression. If that does not work, you might also attempt a backported kernel and see if that fixes things.

Offline

#12 2015-11-20 07:26:45

ohnonot
...again
Registered: 2015-09-29
Posts: 3,911
Website

Re: No sound... [Solved]

^ what i thought, you might need a newer kernel.

Offline

#13 2015-11-20 10:49:32

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

Re: No sound... [Solved]

@tknomanzr:
the suggestion from https://bbs.archlinux.org/viewtopic.php?id=175110 did not work for me.

@ohnonot:

So ideally I should compile a version 4.* of the kernel, right?

By the way, if I have to compile a new version of the kernel, can I use the kernel configuration file from the fedora installation to compile the new kernel for bunsenlabs? (both installations are in the same machine)

Last edited by Naddan (2015-11-20 11:06:44)

Offline

#14 2015-11-20 16:45:29

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: No sound... [Solved]

I'd really just enable Debian backports and try it before I went recompiling a kernel.
Add this to /etc/apt/sources.list, update and install:

deb http://http.debian.net/debian jessie-backports main
sudo apt-get update
sudo apt-get install -t  linux-image-4.2.0-0.bpo.1-amd64

Note: The above is for amd64 architecture. If you use something different you may need to search around a bit to find it.

Last edited by tknomanzr (2015-11-20 16:46:07)

Offline

#15 2015-11-20 19:26:17

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: No sound... [Solved]

^ Probably best to use the kernel metapackage to get the upgrades and security fixes.
https://packages.debian.org/jessie-back … mage-amd64

I like to use apt(8) for stuff like this:

sudo apt edit-sources # add this line: deb http://httpredir.debian.org/debian jessie-backports main
sudo apt update
sudo apt install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,')/jessie-backports

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#16 2015-11-23 13:49:07

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

Re: No sound... [Solved]

I did

sudo apt edit-sources # add this line: deb [url]http://httpredir.debian.org/debian[/url] jessie-backports main
sudo apt update
sudo apt install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,')/jessie-backports

but it did not work... :-/

Offline

#17 2015-11-23 14:03:41

damo
....moderator....
Registered: 2015-08-20
Posts: 5,058

Re: No sound... [Solved]

Naddan wrote:

I did

sudo apt edit-sources # add this line: deb [url]http://httpredir.debian.org/debian[/url] jessie-backports main
sudo apt update
sudo apt install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,')/jessie-backports

but it did not work... :-/

Please be more specific. "...but it did not work..." is not helpful. What didn't work? Any error messages etc

Have you left the [ url ] tags in? The line should read

deb http://httpredir.debian.org/debian jessie-backports main

Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#18 2015-11-25 08:01:03

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

Re: No sound... [Solved]

@damo

I did remove any tag [ url ], and by "it did not work..." I meant: "the commands run (without any tags) well without any errors" Yes no errors at all and yet not sound.

Offline

#19 2015-11-25 08:05:32

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: No sound... [Solved]

Oh dear, sorry about this -- my post wasn't very clear.

I meant for you to add the line after the "#" symbol into the file opened by the command.

Please post the output of:

cat /etc/apt/sources.list /etc/apt/sources.list.d/*

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#20 2015-11-26 10:06:33

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

Re: No sound... [Solved]

@Head_on_a_Stick

Your post was clear... I am not too dull... I think so! big_smile big_smile

Here are the output anyway:

#cat /etc/apt/sources.list.d/*
deb http://pkg.bunsenlabs.org/debian bunsen-hydrogen main
#cat /media/etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150909-03:19]/ jessie contrib main non-free

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20150909-03:19]/ jessie contrib main non-free

deb http://ftp.uk.debian.org/debian/ jessie main non-free contrib
#deb-src http://ftp.uk.debian.org/debian/ jessie main non-free contrib

deb http://security.debian.org/ jessie/updates main contrib non-free
#deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.uk.debian.org/debian/ jessie-updates main contrib non-free
#deb-src http://ftp.uk.debian.org/debian/ jessie-updates main contrib non-free

# added by bl-welcome
# Multimedia repository
deb http://www.deb-multimedia.org jessie main non-free

deb http://repos.codelite.org/wx3.0.2/debian/ wheezy libs

deb http://httpredir.debian.org/debian jessie-backports main

Thanks!

Offline

#21 2015-11-26 13:25:18

damo
....moderator....
Registered: 2015-08-20
Posts: 5,058

Re: No sound... [Solved]

I don't know anything about codelite, or if it is safe to use, but shouldn't you be using `jessie` libs, not `wheezy`?


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#22 2015-11-26 18:15:09

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: No sound... [Solved]

@OP: Is your kernel version 4?

uname -a

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#23 2015-11-30 08:36:22

Naddan
Member
From: UK
Registered: 2015-11-17
Posts: 35

Re: No sound... [Solved]

@damon:
that repo is for wxWidgets, there is no jessie version yet.

@Head_on_a_Stick:
Now that you mention it, no kernel version 4

uname -a
Linux localhost 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) x86_64 GNU/Linux

Offline

#24 2015-11-30 13:40:05

hhh
Meep!
Registered: 2015-09-17
Posts: 8,324
Website

Re: No sound... [Solved]

Maybe obvious, but if you currently have pulseaudio and pavucontrol installed, open pavucontrol, go to the Output tab and try all options, especially the Mute button. Also in alsamixer (m to unmute and arrows to navigate and raise levels).

Offline

#25 2015-11-30 20:17:46

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: No sound... [Solved]

Naddan wrote:

@Head_on_a_Stick:
Now that you mention it, no kernel version 4

uname -a
Linux localhost 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) x86_64 GNU/Linux

So you're not using the backported kernel version.

Did you try it at all?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

Board footer

Powered by FluxBB