You are not logged in.

#1 2020-01-24 18:11:13

vorwart
Member
Registered: 2015-11-03
Posts: 14

[SOLVED] Browsers doing their own thing regardless of WM rules.

Not quite sure how to communicate this, so please bear with me:

For personal preference and efficiency, I have Openbox set to only raise windows when I click on a title bar. I can jump focus from one window to another without the window in focus stealing all the screen real-estate. I have the need to work from window to window, some partially covering others, without disturbing the stacking order (keeps everything in view). I also prefer to have my close button on the left.... and to have every window title bar the same, and to function the same.

At some point a few applications apparently stated using their own, built in window manger or something (!?). Seems like it was a PDF viewer that I noticed first, then my favorite browsers. This really disrupts my consistency of work flow.

Unable to find a painless solution, I have been forced to find other applications that would behave and follow the window manager rules. I use Atril for PDFs and Firefox for web browsing. However, I very much prefer Vivaldi or even Opera to Firefox.

Is there anyway to force all applications to use Openbox and follow the rules like everything else?

This is just chaos.

Last edited by vorwart (2020-01-29 15:23:30)

Offline

#2 2020-01-24 20:36:07

damo
....moderator....
Registered: 2015-08-20
Posts: 5,633

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

Browsers and QT applications can be a problem, depending on the GTK theme you are using.

You can try other themes, or browser themes. You can also try forcing certain behaviour with per-application settings in rc.xml.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#3 2020-01-25 07:22:52

ohnonot
...again
Registered: 2015-09-29
Posts: 4,310
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

vorwart wrote:

At some point a few applications apparently stated using their own, built in window manger or something (!?). Seems like it was a PDF viewer that I noticed first, then my favorite browsers. This really disrupts my consistency of work flow.

Unable to find a painless solution, I have been forced to find other applications that would behave and follow the window manager rules. I use Atril for PDFs and Firefox for web browsing. However, I very much prefer Vivaldi or even Opera to Firefox.

Confusing.
Can you tell us exactly which applications are currently "doing their own thing" wrt window manager rules?

FWIW, I know that browsers (that's vague) tend to do something like that sometimes; or at least it has been a topic before (that's vaguer).

Offline

#4 2020-01-25 07:35:21

vasa1
Member
Registered: 2015-09-29
Posts: 178

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

Some GTK applications use client-side decorations (CSD). Some distros have the gtk-nocsd package to make such applications ignore CSD.

Sorry, that should be gtk3-nocsd. Thanks, ohnonot smile

Last edited by vasa1 (2020-01-26 10:57:00)


Using the Openbox (3.5.2) session of Lubuntu 14.04 LTS but very interested in BL :)

Offline

#5 2020-01-25 15:09:03

vorwart
Member
Registered: 2015-11-03
Posts: 14

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

Yes, Ohnonot, to me, it is very confusing. I thought a window manager was supposed to manage all of your initial/primary windows. Yet there are a prominent few that have broken ranks right out of the box.

Evince, the PDF viewer, does it's own thing with the decorations, but otherwise seems to act as any other window, (For my concern: Focused when clicked on, but raising only when the title bar is clicked, as I have Openbox set to do) but it's very annoying to have the close buttons on the right when I have all windows set to be on the left. So I use Atril instead. That's not a big deal - It's an (ch)easy "fix" and I don't feel like I am missing out.

Firefox and Midori do just fine, but I'd prefer Vivaldi, and often need Chrome for work purposes. It's the Chromium based browsers that do their own thing.... Chromium, Chrome, Opera, Vivaldi.

~Thank you Damo, might be getting into that "painful" area, but it's at least a direction and maybe I can learn something.

~Also good info, Vasa1. I like this distro. Again, might involve pain, but thank you for the direction.

Offline

#6 2020-01-26 07:03:37

ohnonot
...again
Registered: 2015-09-29
Posts: 4,310
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

So it's only Evince.
As vasa1 said: that's GTK3's CSD (client side decorations). Can be fixed.

Offline

#7 2020-01-26 13:17:10

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 5,879

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

Should be a default package in BL

What do they mean: LD_PRELOADable?

Description: Library to disable Gtk+ 3 client side decorations (CSD)
libgtk3-nocsd is a small LD_PRELOADable library used to disable the client side decorations (CSD)
of Gtk+ 3.

Would this be something BL must do on boot?

EDIT:  Duh now I google

EDIT-2
Hmmmmm:  LD_PRELOAD --> absolute path

Last edited by Sector11 (2020-01-26 13:25:12)


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.

Offline

#8 2020-01-26 16:32:53

clusterF
Member
Registered: 2019-05-07
Posts: 520

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

Maybe try out basilisk web browser?

A XUL-based web-browser demonstrating the Unified XUL Platform (UXP).
This browser is a close twin to pre-Servo Firefox in how it operates.

https://www.basilisk-browser.org/


"Ad Astra Incrementis"

git: clusterF

Offline

#9 2020-01-27 01:07:01

hhh
Meep!
Registered: 2015-09-17
Posts: 9,078
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

Sector11 wrote:

Should be a default package in BL

It was in helium, it's been removed by us in lithium. @JohnRaff needs to chime in here for an explanation, I'll just get it wrong if I try.

Offline

#10 2020-01-27 01:34:17

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,169

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

ohnonot wrote:

So it's only Evince.

It's several. Vivaldi, Opera, Epiphany as well. I've never tried gtk3-nocsd.


You must unlearn what you have learned.
    -- yoda

Offline

#11 2020-01-27 02:16:47

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 6,383
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

hhh wrote:
Sector11 wrote:

Should be a default package in BL

It was in helium, it's been removed by us in lithium. @JohnRaff needs to chime in here for an explanation, I'll just get it wrong if I try.

Er... what was in Helium, removed in Lithium?


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#12 2020-01-27 03:41:06

hhh
Meep!
Registered: 2015-09-17
Posts: 9,078
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

Offline

#13 2020-01-27 04:02:26

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 6,383
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

^I'm pretty sure we dropped gtk3-nocsd from Helium. It seemed like a good idea at first, but was kindof buggy, didn't look all that great and sometimes gave you two title bars.
We decided just to leave it as a suggested optional install for users.

The difference in appearance between csd and non-csd apps is annoying though.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#14 2020-01-27 05:40:01

hhh
Meep!
Registered: 2015-09-17
Posts: 9,078
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

I don't see the difference, to be honest. Does transmission-gtk look worse without that package, for example?

Offline

#15 2020-01-27 06:05:16

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 6,383
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

It's only with apps that use csd. I think that might mean GTK3 apps, or possibly only a subset. Try a Gnome app like Evince or Gedit, and compare with/without gtk3-nocsd, or compare Evince with Atril.

I'm quite happy to live with the csd apps (I only use a couple) doing their thing, but users for whom they cause issues (like the OP?) can try installing gtk3-nocs and see if it improves things for them.

Last edited by johnraff (2020-01-27 07:28:32)


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#16 2020-01-28 06:41:29

ohnonot
...again
Registered: 2015-09-29
Posts: 4,310
Website

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

^ yes, GTK3.
TBH, I don't know if this would even affect Chromium & clone, but they usually have options in the settings.

PackRat wrote:
ohnonot wrote:

So it's only Evince.

It's several.

I was refering to OP's situation and their somewhat foggy statement from post #5.

I think just installing the nocsd package is enough (might need to restart the graphical session).
But yeah, it's not ideal.
FWIW (this is Arch), I use http://github.com/krumelmonster/gtk3-mushrooms and have not a worry about this.

Last edited by ohnonot (2020-01-28 06:42:59)

Offline

#17 2020-01-29 15:20:42

vorwart
Member
Registered: 2015-11-03
Posts: 14

Re: [SOLVED] Browsers doing their own thing regardless of WM rules.

Okay guys, I think I can mark this solved.

Solution:

1. Install gtk3-nocsd, restart.
2. Then configure the application's setting to "Use native window", and restart the application.

Just FYI, Ohnonot, those settings with any of the Chromium clones did nothing until after I installed gtk3-nocsd and reset them as decribed above.

I'm just a regular user and don't get in too deep under the hood. I had no idea of the existence of gtk3-nocsd or what it was. The same for CSD.
I just knew the non-uniform behavior really irked me.

Thanks, guys!

Offline

Board footer

Powered by FluxBB