You are not logged in.

#1 2019-11-12 19:59:53

wagmic
Member
From: Casablanca
Registered: 2015-09-30
Posts: 82

is it safe to install libgtk-3-dev [solve]

Hi is it safe to install libgtk-3-dev from strech backport

this is the output when i am trying :

sudo apt install -t stretch-backports libgtk-3-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  at-spi2-core autoconf automake autopoint autotools-dev debhelper
  dh-autoreconf dh-strip-nondeterminism dwz gettext gir1.2-atk-1.0
  gir1.2-atspi-2.0 icu-devtools intltool-debian libarchive-zip-perl
  libatk-bridge2.0-0 libatk-bridge2.0-dev libatk1.0-0 libatk1.0-data
  libatk1.0-dev libatspi2.0-0 libatspi2.0-dev libcairo-script-interpreter2
  libcairo2-dev libdbus-1-dev libdrm-amdgpu1 libdrm-dev libdrm-intel1
  libdrm-nouveau2 libdrm-radeon1 libegl1-mesa-dev libepoxy-dev libexpat1-dev
  libfile-stripnondeterminism-perl libfontconfig1-dev libfreetype6-dev
  libgdk-pixbuf2.0-dev libgl1 libgl1-mesa-glx libglapi-mesa libgles1 libgles2
  libgles2-mesa libglib2.0-dev libglvnd-core-dev libglvnd-dev libglx-mesa0
  libglx0 libgraphite2-dev libharfbuzz-dev libharfbuzz-gobject0
  libharfbuzz-icu0 libice-dev libicu-dev libltdl-dev libmail-sendmail-perl
  libopengl0 libpango1.0-dev libpcre3-dev libpcre32-3 libpcrecpp0v5
  libpixman-1-dev libpng-dev libpng-tools libpthread-stubs0-dev libsm-dev
  libsys-hostname-long-perl libtimedate-perl libtool libwayland-bin
  libwayland-cursor0 libwayland-dev libx11-dev libx11-doc libx11-xcb-dev
  libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
  libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev
  libxcb-shm0-dev libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev
  libxcomposite-dev libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev
  libxfixes-dev libxft-dev libxi-dev libxinerama-dev libxkbcommon-dev
  libxrandr-dev libxrender-dev libxshmfence-dev libxtst-dev libxxf86vm-dev m4
  mesa-common-dev pkg-config po-debconf wayland-protocols
  x11proto-composite-dev x11proto-core-dev x11proto-damage-dev
  x11proto-dri2-dev x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev
  x11proto-kb-dev x11proto-randr-dev x11proto-record-dev x11proto-render-dev
  x11proto-xext-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev
  xorg-sgml-doctools xtrans-dev zlib1g-dev
Paquets suggérés :
  autoconf-archive gnu-standards autoconf-doc dh-make gettext-doc
  libasprintf-dev libgettextpo-dev libcairo2-doc libglib2.0-doc libgtk-3-doc
  libice-doc icu-doc libtool-doc libpango1.0-doc libsm-doc gfortran
  | fortran95-compiler gcj-jdk libwayland-doc libxcb-doc libxext-doc m4-doc
  libmail-box-perl
Les NOUVEAUX paquets suivants seront installés :
  autoconf automake autopoint autotools-dev debhelper dh-autoreconf
  dh-strip-nondeterminism dwz gettext gir1.2-atspi-2.0 icu-devtools
  intltool-debian libarchive-zip-perl libatk-bridge2.0-dev libatk1.0-dev
  libatspi2.0-dev libcairo-script-interpreter2 libcairo2-dev libdbus-1-dev
  libdrm-dev libegl1-mesa-dev libepoxy-dev libexpat1-dev
  libfile-stripnondeterminism-perl libfontconfig1-dev libfreetype6-dev
  libgdk-pixbuf2.0-dev libgl1 libgles1 libgles2 libglib2.0-dev
  libglvnd-core-dev libglvnd-dev libglx-mesa0 libglx0 libgraphite2-dev
  libgtk-3-dev libharfbuzz-dev libharfbuzz-gobject0 libharfbuzz-icu0
  libice-dev libicu-dev libltdl-dev libmail-sendmail-perl libopengl0
  libpango1.0-dev libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev
  libpng-dev libpng-tools libpthread-stubs0-dev libsm-dev
  libsys-hostname-long-perl libtimedate-perl libtool libwayland-bin
  libwayland-dev libx11-dev libx11-doc libx11-xcb-dev libxau-dev
  libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev
  libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev libxcb-shm0-dev
  libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxcomposite-dev
  libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev
  libxft-dev libxi-dev libxinerama-dev libxkbcommon-dev libxrandr-dev
  libxrender-dev libxshmfence-dev libxtst-dev libxxf86vm-dev m4
  mesa-common-dev pkg-config po-debconf wayland-protocols
  x11proto-composite-dev x11proto-core-dev x11proto-damage-dev
  x11proto-dri2-dev x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev
  x11proto-kb-dev x11proto-randr-dev x11proto-record-dev x11proto-render-dev
  x11proto-xext-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev
  xorg-sgml-doctools xtrans-dev zlib1g-dev
Les paquets suivants seront mis à jour :
  at-spi2-core gir1.2-atk-1.0 libatk-bridge2.0-0 libatk1.0-0 libatk1.0-data
  libatspi2.0-0 libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1
  libgl1-mesa-glx libglapi-mesa libgles2-mesa libwayland-cursor0
14 mis à jour, 111 nouvellement installés, 0 à enlever et 112 non mis à jour.
Il est nécessaire de prendre 48,6 Mo dans les archives.
Après cette opération, 197 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n]

What you think about ???

Last edited by wagmic (2019-11-22 21:18:55)


La liberté, personne ne peut l’expliquer mais tout le monde peut la comprendre.Cecilia Meireles
Tout ce qui n'est pas donné ou partagé est perdu (proverbe tsigane)

Offline

#2 2019-11-12 20:38:54

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,553

Re: is it safe to install libgtk-3-dev [solve]

It's always reasonably safe to install backports packages (for stability). Looks like it'll install a bunch of other header packages as well as update some packages; this is normal. Lots of graphics related deps sound alright. I suspect doing this will lift the "to be updated" packages to backport releases also.

Just go ahead smile


At the end of the river the sundown beams

Offline

#3 2019-11-12 20:51:17

wagmic
Member
From: Casablanca
Registered: 2015-09-30
Posts: 82

Re: is it safe to install libgtk-3-dev [solve]

thanks i ll give it a try


La liberté, personne ne peut l’expliquer mais tout le monde peut la comprendre.Cecilia Meireles
Tout ce qui n'est pas donné ou partagé est perdu (proverbe tsigane)

Offline

#4 2019-11-13 05:13:47

stevep
MX Linux Developer
Registered: 2016-08-08
Posts: 379

Re: is it safe to install libgtk-3-dev [solve]

What libgtk-3-dev package in stretch-backports?

https://packages.debian.org/search?keyw … ection=all

Offline

#5 2019-11-22 21:18:13

wagmic
Member
From: Casablanca
Registered: 2015-09-30
Posts: 82

Re: is it safe to install libgtk-3-dev [solve]

Hi twoion i haven say thanks but i have done what you say

@stevep

apt-cache policy libgtk-3-dev
libgtk-3-dev:
  Installé : 3.22.11-1
  Candidat : 3.22.11-1
 Table de version :
 *** 3.22.11-1 500
        500 https://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status

La liberté, personne ne peut l’expliquer mais tout le monde peut la comprendre.Cecilia Meireles
Tout ce qui n'est pas donné ou partagé est perdu (proverbe tsigane)

Offline

Board footer

Powered by FluxBB