You are not logged in.

#1 2019-10-22 16:41:44

Sector11
The Tpyo Knig Mod
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,653

Firefox is not default browser

Almost every time I open Firefox using a link from Thunderbird I get this popup and:

 22 Oct 19 @ 13:30:59 ~
   $ update-alternatives --config x-www-browser
There is only one alternative in link group x-www-browser (providing /usr/bin/x-www-browser): /usr/bin/firefox-esr
Nothing to configure.
 
 22 Oct 19 @ 13:31:02 ~
   $ 

Any help appreciated it is driving me insane.

I have "unchecked" the always check ... it "always comes back" GRRRRRR!!!

In FF I have gone through about:config looking for "check" "default" and "browser" and made sure that the checking is set to "false"

Now no matter how many times I go back to that page:

browser.shell.checkDefaultBrowser

is set to "true"
I reset it to false.

Is pottering messing with my system?  :=)  {joke}

Last edited by Sector11 (2019-10-22 16:43:29)


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

#2 2019-10-23 03:33:47

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 6,018
Website

Re: Firefox is not default browser

My browser.shell.checkDefaultBrowser is set to "false", and what's more it's not bold, meaning that's the default setting I think. I wonder what's changing yours to "true"? You haven't got a user.js in your default firefox directory that's overruling it?

You clicked "use firefox as my default browser"?


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Online

#3 2019-10-23 10:44:21

Sector11
The Tpyo Knig Mod
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,653

Re: Firefox is not default browser

Clicking on the link to come here I clicked "use firefox as my default browser" again and right now

browser.shell.checkDefaultBrowser

is set to false and grey like yours, not bold.

It will change it has been doing that for the past couple of weeks.

There is no user.js or user.json or any "user" anything in my default directory


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

#4 2019-10-23 18:03:39

Sector11
The Tpyo Knig Mod
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,653

Re: Firefox is not default browser

It is driving me NUTS!!!
not-funny-now.th.jpg
IT WILL NOT GO AWAY!!!!


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

#5 2019-10-23 18:54:11

Sector11
The Tpyo Knig Mod
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,653

Re: Firefox is not default browser

OK, I think I'm on to something but still stumped.

Does anyone else have this:
browser-shell-1.th.jpg

Set everything as default:
browser-shell-2.th.jpg

browser-shell-1.th.jpg
and it comes back.


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

#6 2019-10-24 14:26:52

clusterF
Member
Registered: 2019-05-07
Posts: 257

Re: Firefox is not default browser

The problem most likely persists in thunderbird not firefox.

This may help...

https://askubuntu.com/questions/130158/ … n-chromium


"Thou Wanderer, Father of all! Thou Wanderer, Spirit of all!"

Offline

#7 2019-10-24 14:45:58

Sector11
The Tpyo Knig Mod
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,653

Re: Firefox is not default browser

Ooooo thanks cF  will check that out and leave the green checked answer here for others (and because of my forgetter)

Answer to the Link above:

This is what I found working for me: You will need to access the "config editor" in Thunderbird itself.

Open Thunderbird. In 24.6.0, the menu can be accessed on the right hand side of the top menu bar (next to the search bar and is represented by three horizontal lines).

Click Edit > then click Preferences >, a new window will open. You will need to select the Advanced tab, at the bottom of that tab Open the Config Editor.

Then, search for both network.protocol-handler.warn-external.http and network.protocol-handler.warn-external.https.

These two are most likely to have a current value of false. Change the value to true (do this by simply right clicking on them) and the next time you try to open a link from some e-mail it'll ask you which browser to use. Chromium isn't likely to be shown in the list of choices, so use the navigate button. You can find Chromium at /usr/bin/chromium-browser.

If using google chrome as your browser of choice you may want to make it /usr/bin/google-chrome or /usr/bin/google-chrome-stable If Thunderbird doesn't ask you which browser to use when you click on a link after doing this, you can try deleting mimeTypes.rdf file in your profile folder to reset it. The profile folder is typically found as ~/.thunderbird/xxxxxxxx.default/

That said both of my network.protocol-handler.warn-external.http and network.protocol-handler.warn-external.https were set to "true" and I was never asked for a choice ... since I only have one browser installed, firefox is opened and then tells me it's not the default.

 24 Oct 19 @ 11:47:34 ~
   $ update-alternatives --config x-www-browser
There is only one alternative in link group x-www-browser (providing /usr/bin/x-www-browser): /usr/bin/firefox-esr
Nothing to configure.
 
 24 Oct 19 @ 11:47:45 ~
   $ 

BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

Board footer

Powered by FluxBB