You are not logged in.

#1 2019-10-22 09:13:16

linux_user
Member
Registered: 2016-11-04
Posts: 416

[SOLVED] gsimplecal launching as 'inactive window'

Usually, when you launch an application, it becomes the active window. However, when opening gsimplecal (either through tint2, dmenu or gmrun), the pop up calendar happens to be an inactive window. Is this the way gsimplecal is made? Is there anything we can do about it during BL development?

Generally not problem, but if you have set windows transparency to inactive window, you'd notice that the calendar pop up is transparent.

Last edited by linux_user (2019-10-23 11:30:17)


"Blind faith to authority is the greatest enemy of truth."

Offline

#2 2019-10-22 14:43:17

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 1,909
Website

Re: [SOLVED] gsimplecal launching as 'inactive window'

You can override this by adding

<application class="Gsimplecal" name="gsimplecal" type="normal"><focus>yes</focus></application>

to .config/openbox/rc.xml (somewhere at the bottom i guess, inside <applications>).

Offline

#3 2019-10-22 15:48:48

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

^ Well, in that case, this thread should be moved to Basic Help and Support I believe. smile

Thanks @brontosaurusrex


"Blind faith to authority is the greatest enemy of truth."

Offline

#4 2019-10-22 15:59:15

damo
....moderator....
Registered: 2015-08-20
Posts: 5,198

Re: [SOLVED] gsimplecal launching as 'inactive window'

linux_user wrote:

^ Well, in that case, this thread should be moved to Basic Help and Support I believe. smile

Done wink


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#5 2019-10-23 08:57:54

ohnonot
...again
Registered: 2015-09-29
Posts: 4,129
Website

Re: [SOLVED] gsimplecal launching as 'inactive window'

linux_user: have a look at 'man gsimplecal' and ~/.config/gsimplecal/config - there are some settings pertaining to window placement.

Offline

#6 2019-10-23 09:02:24

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

brontosaurusrex wrote:

You can override this by adding

<application class="Gsimplecal" name="gsimplecal" type="normal"><focus>yes</focus></application>

to .config/openbox/rc.xml (somewhere at the bottom i guess, inside <applications>).

It didn't fix it @brontosaurusrex, sorry about my previous message confirming the fix. Will check the man and config files as @ohonot suggested.


ohnonot wrote:

linux_user: have a look at 'man gsimplecal' and ~/.config/gsimplecal/config - there are some settings pertaining to window placement.

Thanks, will do it. I posted it here (in Dev & Sug) thinking that was the way it's coded and we could change it for lithium release.


"Blind faith to authority is the greatest enemy of truth."

Offline

#7 2019-10-23 10:51:49

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 1,909
Website

Re: [SOLVED] gsimplecal launching as 'inactive window'

Working here, actually I can't find a way to not make it work
itsworking.th.png

Offline

#8 2019-10-23 11:29:08

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

brontosaurusrex wrote:

Working here, actually I can't find a way to not make it work
https://cdn.scrot.moe/images/2019/10/23/itsworking.th.png

Thanks for posting it. It made me recheck your snippet I had put, only to realize that I have put it inside a commented code block and for the obvious reason, wasn't executed. The calendar is as opaque as the wall now.

To the dev team: can we have this setting as the default out of the box setting? Is there any advantage of keeping it as a non active window?

@brontosaurusrex: Out of curiosity, what's the idea behind your username. Never realized the sophistication of it until I had to type it. smile

Last edited by linux_user (2019-10-23 11:32:37)


"Blind faith to authority is the greatest enemy of truth."

Offline

#9 2019-10-23 12:03:33

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 1,909
Website

Re: [SOLVED] gsimplecal launching as 'inactive window'

Is there any advantage of keeping it as a non active window?

I imagine there is an advantage if it's called via some sort of hotkey (for example while typing in some text), but can't think of anything else right now.

the idea behind your username.

Real: No idea, some people on irc said 'b' was to short, so I made a longer version.
Fake: Comes from latin 'bro-nto-sau-risus', which means 'makes gsimplecal working'.
Real: I do like a random story where fake prehistoric grass-eater animal gets angry.

Last edited by brontosaurusrex (2019-10-23 12:12:32)

Offline

#10 2019-10-23 12:11:10

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

I imagine there is an advantage if it's called via some sort of hotkey (for example while typing in some text), but can't think of anything else right now.

Even when opening using a hotkey, being in focus (active window) will do no it no harm. If there is no other advantage, it is my suggestion that this be an active windows in lithium. The dev team can make the call.

No idea, some people on irc said 'b' was to short, so I made a longer version.

The art of naming! smile


"Blind faith to authority is the greatest enemy of truth."

Offline

#11 2019-10-23 13:55:50

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,110

Re: [SOLVED] gsimplecal launching as 'inactive window'

Is there any advantage of keeping it as a non active window?

It won't steal focus when started. Also, as I recall, when it's inactive, it is excluded from selection by ALT-Tab (or whatever keys window switching is bound to) - but I haven't used it in a while so that may not be right.

If your key binding is set to toggle gsimplecal, you can start and stop it without having to interact with the window itself.


You must unlearn what you have learned.
    -- yoda

Offline

#12 2019-10-25 14:20:08

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

PackRat wrote:

If your key binding is set to toggle gsimplecal, you can start and stop it without having to interact with the window itself.

...only if the focus is on gsimplecal, as I have set up transparency and dim for inactive windows. smile

Last edited by linux_user (2019-10-25 14:20:37)


"Blind faith to authority is the greatest enemy of truth."

Offline

#13 2019-10-26 15:50:51

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

PackRat wrote:

If your key binding is set to toggle gsimplecal, you can start and stop it without having to interact with the window itself.

Do you mean to say that you can set up a key binding to toggle gsimplecal that is on the clock applet on tint2 panel?


"Blind faith to authority is the greatest enemy of truth."

Offline

#14 2019-10-26 16:27:32

damo
....moderator....
Registered: 2015-08-20
Posts: 5,198

Re: [SOLVED] gsimplecal launching as 'inactive window'

linux_user wrote:
PackRat wrote:

If your key binding is set to toggle gsimplecal, you can start and stop it without having to interact with the window itself.

Do you mean to say that you can set up a key binding to toggle gsimplecal that is on the clock applet on tint2 panel?

In general you can have a toggle script, which can be run with a keybind. So in this case you can have

pgrep -x gsimplecal && pkill gsimplecal  || gsimplecal &>/dev/null &

But in tint2 the clock_lclick_command = gsimplecal will toggle on/off with a mouseclick on the clock anyway. Or am I misunderstanding you?


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#15 2019-10-26 17:22:03

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

damo wrote:

In general you can have a toggle script, which can be run with a keybind. So in this case you can have

pgrep -x gsimplecal && pkill gsimplecal  || gsimplecal &>/dev/null &

I was confirming that @PackRat wasn't talking about binding a key to open gsimplecal just like the way you open from gmrun or dmenu. Just wondering if it is about binding a key to toggle gsimplecal in tint2 (instead of clicking on the clock with the mouse) I'd like to try it.

I tried your snippet. Great work. Although the calendar appears where the mouse is on the screen and not where tint2 clock is (just like clicking on it), I'll use it since it does the job. Thanks @damo smile

Last edited by linux_user (2019-10-26 17:35:46)


"Blind faith to authority is the greatest enemy of truth."

Offline

#16 2019-10-26 17:56:35

nore
>2⁹
From: squirrels' nest
Registered: 2015-09-29
Posts: 472

Re: [SOLVED] gsimplecal launching as 'inactive window'

linux_user wrote:

Although the calendar appears where the mouse is on the screen

In rc.xml, under application settings for Gsimplecal, use something like

<position force="no">
   <x>-0</x>
   <y>24</y>
</position>

to put the window to right edge, 24 pixels from top.

Offline

#17 2019-10-27 14:01:27

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

Ah, it worked. And I used % to put make it appear somewhere in the middle of the monitor.  Much less eye travel. big_smile

<position force="no">
       <x>40%</x>
       <y>40%</y>
    </position>


"Blind faith to authority is the greatest enemy of truth."

Offline

#18 2019-10-27 14:14:56

nore
>2⁹
From: squirrels' nest
Registered: 2015-09-29
Posts: 472

Re: [SOLVED] gsimplecal launching as 'inactive window'

linux_user wrote:

somewhere in the middle

Exactly in the middle:

<x>center</x>
<y>center</y>

Offline

#19 2019-10-27 14:21:50

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

^ Exactly in the middle it is @nore smile


"Blind faith to authority is the greatest enemy of truth."

Offline

#20 2019-10-27 14:22:14

linux_user
Member
Registered: 2016-11-04
Posts: 416

Re: [SOLVED] gsimplecal launching as 'inactive window'

linux_user wrote:

^ Exactly in the middle it is @nore, Thank you! smile


"Blind faith to authority is the greatest enemy of truth."

Offline

Board footer

Powered by FluxBB