You are not logged in.

#1 2019-10-13 04:06:58

Registered: 2016-05-10
Posts: 92

[Resolved]Cannot connect to internet in Helium release

I am in the process of installing Helium on a 32-bit Dell tower. When I run 'uname -a' on the host, I get:

Linux herman 4.9.0-9-686-pae #1 SMP Debian 4.9.168-1+deb9u3 (2019-06-16) i686 GNU/Linux

I have a network connection, but it seems to me that the DNS is not working.

I can ping any of the hosts or the router in my intranet and I can run 'ssh' and login in on other hosts. In addition, I can ping IP addresses on the internet and I get a positive response, but I have to use the IP address, not the domain name. For example, I can:




does not work  and I get the error message:

ping Temporary failure in name resolution

I have installed Helium on one other machine and the only difference in /etc/network/interfaces on the two hosts, is the host IP address. The interfaces file on the problem machine, 'herman', is:

 1 # This file describes the network interfaces available on your system
  2 # and how to activate them. For more information, see interfaces(5).
  4 source /etc/network/interfaces.d/*
  6 # The loopback network interface
  7 auto lo
  8 iface lo inet loopback
 10 auto eno1
 11 iface eno1 inet static
 12 address
 13 netmask
 15 gateway
 16 broadcast
 18 dns-nameservers

The output of 'ip addr show' is:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 90:b1:1c:98:dd:22 brd ff:ff:ff:ff:ff:ff
    inet brd scope global eno1
       valid_lft forever preferred_lft forever
    inet6 fe80::92b1:1cff:fe98:dd22/64 scope link
       valid_lft forever preferred_lft forever

So, I'm pretty sure there is a DNS problem, but I can not find a way to resolve the problem.

I would appreciate suggestions and help. Thank you in advance.

Jim A.

Last edited by jjanderson5 (2019-10-13 15:58:41)


#2 2019-10-13 07:14:14

Registered: 2015-09-29
Posts: 4,630

Re: [Resolved]Cannot connect to internet in Helium release

Maybe it expects to find DNS on the ROuter, but the Router does not provide that?
Can you edit the connection in Network-Manager and manually add DNS servers (under IPv4 & IPv6 settings)?
I remember I sometimes chose "Automatic, Addresses only", then added DNS servers below.

BL quote proposals to this thread please.
how to ask smart questions | my repos / my repos | my blog
Thank you for posting direct image links!


#3 2019-10-13 15:57:58

Registered: 2016-05-10
Posts: 92

Re: [Resolved]Cannot connect to internet in Helium release

That worked. Thank you!


Board footer

Powered by FluxBB