You are not logged in.

#1 2019-07-04 18:54:42

cothrige
Member
Registered: 2016-05-16
Posts: 7

Compton and Emacs Transparency

I have run into a weird thing about compton that I cannot figure out. For some reason when using compton Emacs is almost entirely transparent. To be thorough about seeing if it was caused by some setting I introduced I reset my config to the one at /usr/share/bunsen/skel/.config/compton.conf, removed the config entirely, ran emacs with '-q' and even temporarily removed all my emacs configs. I have also gone line by line through the compton config to look for something that I thought would cause emacs to react this way but have had no luck. I even tried various exclude settings for different things all to no avail. Regardless of what I have tried I still get a ghostly emacs as seen below.

Screenshot_2019-07-04_13-28-06.th.png

I can work around this by explicitly setting the alpha of emacs frames to 100 in my init, which is fine really, but it is just the opposite of what I would expect and have always had in the past. Normally you include an alpha setting to create some amount of transparency, not to avoid it.

Has anyone else run into this?

Offline

#2 2019-07-04 19:28:29

damo
....moderator....
Registered: 2015-08-20
Posts: 5,172

Re: Compton and Emacs Transparency

According to https://www.emacswiki.org/emacs/TransparentEmacs...

(set-frame-parameter nil 'alpha nil) should let the window manger handle it again


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#3 2019-07-04 20:52:37

cothrige
Member
Registered: 2016-05-16
Posts: 7

Re: Compton and Emacs Transparency

Interesting. That seems to have no effect here and results in the same transparent frame. The only way I have found to get around it, short of disabling compositing, is to set things very explicitly as suggested at that same website as follows:

(set-frame-parameter (selected-frame) 'alpha '(85 . 50))
(add-to-list 'default-frame-alist '(alpha . (85 . 50)))

It works as far as it goes and is easy enough unless I decide to use emacs directly as another user which means it is practically invisible. And it really shouldn't be necessary. Leaving alpha settings out should result in a fully opaque window. Maybe I will try building from source and seeing if that has an effect.

Offline

#4 2019-07-04 21:23:11

damo
....moderator....
Registered: 2015-08-20
Posts: 5,172

Re: Compton and Emacs Transparency

What have you tried in compton.conf in the opacity-rules section? The default conf has an example which is commented out:

#opacity-rule = [ "80:class_g = 'URxvt'" ];

Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#5 2019-07-05 19:05:21

cothrige
Member
Registered: 2016-05-16
Posts: 7

Re: Compton and Emacs Transparency

Yes, I did try various opacity-rules and such, all with no results. I even removed compton and replaced it temporarily with xcompmgr and found the behavior persisted. After that I thought I would focus on emacs, and since it happens even without any init files I figured it would have to be somewhere in the system install. Trying to narrow that down I purged every emacs related package I could find and reinstalled everything fresh, but again the behavior continued. I also did the same but compiled emacs myself with the same result again. At this point I just really cannot imagine where this phenomenon is coming from, though since I can work around it I probably will just live with it for now.

Offline

#6 2019-07-05 19:18:01

damo
....moderator....
Registered: 2015-08-20
Posts: 5,172

Re: Compton and Emacs Transparency

I see someone else had success with

opacity-rule = [ "90:class_g = 'Emacs'"]

Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#7 2019-07-07 00:00:06

cothrige
Member
Registered: 2016-05-16
Posts: 7

Re: Compton and Emacs Transparency

damo wrote:

I see someone else had success with

opacity-rule = [ "90:class_g = 'Emacs'"]

Yes, I think that would have helped had my problem been in compton itself. Unfortunately it had no effect for me. Obviously I made some little tweak somewhere way back and it had a side-effect that I didn't notice, and now I doubt I will be able to find what it is. At least it isn't something that causes real breakage but rather just a visual bug. I figure I will finally fix it when Lithium is out, which is something extra to look forward to. smile And I certainly appreciate you taking the time to try to help me out with it.

Offline

Board footer

Powered by FluxBB