You are not logged in.

#1 2019-06-25 17:52:24

oguzh664
New Member
Registered: 2019-06-25
Posts: 2

GRUB error while installing & nothing to boot on BIOS menu

Hi, I burn the latest iso on a USB drive in windows with etcher.

Live version works (it's what I'm currently using), the installer works and I could go as far as the installing, but the installer gave the following error in GRUB install.

WP_20190625_18_24_32_Raw.jpg

I skipped GRUB step (just pressed 'continue' when it gave the multiple errors [about GRUB]) and the install finished. It was completed and I unplugged my USB drive then after the laptop restarted, it booted into windows rescure or whatever it was. Then I checked the BIOS and could not see BL, but could only see the "Windows boot manager option"

So yea, I could not boot to the installed system. And since I deleted C:, formatted into ext4 so I could install BL onto it, I was left with no OS. I opened Gparted on Live version and saw that the 120GB ext4 (which I marked as / root) had 4GB of usage. I guess that 4 gigs was the BL, but since it was failed, I formatted it. Now I have a partition of 120GB out of a 500GB hard drive. How do I install without any problem? Please help. and yes, it's a single 500GB disk and I have 350~gb of NTFS partition with data in it. (not important, but also must not get deleted)

Info;
No secure boot, BIOS on UEFI (a.k.a it's on windows8.1 mode instead of 7 [7 is for EFI and legacy mode I believe])

I only set a 120GB / root and 4GB swap, picked the "guided install with largest size" and it was installed on 120GB partition. Was succesfull about connectig to mirrors etc.

Offline

#2 2019-06-25 21:48:22

Naik
Member
From: Lipsia
Registered: 2015-10-03
Posts: 168

Re: GRUB error while installing & nothing to boot on BIOS menu

Hey there!
It is difficult to say what to do about this without knowing what exactly has gone wrong with grub and what exactly your setup looks like.
I guess there is some kind of a hidden partition (or even flash drive?) containing this win-rescue thingy, but I don't know how these things work to be honest.
You could have reinstalled grub* via live-CD or may do so if you give the installation another try and the error reoccurs.
Pleas keep in mind to take note of the exact error messages provided by the installer, so it is easier to help you.
Since you formatted the 120GB BL partition, trying to install BL again seems to be the first thing to do.
But you may also provide the output of blkid from the live-cd to give us a clue on what exactly your setup looks like. To do so, hit WIN+T to start the terminator and type:

sudo blkid

Anyways you may keep your head up, I have never heard of a living HDD where Grub was simply impossible to be setup and even if this should be the case there are other options around (see lilo).

*the link provided is from kali-linux forum but it should work non the less. It's debian too..

Naik --greetz


"Kaum macht [Mensch]* es richtig, funktioniert es sofort!"
BL-Kitchen on GitHub

Offline

#3 2019-06-25 22:23:13

oguzh664
New Member
Registered: 2019-06-25
Posts: 2

Re: GRUB error while installing & nothing to boot on BIOS menu

Naik wrote:

Hey there!
I guess there is some kind of a hidden partition (or even flash drive?) containing this win-rescue thingy, but I don't know how these things work to be honest.

Hey, about the windows recovery, internally called Windows RE.
This is a label name for a 16mb or 500mb partition that's created by a windows install. It absolutely does nothing for me, and if I never had that, the linux install would stay the same. It booted, because there was only "windows boot manager" option on boot menu. Which possibly triggers that partition and it boots to a screen that says "(something something) recovery/repair" or simply the BIOS can't boot the first option and goes straight to RE. Again, there's no GRUB or anything. A GRUB option for a good linux install and RE might have been;

-Boot "linux"
-Boot "linux" (rescue mode)
-Boot "all hope is lost"
-Boot Windows Recovery

btw, the recovery partition on other windows computer I got is 13gb and 11gb of it is used. (also visible on Win explorer, unlike the small RE partition I got in this BL-project-thingy, which is only visible in Gparted or in a Windows setup)

I hope I'm not talking crap. And of course, I also have little to no info about Recovery.

I'm putting this project on hold, because it's getting late here. In sleep I go, 12 hours later I might continue and supply you with inputs from that command

Last edited by oguzh664 (2019-06-25 22:25:03)

Offline

#4 2019-06-26 06:17:27

ohnonot
...again
Registered: 2015-09-29
Posts: 3,773
Website

Re: GRUB error while installing & nothing to boot on BIOS menu

oguzh664 wrote:

This is a label name for a 16mb or 500mb partition that's created by a windows install. It absolutely does nothing for me, and if I never had that, the linux install would stay the same.

Please boot some Live Linux distro, preferably one that contains Gparted already (but you can also simply install it within the live environment).
Fire up Gparted and see what you have there.
There's options now for each partition to erase. (Possibly also to grow the surrounding partitions to fill up the freed space, but I'd try without that step first.)
Before you do any of that make a full backup of the whole disk. Nothing should be lost, but better to be safe than sorry. Not only because of the data you mentioned in post #1 but also because I heard of some UEFI crap computers that get bricked when some data on the hard drive is missing.

Once you erased that partition try installing again.

Offline

Board footer

Powered by FluxBB