You are not logged in.

#1 2019-04-28 04:47:01

pamir
Member
Registered: 2018-02-02
Posts: 43

[NOTABUG]youtube-dl version 2017.05.18.1

I got a bug in youtube-dl version 2017.05.18.1 for bunsenlabs.



ERROR: 3an6NlxPo84: "token" parameter not in video info for unknown reason; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see  https://yt-dl.org/update  on how to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.

youtube-dl cannot help unless it is the latest version, which bunsenlabs synaptic package manager is saying it is at the newest.

youtube-dl asks on their website :


Unfortunately, there is nothing we youtube-dl developers can do if your distribution serves a really outdated version. You can (and should) complain to your distribution in their bugtracker or support forum.


youtube-dl -v

shows this:


[debug] System config: []
[debug] User config: []
[debug] Custom config: []
[debug] Command-line args: ['-v']
[debug] Encodings: locale UTF-8, fs utf-8, out UTF-8, pref UTF-8
[debug] youtube-dl version 2017.05.18.1
[debug] Python version 3.5.3 - Linux-4.9.0-8-amd64-x86_64-with-BunsenLabs-9.6-helium
[debug] exe versions: ffmpeg 3.2.12-1, ffprobe 3.2.12-1, rtmpdump 2.4
[debug] Proxy map: {}
Usage: youtube-dl [OPTIONS] URL [URL...]

Last edited by johnraff (2019-04-28 05:39:07)

Offline

#2 2019-04-28 05:38:00

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 5,460
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

pamir wrote:
youtube-dl wrote:

Unfortunately, there is nothing we youtube-dl developers can do if your distribution serves a really outdated version.

This says it. Unfortunately the version provided by Debian is always old (so this isn't a BunsenLabs bug), and youtube changes its interface so often that youtube-dl has to be constantly updated to keep up with it.

You could follow the website's recommended manual install procedure, though I prefer to install it in my personal ~/bin directory where it can be run, and updated, without using sudo.
Like this:

wget https://yt-dl.org/downloads/latest/youtube-dl -O ~/bin/youtube-dl
chmod +x ~/bin/youtube-dl

Make sure your PATH variable includes ~/bin. eg:

john@helium:~$ echo $PATH
/home/john/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

If /home/user/bin is missing, add it in ~/.xsessionrc:

# set PATH so it includes user's private bin if it exists
if [ -d ${HOME}/bin ] ; then
    PATH="${HOME}"/bin:"${PATH}"
fi

(BunsenLabs is already configured like this.)

Last edited by johnraff (2019-04-28 05:39:47)


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#3 2019-04-28 06:48:39

ohnonot
...again
Registered: 2015-09-29
Posts: 3,773
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

^ and from then onwards you can update youtube-dl with

youtube-dl -U

this modifies the code in-situ, security software might flag that (as a false positive).
but you can trust youtube-dl big_smile

Offline

#4 2019-04-28 07:01:01

hhh
Meep!
Registered: 2015-09-17
Posts: 7,926
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

ohnonot wrote:

^ and from then onwards you can update youtube-dl with

youtube-dl -U

this modifies the code in-situ, security software might flag that (as a false positive).
but you can trust youtube-dl big_smile

Disabled in debian lithium...

roy@TyrellCorp:~$ youtube-dl -U
Usage: youtube-dl [OPTIONS] URL [URL...]

youtube-dl: error: youtube-dl's self-update mechanism is disabled on Debian.
Please update youtube-dl using apt(8).
See https://packages.debian.org/sid/youtube-dl for the latest packaged version.

Offline

#5 2019-04-28 07:04:38

ohnonot
...again
Registered: 2015-09-29
Posts: 3,773
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

^ haven't you read what johnraff just wrote. nay, what this whole thread is about? the debian package is useless.

Offline

#6 2019-04-28 08:36:49

hhh
Meep!
Registered: 2015-09-17
Posts: 7,926
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

ohnonot wrote:

^ haven't you read what johnraff just wrote. nay, what this whole thread is about? the debian package is useless.

Joo. Why are you providing update instructions then? tongue

Offline

#7 2019-04-28 08:47:46

hhh
Meep!
Registered: 2015-09-17
Posts: 7,926
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

My bad, ohnonot. You were right, I wasn't reading the thread. I removed the debian package and used John's instructions above and all is working. Sorry for my mistake.

roy@TyrellCorp:~$ youtube-dl -U
WARNING: Assuming --restrict-filenames since file system encoding cannot encode all characters. Set the LC_ALL environment variable to fix this.
youtube-dl is up-to-date (2019.04.24)
roy@TyrellCorp:~$ 

Offline

#8 2019-04-28 15:05:18

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 708

Re: [NOTABUG]youtube-dl version 2017.05.18.1

Try the version in DMO? I use the DMO version of yt-dl as they build it pretty often.


Real Men Use Linux

Offline

#9 2019-04-28 19:55:09

ohnonot
...again
Registered: 2015-09-29
Posts: 3,773
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

^ what's DMO?

Offline

#10 2019-04-28 21:41:00

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 708

Re: [NOTABUG]youtube-dl version 2017.05.18.1

ohnonot wrote:

^ what's DMO?

Deb-multimedia dot org.


Real Men Use Linux

Offline

#11 2019-04-29 00:54:44

stevep
MX Linux Developer
Registered: 2016-08-08
Posts: 367

Re: [NOTABUG]youtube-dl version 2017.05.18.1

QMPlay2 and youtube-dl-gui also can download, install, and run an internal version of youtube-dl. QMPlay2 does the initial install and updates automatically.

https://build.opensuse.org/package/show … mplay2-qt5
https://build.opensuse.org/package/show … outube-dlg

Offline

#12 2019-04-29 04:00:32

hhh
Meep!
Registered: 2015-09-17
Posts: 7,926
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

@stevep, great!

Offline

#13 2019-04-29 05:45:21

ohnonot
...again
Registered: 2015-09-29
Posts: 3,773
Website

Re: [NOTABUG]youtube-dl version 2017.05.18.1

i heard that deb-multimedia.org is not recommended (anymore).

in any case, youtube-dl really needs to be up-to-date on an almost daily basis. no maintainer packaging, however frequent, can achieve that.

it has happened to me at least half a dozen times that from one day to another youtube-dl stopped working (usually with youtube, they like to play that game), and a git pull made it work again.

so either directly clone the git repo (on archlinux, the AUR package youtube-dl-git can do that for you) or use youtube-dl's builtin -U functionality.

Offline

#14 2019-05-04 05:30:29

pamir
Member
Registered: 2018-02-02
Posts: 43

Re: [NOTABUG]youtube-dl version 2017.05.18.1

wget https://yt-dl.org/downloads/latest/youtube-dl -O ~/bin/youtube-dl
chmod +x ~/bin/youtube-dl

Johnraff above way works perfectly, nothing else to be done. Thank you.

youtube-dl -U

Then keeps that updated.

Offline

Board footer

Powered by FluxBB