You are not logged in.

#1 2019-03-27 01:53:37

mgant
New Member
Registered: 2019-03-26
Posts: 1

[INVALID] Cisco AnyConnect Routing Issues

**Edit** I'm withdrawing my question. After trying some other things that still didn't help, I decided to switch distributions sad (sorry). With another distro it is now working.


I am stumped trying to get anyconnect to work properly. This is a new install on a recently acquired netbook. I also have anyconnect installed on a Fedora 29 desktop that works perfectly.

Here's the problem: anyconnect runs and connects to the vpn server but, when I try to connect to a computer on the vpn via ssh it times out trying to connect. I believe that DNS is working because if I run,

$ ping some_computer

where some_computer is a host on the vpn, the correct IP address is found by ping but 0 packets are received.

My IT department thinks that the certificated isn't installed correctly but I think it is otherwise it would never connect to the vpn server.

I've searched the internet and found these pages for installing and running anyconnect on Debian (and Debian based distros)

http://www.socsci.uci.edu/~jstern/uci_v … index.html

and others which all have similar instructions. Nothing has worked so far. I really believe this is a route issue. So I compared 'ip route' with my desktop and with my netbook and there are some slight differences but I can't find any information that would tell me whether these are important/significant. Here's the 'ip route' output:

desktop:

default dev cscotun0 proto unspec scope link notify
default via 10.0.0.1 dev enp4s0 proto dhcp metric 100
x.x.x.x via 10.0.0.1 dev enp4s0 proto unspec notify
10.0.0.1 dev enp4s0 proto unspec scope link notify
x.x.x.x/23 dev cscotun0 proto kernel scope link src x.x.x.x

netbook:

default dev cscotun0 proto none scope link notify
default via 10.0.0.1 dev wlp2s0 proto static metric 600
x.x.x.x via 10.0.0.1 dev wlp2s0 proto none notify
10.0.0.1 dev wlp2s0 proto none scope link notify
x.x.x.x/23 dev cscotun0 proto kernel scope link src x.x.x.x

(Note I have intentially removed some IP addresses but they are the same on both).

Obviously, the netbook is using wifi but when I switch my desktop to wifi it still works. What is the difference between 'proto unspec' and 'proto none'? The one difference that I think may be significant is the second line where it 'proto dhcp' on the desktop and 'proto static' on the netbook. Both are using dhcp to configure the network interface but is this significant?

I know this isn't a lot to go on but any help would be greatly appreciated.

-Mike

Last edited by mgant (2019-03-28 02:40:36)

Offline

Board footer

Powered by FluxBB