You are not logged in.

#1 2019-01-19 13:17:52

brian7ng
New Member
Registered: 2019-01-19
Posts: 4

Iconfonts (NERD fonts) not showing

Hi,

I'm on a fresh installation of Helium using VMWare.

I'm trying to make the icon fonts working but it seems only Firefox can show the icon. Other applications (text editor, terminator ...) are only showing the square.

The fonts are downloaded on nerd fonts github repository. My locale is en_US.UTF8.

Is there anywhere I can take a look to solve this issue?

Thanks.

Offline

#2 2019-01-20 11:55:44

ohnonot
...again
Registered: 2015-09-29
Posts: 3,584
Website

Re: Iconfonts (NERD fonts) not showing

this is a little thin.
please show us exactly (commands entered, output received) how you installed the font and from where, and how you can show the icon in firefox but not in ... which other applications?

Offline

#3 2019-01-20 12:42:18

S7.L
Member
Registered: 2018-09-16
Posts: 338

Re: Iconfonts (NERD fonts) not showing

Offline

#4 2019-01-20 16:51:16

brian7ng
New Member
Registered: 2019-01-19
Posts: 4

Re: Iconfonts (NERD fonts) not showing

ohnonot wrote:

this is a little thin.
please show us exactly (commands entered, output received) how you installed the font and from where, and how you can show the icon in firefox but not in ... which other applications?

The nerd fonts are popular patched fonts:
https://github.com/ryanoasis/nerd-fonts

I'm using it with Oh-my-zsh.
The fonts are installed under ~/.fonts, and I also did the font cache refresh.

sudo dpkg-reconfigure fontconfig fontconfig-config

To test the font I install fontforge, open the patched font, and try copying a character to terminal (terminator), the icon is notshown, on firefox it can display normally. I did the same test with Geany.

I have no clue where to look at this issue honestly. I use the same font under Ubuntu without any special configuration (just choosing the font for terminal and it works).

Last edited by brian7ng (2019-01-20 16:51:53)

Offline

#5 2019-01-22 06:08:27

ohnonot
...again
Registered: 2015-09-29
Posts: 3,584
Website

Re: Iconfonts (NERD fonts) not showing

which characters? other fonts also contain unicode characters.
which fonts do firefox/terminator/geany use?
can you select the desired font in a font selection dialog?
Have a look at this Quick Search (tm), esp. the first result. looks like it might have sth to do with locale.

Offline

#6 2019-01-24 01:51:09

brian7ng
New Member
Registered: 2019-01-19
Posts: 4

Re: Iconfonts (NERD fonts) not showing

ohnonot wrote:

which characters? other fonts also contain unicode characters.
which fonts do firefox/terminator/geany use?
can you select the desired font in a font selection dialog?
Have a look at this Quick Search (tm), esp. the first result. looks like it might have sth to do with locale.

Firefox is using Noto Sans Serif. And I'm using Noto Sans in Font configuration for most of things.

Geany, Terminator are configured to use Iosevka Nerd Fonts (which including many glyphs).

The example glyph which not showing is https://emojipedia.org/spouting-whale.

I'm not sure the locale is an issue, because mine is en_US.UTF-8.

locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

My fontconfig is:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit mode="assign" name="hinting" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="autohint" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="hintstyle" >
            <const>hintslight</const>
        </edit>
        <edit mode="assign" name="rgba" >
            <const>rgb</const>
        </edit>
        <edit mode="assign" name="antialias" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="lcdfilter">
            <const>lcddefault</const>
        </edit>
    </match>

<!--
    This section allows the user to define the fonts used for the
    "serif", "sans-serif" and "monospace" aliases.

    These aliases can then be set in lxappearance (the theme-changing
    GUI used by BunsenLabs) and also in individual programs to allow
    this file to be used for desktop-wide font configuration.

    By default, BunsenLabs uses one of these aliases everywhere
    a font needs to be specified. Set your favourite fonts here
    to ensure consistency across your working environment.
    You can still change fonts on a per-application basis if you want.
-->

    <alias>
        <family>serif</family>
        <prefer>
            <family>Noto Serif</family>
        </prefer>
    </alias>
    <alias>
        <family>sans-serif</family>
        <prefer>
            <family>Noto Sans</family>
        </prefer>
    </alias>
    <alias>
        <family>monospace</family>
        <prefer>
            <family>Iosevka</family>
        </prefer>
    </alias>

</fontconfig>

However, when I install the package fonts-symbola, the missing glyphs are showing correctly, but it's not having any color as I tested with default Ubuntu install.

Offline

#7 2019-01-24 07:11:45

ohnonot
...again
Registered: 2015-09-29
Posts: 3,584
Website

Re: Iconfonts (NERD fonts) not showing

brian7ng wrote:

I'm not sure the locale is an issue, because mine is en_US.UTF-8.

did you read beyond the first solution of the first search result?
things you haven't commented on so far:

  • terminator has settings that might pertain to your situation, both in context menu and the rather voluminous preferences.

  • what are your locale settings really? see e.g. here (scroll down to "Locale" and show us some output. Maybe try some of the things suggested there.

Most search results look pretty old to me; that can be a sign of you having messed something up that nobody else experiences.

try if it works beter when you move your fontconfig out of the way (not sure if log out/in is required).
also try to just use "serif", "sans-serif" and "monospace" fonts in geany etc.
in general, try more (and tell us about it).

forgot to ask: when you choose one of the nerd fonts in a gtk font choosing dialog, can you see the desired glyphs in it?

Offline

#8 2019-01-24 07:19:21

brian7ng
New Member
Registered: 2019-01-19
Posts: 4

Re: Iconfonts (NERD fonts) not showing

Hey ohnonot,

Thank you for your response.

I did more research with the keyword colorful "Emoji" and it turns out the package fonts-noto-color-emoji is what I need, also a reboot (or re-login) is required. The package is on sid btw.

Offline

Board footer

Powered by FluxBB