You are not logged in.

#1 2019-01-02 23:12:51

johnha
Member
Registered: 2018-07-01
Posts: 6

[SOLVED] Icons not working in my .desktop file

For some reason it doesn't look like the icons are working in my .desktop files. I made one for firefox-nightly, and I checked the path for the icons but in tint2, it just shows a generic round cog instead of the actual icon.

Anyone encounter this also?

cat > ~/.local/share/applications/firefox-nightly.desktop <<EOT
[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Terminal=false
Exec=~/bin/firefox/firefox
Name=Firefox-Nightly
Icon=~/bin/firefox/browser/chrome/icons/default/default64.png
EOT

Offline

#2 2019-01-02 23:44:51

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,281

Re: [SOLVED] Icons not working in my .desktop file

You can't use shell expansion '~' in .desktop files (Exec= is a bit more special). You always must specify the full, absolute paths or an icon name from an icon theme (without a leading slash). See https://standards.freedesktop.org/deskt … atest.html:

Icon

Icon to display in file manager, menus, etc. If the name is an absolute path, the given file will be used. If the name is not an absolute path, the algorithm described in the Icon Theme Specification will be used to locate the icon.


Im grünen Wald, dort wo die Drossel singt…

Offline

#3 2019-01-03 01:55:53

johnha
Member
Registered: 2018-07-01
Posts: 6

Re: [SOLVED] Icons not working in my .desktop file

Ah, thank you so much @twoion!

Offline

Board footer

Powered by FluxBB