You are not logged in.

#1 2018-11-19 01:39:34

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 183
Website

Wine: I need it to look like Vista or later

Hi there everyone!

I'm trying to run UIforETW and it spits out the error on startup:

ETW Tracing requires Windows Vista or above.

I'm wondering how I can(or if I'm even able to) have it look like a Vista or later Win install.

Any thoughts would be greatly appreciated!


Schw.im! A social site with an identity crisis.

Offline

#2 2018-11-19 04:04:15

nore
>2⁹
From: blueberry bush
Registered: 2015-09-29
Posts: 389

Re: Wine: I need it to look like Vista or later

Have you tried

winecfg

Offline

#3 2018-11-19 13:13:31

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 183
Website

Re: Wine: I need it to look like Vista or later

Thanks a bunch for the help!

That got me past the version mismatch and right into a missing Windows SDK element.  Tried running the SDK installer and that just doesn't even open. Power of Wine, I guess.

Thanks again!


Schw.im! A social site with an identity crisis.

Offline

#4 2018-11-19 13:34:37

nore
>2⁹
From: blueberry bush
Registered: 2015-09-29
Posts: 389

Re: Wine: I need it to look like Vista or later

Maybe winetricks could help you past SDK installation? Never tried it myself, though.

Offline

#5 2018-11-19 13:47:33

earlybird
ほやほや
Registered: 2015-12-16
Posts: 605
Website

Re: Wine: I need it to look like Vista or later

If you need to run SDKs whose APIs may penetrate right through to kernel APIs largely unused by desktop applications, running a Windows 7 VM or so would almost be preferable as coverage of such APIs by wine is almost exclusively driven by requirements of more popular applications like Office and not a holistic approach to API coverage. Perhaps ReactOS can run your stuff?

Offline

Board footer

Powered by FluxBB