You are not logged in.

#1 2015-11-03 16:52:24

pyraylos
Member
Registered: 2015-11-02
Posts: 7

[SOLVED] keyring popup window

hi. i've been using this distro for a couple of months with autologin enabled. yesterday i installed geary and now everytime the laptop boots up a message appears:
"The login keyring did not get unlocked when you logged in your computer."
when i disable autologin the message doesn't popup again, but i want autologin to be enabled. how to solve this?

Last edited by pyraylos (2015-11-05 08:52:34)

Offline

#2 2015-11-03 18:14:07

damo
....moderator....
Registered: 2015-08-20
Posts: 6,703

Re: [SOLVED] keyring popup window

Have you edited your autostart?


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2015-11-03 18:23:37

pyraylos
Member
Registered: 2015-11-02
Posts: 7

Re: [SOLVED] keyring popup window

yes i had made an entry in autostart but i removed it and i got the same message.

Offline

#4 2015-11-03 18:30:07

hhh
Meep!
Registered: 2015-09-17
Posts: 12,206
Website

Re: [SOLVED] keyring popup window

Try backing up the file ~/.local/share/login.keyring, delete the original and logout/login/logout/login.

Offline

#5 2015-11-03 18:31:22

damo
....moderator....
Registered: 2015-08-20
Posts: 6,703

Re: [SOLVED] keyring popup window

pyraylos wrote:

yes i had made an entry in autostart but i removed it and i got the same message.

Do you still have

## GNOME PolicyKit and Keyring
eval $(gnome-keyring-daemon -s --components=pkcs11,secrets,ssh,gpg) &

## for authentication
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 & 

Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#6 2015-11-03 18:36:21

ohnonot
...again
Registered: 2015-09-29
Posts: 5,554

Re: [SOLVED] keyring popup window

please post you autostart here, as it is, with the problem happening.
please use code tags for code.


Give to COVAX! Here or here. (explanation)

Offline

#7 2015-11-03 19:00:24

pyraylos
Member
Registered: 2015-11-02
Posts: 7

Re: [SOLVED] keyring popup window

Do you still have

## GNOME PolicyKit and Keyring
eval $(gnome-keyring-daemon -s --components=pkcs11,secrets,ssh,gpg) &

## for authentication
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 & 

yes these 2 entries are there. i did what hhh suggested, but all i got was a message to enter new keyring passwd. message still appears. reverted back to backup file. here's the autostart file:

## Openbox autostart
## ====================
## When you login to your BunsenLabs Openbox session, this autostart script
## will be executed to set-up your environment and launch any applications
## you want to run at startup.
##
## Note: some programs, such as 'nm-applet' are run via XDG autostart.
## Run
## /usr/lib/i386-linux-gnu/openbox-xdg-autostart --list
## or
## /usr/lib/x86_64-linux-gnu/openbox-xdg-autostart --list
## to list any XDG autostarted programs.
##
## More information about this can be found at:
## http://openbox.org/wiki/Help:Autostart
##
## If you do something cool with your autostart script and you think others
## could benefit from your hack, please consider sharing it at:
## http://bunsenlabs.org
##

## GNOME PolicyKit and Keyring
eval $(gnome-keyring-daemon -s --components=pkcs11,secrets,ssh,gpg) &

## for authentication
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &

## Set root window colour
#hsetroot -solid "#2E3436" &

nitrogen --restore &

bl-compositor --start &

## Start the tint2 session (the default tint2 will run if no sessions have been set)
(sleep 2s; bl-tint2-session) &

## Start the Conky session (the default conkyrc will run if no sessions have been set)
#(sleep 2s; bl-conky-session --autostart) &

## Volume control for systray
(sleep 2; volti) &

## Volume keys daemon
xfce4-volumed &

## Start Clipboard manager
(sleep 3; clipit) &

## Start Thunar Daemon, if set as bl-file-manager
if [ "$(readlink -f $(which bl-file-manager))" = "$(which thunar)" ]
then
    thunar --daemon &
fi

## Enable power management
xfce4-power-manager &

## Start the battery applet
(sleep 2; fdpowermon) &

## Start xscreensaver (light-locker now used by default, run via XDG autostart.)
#xscreensaver -no-splash &

## Detect and configure touchpad. See 'man synclient' for more info.
#if egrep -iq 'touchpad' /proc/bus/input/devices; then
#    synclient VertEdgeScroll=1 &
#    synclient HorizEdgeScroll=1 &
#    synclient TapButton1=1 &
#fi

## Set keyboard settings - 250 ms delay and 25 cps (characters per second) repeat rate.
## Adjust the values according to your preferances.
xset r rate 250 25 &

## Turn on/off system beep
xset b off &

## bl-welcome - post-installation script, will not run in a live session and
## only runs once. Safe to remove.
#(sleep 10; bl-welcome --firstrun) &

## bl-fortune - have the system come up with a little adage (not yet enabled)
#(sleep 120; bl-fortune) &

fbxkb &
tpb -d &
iceweasel &

Offline

#8 2015-11-03 19:07:07

hhh
Meep!
Registered: 2015-09-17
Posts: 12,206
Website

Re: [SOLVED] keyring popup window

What if you just leave the password field empty and click OK?

Source (last line of article)...
http://ubuntuhandbook.org/index.php/201 … ntu-13-04/

Offline

#9 2015-11-03 19:13:31

hhh
Meep!
Registered: 2015-09-17
Posts: 12,206
Website

Re: [SOLVED] keyring popup window

Here's a bug report with a workaround, see if that fixes it...
https://bugs.launchpad.net/ubuntu/+sour … ug/1022322

Offline

#10 2015-11-03 20:05:17

pyraylos
Member
Registered: 2015-11-02
Posts: 7

Re: [SOLVED] keyring popup window

i had no luck with the workaround. i discovered that geary autostarts at boot without having an entry in autostart. can i at least disable this so that i get the keyring message only when i start geary?

Offline

#11 2015-11-03 20:14:53

damo
....moderator....
Registered: 2015-08-20
Posts: 6,703

Re: [SOLVED] keyring popup window

pyraylos wrote:

i had no luck with the workaround. i discovered that geary autostarts at boot without having an entry in autostart. can i at least disable this so that i get the keyring message only when i start geary?

Do you mean "geany"? How did you install it?


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#12 2015-11-03 20:19:18

pyraylos
Member
Registered: 2015-11-02
Posts: 7

Re: [SOLVED] keyring popup window

no, i mean geary mail. i think i got it with apt-get.

Offline

#13 2015-11-03 20:31:47

hhh
Meep!
Registered: 2015-09-17
Posts: 12,206
Website

Re: [SOLVED] keyring popup window

Ah, I misread it as geany in your OP, that one letter makes a big difference!

Offline

#14 2015-11-03 20:33:43

damo
....moderator....
Registered: 2015-08-20
Posts: 6,703

Re: [SOLVED] keyring popup window

Is there a geary Preferences setting to remember your password?


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#15 2015-11-03 20:44:43

pyraylos
Member
Registered: 2015-11-02
Posts: 7

Re: [SOLVED] keyring popup window

i wrote geany at first but then corrected it. no option to remember passwd but theres an option for notify for new mail. i disabled this and it works. well better this solution than nothing i guess. thanks everybody for your help.

Offline

#16 2015-11-04 06:45:56

ohnonot
...again
Registered: 2015-09-29
Posts: 5,554

Re: [SOLVED] keyring popup window

geany != geary.

that really explains it all.
it has nothing to do with your current autostart.

geary = GNOME software.

it has most probably installed loads of dependencies, amongst which things relating to authentication.
it must have credentials from you so it can look at your email account.

what do you actually do once you get that keyring popup?

( if you think this is solved already, please mark it so by editing your first post's headline )


Give to COVAX! Here or here. (explanation)

Offline

#17 2015-11-04 10:59:45

pyraylos
Member
Registered: 2015-11-02
Posts: 7

Re: [SOLVED] keyring popup window

i enter the keyring passwd(that i set up the first time it poped up) and goes away.

Offline

#18 2015-11-04 17:24:26

ohnonot
...again
Registered: 2015-09-29
Posts: 5,554

Re: [SOLVED] keyring popup window

pyraylos wrote:

i enter the keyring passwd(that i set up the first time it poped up) and goes away.

and that is exactly how it is supposed to be.
by unlocking that keyring you are allowing geary to access your email account.

in times long past, i simply entered an empty password (=press enter twice), and despite complaining about insecure storage, it accepted that. however, i remember that it was kind of difficult to achieve this once i had entered a real password.


Give to COVAX! Here or here. (explanation)

Offline

#19 2015-11-05 12:03:16

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,283
Website

Re: [SOLVED] keyring popup window

ohnonot wrote:
pyraylos wrote:

i enter the keyring passwd(that i set up the first time it poped up) and goes away.

and that is exactly how it is supposed to be.

This.

With autologin you never get to enter your password (that's the point of autologin) but as a result gnome-keyring has nothing with which to unlock your keyring. A keyring without any password protection is pretty pointless after all. Basically, you can't have an automatically-opened keyring together with autologin.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

Board footer

Powered by FluxBB