You are not logged in.

#1 2018-07-18 10:16:54

jimjamz
Member
From: Nagasaki, Japan
Registered: 2016-04-04
Posts: 66

[SOLVED] Performance issues with bl-exit

I'm running BL Helium in as a Virtualbox guest VM.

When I select the 'exit' option from the context menu, the CPU usage immediately increases to 100% and never returns to normal levels.

2018-07-18-09-20-04_scrot.png

The fading gradient of the bl-exit panel gradually comes through very slowly and seems to be updated once every few minutes.  Yet, even when the bl-exit panel seems to be fully available, I cannot select any option.  Although the system appears to be entirely frozen, the only thing that seems to work is the conky menu, which is able to show the correct CPU usage and the uptime is updated correctly every 1 second.

2018-07-18-11-03-18_scrot.png

I notice that the tooltip in the top-left has also changed by hovering over the X browser icon but I cannot seem to make it change again.  I suspect I had left the mouse cursor hovering over the icon for a very long time.  Hovering my mouse over any other icon in that area does not change it a third time.

Last edited by jimjamz (2018-08-23 04:55:57)

Offline

#2 2018-08-21 13:56:06

jimjamz
Member
From: Nagasaki, Japan
Registered: 2016-04-04
Posts: 66

Re: [SOLVED] Performance issues with bl-exit

Is there a way to disable bl-exit?  This seems to be the root cause of the problem but I cannot diagnose why (nothing in syslog).  When launching bl-exit from the context menu option, 'Exit, the CPU usage rockets to 100% and never idles.

Or perhaps I can change the 'Exit' option on the context menu to simply invoke 'sudo poweroff''?

Offline

#3 2018-08-21 17:05:23

malm
jgmenu developer
Registered: 2016-10-13
Posts: 228
Website

Re: [SOLVED] Performance issues with bl-exit

Not sure what the problem is.
Until it’s sorted, the easiest solution might be to just run “poweroff” in a terminal or from dmenu (alt-F3)

Offline

#4 2018-08-21 17:15:00

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 820

Re: [SOLVED] Performance issues with bl-exit

How does bl-exit work if you disable compton first, then exit?

In the Scripts thread, there is a minimal exit script, you can try that. Simplified code, same options.


You must unlearn what you have learned.
    -- yoda

Offline

#5 2018-08-21 21:03:01

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: [SOLVED] Performance issues with bl-exit

jimjamz wrote:

I'm running BL Helium in as a Virtualbox guest VM.

When I select the 'exit' option from the context menu, the CPU usage immediately increases to 100% and never returns to normal levels.

https://s15.postimg.cc/w8vuy1sxn/2018-07-18-09-20-04_scrot.png

The fading gradient of the bl-exit panel gradually comes through very slowly and seems to be updated once every few minutes.  Yet, even when the bl-exit panel seems to be fully available, I cannot select any option.  Although the system appears to be entirely frozen, the only thing that seems to work is the conky menu, which is able to show the correct CPU usage and the uptime is updated correctly every 1 second.

https://s15.postimg.cc/rpo7q3sob/2018-07-18-11-03-18_scrot.png

I notice that the tooltip in the top-left has also changed by hovering over the X browser icon but I cannot seem to make it change again.  I suspect I had left the mouse cursor hovering over the icon for a very long time.  Hovering my mouse over any other icon in that area does not change it a third time.

There is an alpha fade in going on there that sounds like it's smashing your computer. You can try to run the Classic BL-exit by adjusting the theme settings. Go to ~/.config/bl-exit/blexitrc and set the theme entry to Classic and see if that helps.

Offline

#6 2018-08-22 06:30:54

jimjamz
Member
From: Nagasaki, Japan
Registered: 2016-04-04
Posts: 66

Re: [SOLVED] Performance issues with bl-exit

@malm - I know I could do this, and I usually do when I remember.  However, I have a habit of going to the context menu and selecting 'Exit'.  And I only remember once I've already selected it and frozen the system smile

@PackRat - I'm not familiar with compton or disabling it.  I found the .config/compton.conf but it seems one can only disable individual components (shadows, opacity, fading etc...).  Is there a a more generic and recommended way to stop or disable it?

@tknomanzr - I did look for ~/.config/bl-exit/blexitrc but was unable to find it.  The closest I could find was ~/.config/bunsen/bl-welcome, but nothing for bl-exit under ~/.config.

Offline

#7 2018-08-22 07:12:50

dolly
Miss Mixunderstand
From: /lab1
Registered: 2015-10-03
Posts: 343

Re: [SOLVED] Performance issues with bl-exit

One can easily disable the compositor from the right click menu. Preferences/Compositor/Disable Compositing, or # it out in the autostart file.


Keep BunsenLabs #!yish please.

Offline

#8 2018-08-22 12:08:20

jimjamz
Member
From: Nagasaki, Japan
Registered: 2016-04-04
Posts: 66

Re: [SOLVED] Performance issues with bl-exit

dolly wrote:

One can easily disable the compositor from the right click menu. Preferences/Compositor/Disable Compositing, or # it out in the autostart file.

D'oh! So easy - I did not even know that option existed on the context menu.  It just proves that I never go into that area smile thanks!

Offline

#9 2018-08-22 17:17:36

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: [SOLVED] Performance issues with bl-exit

jimjamz wrote:

@malm - I know I could do this, and I usually do when I remember.  However, I have a habit of going to the context menu and selecting 'Exit'.  And I only remember once I've already selected it and frozen the system smile

@PackRat - I'm not familiar with compton or disabling it.  I found the .config/compton.conf but it seems one can only disable individual components (shadows, opacity, fading etc...).  Is there a a more generic and recommended way to stop or disable it?

@tknomanzr - I did look for ~/.config/bl-exit/blexitrc but was unable to find it.  The closest I could find was ~/.config/bunsen/bl-welcome, but nothing for bl-exit under ~/.config.

~/.config/bl-exit/bl-exit/bl-exitrc is the file you are looking for. When set to Classic, it will default back to the old Crunchbang style menu, which is considerably less resource hungry than the Helium theme.

Offline

#10 2018-08-23 00:50:52

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 4,675
Website

Re: [SOLVED] Performance issues with bl-exit

BunsenLabs does not install .config/bl-exit in skel (and hence users' home directories) so the app default settings are used. Users can change that by copying /etc/bl-exit to ~/.config and then editing ~/.config/bl-exit/bl-exitrc
The theme setting is on line 56: set it to classic.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Online

#11 2018-08-23 04:54:43

jimjamz
Member
From: Nagasaki, Japan
Registered: 2016-04-04
Posts: 66

Re: [SOLVED] Performance issues with bl-exit

Thanks guys and girls for all the suggestions.  Before trying to disable Compton, I copied the bl-exitrc from /etc/bl-exit to ~/.config/bl-exit/bl-exitrc and changed line 56's value to classic.

Now, when selecting Exit from the context menu, I see the classic version of the dialog box and the system no longer locks up.
I'm not sure what caused the original problem, but I appreciate this solution.  Thanks for all your suggestions!

Offline

#12 2018-08-23 05:04:17

ohnonot
...again
Registered: 2015-09-29
Posts: 3,197
Website

Re: [SOLVED] Performance issues with bl-exit

fwiw, the old cb-exit is much simpler and still available:
https://github.com/super-nathan/cb-exit
"sudo reboot" and "sudo shutdown" probably need to be replaced by "systemctl reboot" and "systemctl shutdown".

Offline

#13 2018-08-23 22:46:51

hhh
That's easy!
Registered: 2015-09-17
Posts: 6,106
Website

Re: [SOLVED] Performance issues with bl-exit

@ohnonot, nice find!

Offline

#14 2018-08-26 15:48:18

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 541

Re: [SOLVED] Performance issues with bl-exit

ohnonot wrote:

fwiw, the old cb-exit is much simpler and still available:
https://github.com/super-nathan/cb-exit
"sudo reboot" and "sudo shutdown" probably need to be replaced by "systemctl reboot" and "systemctl shutdown".

Nice, I remember that one and is it useful with Fluxbox as well?

Last edited by DeepDayze (2018-08-26 15:48:49)


Real Men Use Linux

Offline

#15 2018-08-28 04:52:56

ohnonot
...again
Registered: 2015-09-29
Posts: 3,197
Website

Re: [SOLVED] Performance issues with bl-exit

^ yes.

Offline

Board footer

Powered by FluxBB