You are not logged in.

#1 2018-06-26 10:59:02

wammes
Member
From: Krupka, ČR
Registered: 2018-06-23
Posts: 27
Website

Texmaker SOLVED

I wanted to install texmaker but it draws in all texlive packages as dependencies. I do not want that, since I don’t use texlive. I use MikTex instead. Does anybody know a way to install texmaker without texlive? I know it works perfectly with MikTex. Thanks in advance.

Last edited by wammes (2018-06-26 16:08:37)

Offline

#2 2018-06-26 11:30:02

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 1,816
Website

Re: Texmaker SOLVED

Perhaps

apt install texmaker --no-install-recommends

Offline

#3 2018-06-26 13:17:37

wammes
Member
From: Krupka, ČR
Registered: 2018-06-23
Posts: 27
Website

Re: Texmaker SOLVED

Nope. Still wants to install all texlive dependencies. Weird! I ended up installing the deb file from the texmaker site. Gdebi confirmed that all dependencies were met wink As they are. I think it's very weird that texmaker in the Debian repositories -forces- you to  use texlive.

Offline

#4 2018-06-26 13:45:33

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2015-09-29
Posts: 643

Re: Texmaker SOLVED

^Strange ... The command by brontosaurex shouldn't install texlive, as seen by this:

$ apt-cache depends texmaker | grep texlive
  Recommends: texlive-latex-extra
  Recommends: texlive-lang-english
  Suggests: texlive-lang-all

OTOH, just tried on BL (in VBox):

$ sudo apt --no-install-recommends install texmaker
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libpoppler-qt5-1 libqt5concurrent5 libqt5opengl5 libqt5printsupport5 libqt5qml5
  libqt5quick5 libqt5script5 libqt5sql5 libqt5webkit5 libqt5xml5 libsynctex1
  texmaker-data
Suggested packages:
  qt5-qmltooling-plugins texlive-lang-all
Recommended packages:
  libqt5sql5-sqlite | libqt5sql5-mysql | libqt5sql5-odbc | libqt5sql5-psql
  | libqt5sql5-tds | libqt5sql5-ibase netpbm psutils latex-beamer
  texlive-latex-extra texlive-lang-english hunspell-en-us | hunspell-dictionary
  | myspell-dictionary asymptote
The following NEW packages will be installed:
  libpoppler-qt5-1 libqt5concurrent5 libqt5opengl5 libqt5printsupport5 libqt5qml5
  libqt5quick5 libqt5script5 libqt5sql5 libqt5webkit5 libqt5xml5 libsynctex1
  texmaker texmaker-data
0 upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
Need to get 17.4 MB of archives.
After this operation, 65.0 MB of additional disk space will be used.
Do you want to continue? [Y/n]

It doesn't install full texlive suite .... Perhaps you have something else which somehow requires full texlive?


Postpone all your duties; if you die, you won't have to do them ..

Offline

#5 2018-06-26 16:01:41

wammes
Member
From: Krupka, ČR
Registered: 2018-06-23
Posts: 27
Website

Re: Texmaker SOLVED

Indeed, this is weird. I have no idea what other package has a need for texlive. Anyways, the installed texmaker deb file works perfectly with my MikTex install. Thanks for trying. I’ll check it myself in a virtual machine when I have time. Again, thanks. Glad to see that apt behaves as expected wink

Offline

Board footer

Powered by FluxBB