You are not logged in.

#1 2018-06-11 11:26:35

pamir
Member
Registered: 2018-02-02
Posts: 31

disable touchpad while typing not working on all methods.

I have an annoying setup where on the laptop the slightest movement causes the touchpad to go crazy.

I just want to disbale touchpad while typing. On boot up Bunsenlabs standard configuration in autostart does not work every boot up.

I correctly was told on the forum to
edit autostart and comment out the command

## synclient VertEdgeScroll=1 HorizEdgeScroll=1 TapButton1=1 2>/dev/null
and comment out
## Disable touchpad while typing
## syndaemon -i 1 -K -t -R -d &


then in terminal
sudo mkdir -p /etc/X11/xorg.conf.d
sudo cp /usr/share/X11/xorg.conf.d/70-synaptics.conf /etc/X11/xorg.conf.d
sudo geany /etc/X11/xorg.conf.d/70-synaptics.conf

edit to have:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-t … rrors.html
#       MatchDevicePath "/dev/input/event*"

        Option "VertEdgeScroll" "1"
        Option "HorizEdgeScroll" "1"
        Option "TapButton1" "1"
        Option "VertTwoFingerScroll"   "0"
        Option "HorizTwoFingerScroll"  "0"
        Option "DisableWhileTyping" "1"
EndSection

The problem is that whilst all the options VertEdgeScroll, HorizEdgeScroll, TapButton1, VertTwoFingerScroll,HorizTwoFingerScroll work.

The problem is DisableWhileTyping does notnwork, also :

Option "PalmDetect" "1"

does not work too.

So the only method that works is to set :

Option "TapButton1" "0"

This does work.

Any help would be apprciated.

Offline

#2 2018-06-11 21:43:16

stevep
MX Linux Developer
Registered: 2016-08-08
Posts: 327

Re: disable touchpad while typing not working on all methods.

Have you tried touchpad-indicator?  http://mxrepo.com/mx/repo/pool/main/t/t … indicator/

Offline

#3 2018-06-12 04:20:18

ohnonot
...again
Registered: 2015-09-29
Posts: 3,190
Website

Re: disable touchpad while typing not working on all methods.

not all touchpads (drivers) implement all features i believe.

is this even a synaptics touchpad?
https://wiki.debian.org/SynapticsTouchp … f_Touchpad

pamir wrote:

on the laptop the slightest movement causes the touchpad to go crazy.

movement of what? your hands on the keyboard? the laptop itself?
sounds like there's something wrong with your hardware.

PS: some info about the laptop please.

Last edited by ohnonot (2018-06-12 04:29:30)

Offline

#4 2018-06-12 13:20:06

pamir
Member
Registered: 2018-02-02
Posts: 31

Re: disable touchpad while typing not working on all methods.

ohnonot wrote:

not all touchpads (drivers) implement all features i believe.

is this even a synaptics touchpad?
https://wiki.debian.org/SynapticsTouchp … f_Touchpad

pamir wrote:

on the laptop the slightest movement causes the touchpad to go crazy.

movement of what? your hands on the keyboard? the laptop itself?
sounds like there's something wrong with your hardware.

PS: some info about the laptop please.


Ohnonot, you are completely right.

is this even a synaptics touchpad? It appears to be Elantech

so i ran in terminal:
grep -i pad /proc/bus/input/devices

N: Name="ELAN1200:00 04F3:3022 Touchpad"

It is a ASUS Zenbook Flip UX360UA-DQ143T. I then did:

xinput list

which results:
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ ELAN1200:00 04F3:3022 Touchpad              id=13    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Asus Wireless Radio Control                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                   id=8    [slave  keyboard (3)]
    ↳ Sleep Button                                id=9    [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                        id=10    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                            id=11    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=12    [slave  keyboard (3)]

then in terminal i did :

xinput list-props 13

which results:

Device 'ELAN1200:00 04F3:3022 Touchpad':
    Device Enabled (140):    1
    Coordinate Transformation Matrix (142):    1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (444):    1
    Device Accel Constant Deceleration (445):    2.500000
    Device Accel Adaptive Deceleration (446):    1.000000
    Device Accel Velocity Scaling (447):    12.500000
    Synaptics Edges (448):    128, 3072, 118, 2080
    Synaptics Finger (449):    25, 30, 0
    Synaptics Tap Time (450):    180
    Synaptics Tap Move (451):    170
    Synaptics Tap Durations (452):    180, 180, 100
    Synaptics ClickPad (453):    1
    Synaptics Middle Button Timeout (454):    0
    Synaptics Two-Finger Pressure (455):    282
    Synaptics Two-Finger Width (456):    7
    Synaptics Scrolling Distance (457):    77, 77
    Synaptics Edge Scrolling (458):    1, 1, 0
    Synaptics Two-Finger Scrolling (459):    0, 0
    Synaptics Move Speed (460):    1.000000, 1.750000, 0.051520, 0.000000
    Synaptics Off (461):    0
    Synaptics Locked Drags (462):    0
    Synaptics Locked Drags Timeout (463):    5000
    Synaptics Tap Action (464):    0, 0, 0, 0, 0, 0, 0
    Synaptics Click Action (465):    1, 3, 2
    Synaptics Circular Scrolling (466):    0
    Synaptics Circular Scrolling Distance (467):    0.100000
    Synaptics Circular Scrolling Trigger (468):    0
    Synaptics Circular Pad (469):    0
    Synaptics Palm Detection (470):    0
    Synaptics Palm Dimensions (471):    10, 200
    Synaptics Coasting Speed (472):    20.000000, 50.000000
    Synaptics Pressure Motion (473):    30, 160
    Synaptics Pressure Motion Factor (474):    1.000000, 1.000000
    Synaptics Grab Event Device (475):    0
    Synaptics Gestures (476):    1
    Synaptics Capabilities (477):    1, 0, 0, 1, 1, 0, 0
    Synaptics Pad Resolution (478):    31, 31
    Synaptics Area (479):    0, 0, 0, 0
    Synaptics Soft Button Areas (480):    1600, 0, 1802, 0, 0, 0, 0, 0
    Synaptics Noise Cancellation (481):    19, 19
    Device Product ID (266):    1267, 12322
    Device Node (265):    "/dev/input/event13"


What should i do disable touchpad whilst typing?

Last edited by pamir (2018-06-12 13:34:29)

Offline

#5 2018-06-12 17:44:26

ohnonot
...again
Registered: 2015-09-29
Posts: 3,190
Website

Re: disable touchpad while typing not working on all methods.

please use the instructions from debian wiki to determine whether this is a synaptics (compatible) touchpad or not.

pamir wrote:

What should i do disable touchpad whilst typing?

pamir wrote:

syndaemon -i 1 -K -t -R -d &

???

edit: try that command in a terminal; if the touchpad is not compatible, it should tell you.

Last edited by ohnonot (2018-06-13 03:38:54)

Offline

#6 2018-06-12 17:49:56

hhh
That's easy!
Registered: 2015-09-17
Posts: 6,093
Website

Re: disable touchpad while typing not working on all methods.

@pamir, you've been posting "Help & Support" threads in the "Development & Suggestions" forum. That forum is for discussing and developing our next major release (lithium, based on buster) as well as improvements to the current helium release.

Kindly post Help issues to the Help forum. Thanks.

-mod hhh- moving to "Basic Help & Support"

Online

Board footer

Powered by FluxBB