You are not logged in.

#1 2018-05-19 18:54:51

ghorvath
Member
Registered: 2015-10-01
Posts: 130

Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

Previously I was running Crunchbang on a very old laptop (Acer Travelmate 210, Pentium Celeron 700, 512 MB RAM, 10 GB HDD). I tried bl-Hydrogen, but for whatever reason the graphics did not work, so I migrated back to Crunchbang. However, debian wheezy support ends in May, so I desperately needed to upgrade to something.

Now Helium is out, and I tried it, and it works!!! However, it is incredibly slow. Like it took more than 10 minutes to boot for the first time, and the graphics is again slow. Opening a terminal takes more than 10 seconds.

So I was thinking about not starting graphics automatically, but only if needed for something (which is not likely, because I most probably will only use it for listening to music).

How would I go about disabling the automatic boot to graphics?

Edit: The second boot was much faster (less than 2 minutes), so I might keep the graphics after all. Still would be interested in the solution.

Last edited by ghorvath (2018-05-25 20:09:42)

Offline

#2 2018-05-19 19:04:20

cloverskull
Member
Registered: 2015-10-01
Posts: 301

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

It should be as easy as

sudo systemctl disable lightdm.service

This should prevent the desktop manager (lightdm in this case) from automatically starting.

Offline

#3 2018-05-19 19:25:53

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

ghorvath wrote:

Opening a terminal takes more than 10 seconds

Yeah that's terminator, it is insanely slow to open (bash doesn't help either).

Try a lighter alternative:

sudo apt install rxvt-unicode-256color
sudo update-alternatives --set x-terminal-emulator $(which urxvt)
ghorvath wrote:

How would I go about disabling the automatic boot to graphics?

Have you tried our "boot to CLI" option in  the GRUB menu?

Permanently disable the display manager with

sudo systemctl set-default multi-user.target

Note though that light-locker (our screenlocker) will have to be disabled or it will lock the desktop up when it activates, see https://forums.bunsenlabs.org/viewtopic.php?id=2080 for details.

If you need to re-enable the display manager use

sudo systemctl set-default graphical.target

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#4 2018-05-19 21:57:08

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2015-09-29
Posts: 520

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

@OP: I have installed BL Helium on some old HP Compaq laptop a few days ago (64 bit), and I have experienced the very same slow boot times.

Funnily enough, this advice from HoaS:

$ sudo apt-get install haveged

helped, and now boot times are normal (for the hardware in question).

See this post.

Now, it seems that there really is something going on with this entropy stuff. I don't know if this is hardware related, or what. Unfortunately, I have no enough time to look into it, but I would like to hear from OP, if he can detect 'random: crng init done' lines in 'dmesg' output, as in linked post above.

(Does this problem deserve separate topic?)


Postpone all your duties; if you die, you won't have to do them ..

Offline

#5 2018-05-19 23:29:19

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 541

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

Hopefully with @IMbecil's tip you can then retry a boot to graphical desktop. I myself have an old IBM Thinkpad T22 and with the haveged I was able to get a fairly speedy boot on that machine.


Real Men Use Linux

Offline

#6 2018-05-20 08:11:29

ghorvath
Member
Registered: 2015-10-01
Posts: 130

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

Thanks for the tip on haveged. I installed it, however I doubt that was the reason. The second boot was rather fast (well, at least comparable to how quickly Crunchnbang booted), and even the graphics was faster. And this was without the haveged. Can it not be possible that the installer does some post-installation stuff at the very first boot into the installed system?

And of course CLI is really good, no surprise there, thanks for the advice.

I will report if anything else comes up.

Thanks!

Edit: just for reference, here are the results of the random generation for the second boot, without haveged (I am not sure about the first boot):

ghorvath@acerlaptop:~$ sudo dmesg | grep random
[    1.020236] random: fast init done
[   11.674906] random: crng init done

Last edited by ghorvath (2018-05-20 08:15:09)

Offline

#7 2018-05-20 09:41:16

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2015-09-29
Posts: 520

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

^Well, the 11 seconds for 'random: crng init done' seems not so bad. On my (fast) setup, with haveged it is:

[    2.439064] random: fast init done
[    4.822719] random: crng init done

Comparing with your times, perhaps having the haveged could help with your second line, which I can confirm affects the 'graphical' boot time (I think the X needs some strong, crypto-grade, random numbers).

Note: the installation of the haveged is simple, doesn't require lot of space, and is easily and painlessly removed with

$ sudo apt-get remove --purge haveged

So it is simple to try it ...


Postpone all your duties; if you die, you won't have to do them ..

Offline

#8 2018-05-20 14:55:26

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 541

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

Also try replacing terminator with rxvt-unicode as suggested by HoaS if you find terminator opens too slow for you. On an old machine like that I doubt you can play videos without stuttering so it may be worth using that real old laptop like a netbook for basic stuff. I think LO will work OK on that machine and playing mp3's with audacious.

Is all hardware recognized?

If you want to replace the CD drive I think you can find one on eBay.

Last edited by DeepDayze (2018-05-20 14:56:39)


Real Men Use Linux

Offline

#9 2018-05-20 18:06:50

hhh
That's easy!
Registered: 2015-09-17
Posts: 6,106
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

ghorvath wrote:

Can it not be possible that the installer does some post-installation stuff at the very first boot into the installed system?

There's a note about it in the Release Announcement...

Please note that the first time the new system boots takes longer than normal as drivers and configurations initialize, subsequent boots should be quite zippy.

On my old Inspiron, the login screen and the desktop took about a minute each to load on first boot but just seconds on subsequent boots. I haven't checked the Debian Live ISOs yet, I'll try to do that tonight to see if it's something on our end that needs to be addressed.

Offline

#10 2018-05-20 19:41:50

ghorvath
Member
Registered: 2015-10-01
Posts: 130

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

hhh wrote:
ghorvath wrote:

Can it not be possible that the installer does some post-installation stuff at the very first boot into the installed system?

There's a note about it in the Release Announcement...

Please note that the first time the new system boots takes longer than normal as drivers and configurations initialize, subsequent boots should be quite zippy.

Thanks, I missed it completely! So much so, that when I first installed bl-Helium on another machine, and it gave me a black screen after the reboot, I just turned it off by a hard reset, because I thought that something went wrong. The second boot took only a couple of seconds, but now I am left wondering if the first boot has never been finished properly, and I might be better off reinstalling that system....

Offline

#11 2018-05-20 20:13:25

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

I wouldn't actually recommend haveged, the kernel should be capable of generating enough entropy and the extra program will just eat processor cycles that can't really be spared.

There are several ways of stripping down BL further, here are a few off the top of my head:

  • disable NetworkManager (and nm-applet) and use /etc/network/interfaces instead

  • disable all unwanted running programs and .services (clipit and conky can be quite hungry)

  • swap the display manager for a console login (and disable the screenlocker)

  • urxvt/mksh instead of terminator/bash


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#12 2018-05-21 05:12:15

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 4,675
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

...then fire up a system resources meter like htop (Super+H on BL) and check out the processes using the most memory. You might be able to track down some more candidates for removal.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#13 2018-05-21 05:57:40

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

^ Good idea smile

I like to use ps_mem for that sort of thing:

https://github.com/pixelb/ps_mem

It's just a python script so it doesn't need installing:

sudo apt install git
git clone https://github.com/pixelb/ps_mem && cd ps_mem
sudo ./ps_mem.py

EDIT: please *do not* download random scripts and run them as root unless you have read and understood them.

Last edited by Head_on_a_Stick (2018-05-21 05:59:27)


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#14 2018-05-21 05:59:29

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

ghorvath wrote:

Thanks for the tip on haveged. I installed it, however I doubt that was the reason. The second boot was rather fast (well, at least comparable to how quickly Crunchnbang booted), and even the graphics was faster. And this was without the haveged. Can it not be possible that the installer does some post-installation stuff at the very first boot into the installed system?

And of course CLI is really good, no surprise there, thanks for the advice.

I will report if anything else comes up.

Thanks!

Edit: just for reference, here are the results of the random generation for the second boot, without haveged (I am not sure about the first boot):

ghorvath@acerlaptop:~$ sudo dmesg | grep random
[    1.020236] random: fast init done
[   11.674906] random: crng init done

On first boot, Bunsenlabs copies a bunch of stuff into place, so it will be slower than any subsequent reboots. This is normal, just a lot more noticeable on old hardware.

Offline

#15 2018-05-21 08:28:31

ghorvath
Member
Registered: 2015-10-01
Posts: 130

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

Head_on_a_Stick wrote:
ghorvath wrote:

Opening a terminal takes more than 10 seconds

Yeah that's terminator, it is insanely slow to open (bash doesn't help either).

Try a lighter alternative:

sudo apt install rxvt-unicode-256color
sudo update-alternatives --set x-terminal-emulator $(which urxvt)

Thanks, this terminal is indeed really quick!

However, I cannot find the configuration file for this. I really dislike the Bunsen default of having these square-sized terminal windows (sorry guys!)... My preference goes for the slick default, which has a ratio approx 2:1. But I cannot remove the settings for the current square anywhere. I guess it would be for x-terminal emulator. Can you point me to the config file?

Offline

#16 2018-05-21 09:57:06

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 4,675
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

Ths configurations for urxvt are in ~/Xresources.
You want

! Window size: change this
URxvt.geometry: 83x35

The size is in characters, not pixels.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#17 2018-05-25 05:45:40

ghorvath
Member
Registered: 2015-10-01
Posts: 130

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

Thanks!

And how could I change the terminator size settings to the default?

Offline

#18 2018-05-25 06:00:51

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 4,675
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

^Right-click a Terminator window and go to the preferences.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#19 2018-05-25 19:20:34

ohnonot
...again
Registered: 2015-09-29
Posts: 3,197
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

re urxvt: i recently read an article, comparing terminal emulators, turns out mlterm might be even snappier than urxvt.
even comes with a gtk2 config UI (Ctrl-rclick).

Offline

#20 2018-05-25 20:09:26

ghorvath
Member
Registered: 2015-10-01
Posts: 130

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

ohnonot wrote:

re urxvt: i recently read an article, comparing terminal emulators, turns out mlterm might be even snappier than urxvt.
even comes with a gtk2 config UI (Ctrl-rclick).

Thanks, I might try it, but urxvt was reasonably quick, so I will stick with that for now. (When I am not using the CLI, anyway. :-) )

I mark this thread solved, thanks everyone for the help!

Offline

#21 2018-05-25 22:31:34

hhh
That's easy!
Registered: 2015-09-17
Posts: 6,106
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

Moving this to Basic Help and Support since it's about our current release (though we do appreciate the thoughtfulness of not wanting to clutter that forum smile ).

Offline

#22 2018-05-27 20:22:26

hhh
That's easy!
Registered: 2015-09-17
Posts: 6,106
Website

Re: Solved: Bunsenlabs Helium on veeeeeeeeeeery old machine

I just removed the GNOME accessibility daemon with no problem. This removed just the one package for me, but check what apt reports will get removed before you execute, as your mileage may vary...

sudo apt purge --autoremove at-spi2-core

Reboot.

Offline

Board footer

Powered by FluxBB