You are not logged in.

#1 2015-11-01 06:21:55

Frogman
Member
From: The Server Room
Registered: 2015-11-01
Posts: 22

Setting default audio output with a bluetooth audio device

I haven't seen much on bluetooth here yet, so here's a quick run down of how I got bluetooth headphones working on a fresh BL install. I first managed to get bluetooth set up and working by following this Debian guide: https://wiki.debian.org/BluetoothUser/a2dp I installed blueman and added blueman-applet to my ~/.config/openbox/autostart script. I could pair and get audio to my headphones just fine. However, I had to manually set each individual program to output to the headphones via the pavucontrol playback tab instead of having them be the default audio output when they are connected. I Googled up the proper wiki page to set this (fallback) and all seems fine now. http://www.freedesktop.org/wiki/Softwar … ultDevice/

Offline

#2 2015-11-01 11:52:02

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Setting default audio output with a bluetooth audio device

Nice, thanks for this!

Moving to Scripts, Tutorials & Tips


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2015-11-06 00:12:44

Frogman
Member
From: The Server Room
Registered: 2015-11-01
Posts: 22

Re: Setting default audio output with a bluetooth audio device

Update: I took blueman-applet out of autostart. Turns out that it starts by default on boot up and I ended up with two instances in the panel when I started the system. My initial test had been to log out and back in and blueman-applet wan't started by default when doing only that.

The fallback setting is lost when my headphones disconnect and I have to re-enable it when I connect them again. I'm sure there is a script somewhere that I could add that to so that when the system detects they are connected it sets it.

Offline

#4 2015-11-06 06:51:55

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Setting default audio output with a bluetooth audio device

Frogman wrote:

Update: I took blueman-applet out of autostart. Turns out that it starts by default on boot up

All .desktop files in /etc/xdg/autostart and ~/.config/autostart run when the X session starts.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2015-11-06 20:08:18

Frogman
Member
From: The Server Room
Registered: 2015-11-01
Posts: 22

Re: Setting default audio output with a bluetooth audio device

Ah-ha! There is a blueman.desktop file in there. Thanks!

Offline

Board footer

Powered by FluxBB