You are not logged in.

#1 2018-04-20 19:45:21

ohnonot
...again
Registered: 2015-09-29
Posts: 3,773
Website

conky on Lubuntu doesn't obey own_window_type

-moderator edit by hhh- New topic created, split from...
https://forums.bunsenlabs.org/viewtopic.php?id=4742
This is a sloppy thread split, please see the short thread linked to get the context of the discussion. Thanks!

no, if it isn't managing the desktop anymore means conky's now painting on the root window and it has nothing to do with LXDE anymore.
please post the complete head section of the conky in question.
also are you using compton or something? LXDE does not do compositing, so you don't need ARGB settings at all.

relevant section from my conky:

own_window yes
own_window_transparent yes
own_window_type override

Last edited by hhh (2018-04-22 00:00:04)

Offline

#2 2018-04-20 20:21:08

martix
Kim Jong-un Stunt Double
Registered: 2016-02-19
Posts: 1,267

Re: conky on Lubuntu doesn't obey own_window_type

^Hmm, interesting. I just gave it a try and with those settings right click works this way: Lets say I minimize the browser, right click on conky, nothing happens. Right click on desktop opens the menu. Right click again, menu closed. Right click again on conky, menu opens. "own_window no" completely messes up the desktop (all the windows blinking and they also disappear).

Offline

#3 2018-04-20 21:01:59

unklar
Member
Registered: 2015-10-31
Posts: 883

Re: conky on Lubuntu doesn't obey own_window_type

What happens if instead of

own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_hints undecorated,above,sticky,skip_taskbar,skip_pager

in the conky.

Are you sure you're registering with OB?
In the login screen of LXDE there is an extra selection option for this.

Offline

#4 2018-04-20 22:42:18

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

ohnonot wrote:

please post the complete head section of the conky in question.

Here's the current version:

background yes
use_xft yes
xftfont Liberation Sans:size=9
xftalpha 1
update_interval 1.0
total_run_times 0
own_window yes
own_window_transparent no
own_window_type override
own_window_argb_visual yes
own_window_argb_value 150
#own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
double_buffer yes
draw_shades yes
draw_outline no
draw_borders no
draw_graph_borders no
# default_color 808080
default_color ff8000
default_shade_color 000000
default_outline_color 828282
alignment top_right
gap_x 8
gap_y 40
no_buffers yes
uppercase no
cpu_avg_samples 2
override_utf8_locale no
maximum_width 200
minimum_size 200 1030
temperature_unit fahrenheit
##############################################
#  Output
##############################################

also are you using compton or something? LXDE does not do compositing, so you don't need ARGB settings at all.

I did install xcompmgr to get my conky translucency as my searching led to that as the solution.

See anything awry?


Schw.im! A social site with an identity crisis.

Offline

#5 2018-04-20 22:47:49

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

martix wrote:

^Hmm, interesting. I just gave it a try and with those settings right click works this way: Lets say I minimize the browser, right click on conky, nothing happens. Right click on desktop opens the menu. Right click again, menu closed. Right click again on conky, menu opens. "own_window no" completely messes up the desktop (all the windows blinking and they also disappear).

Hey, that's how it works for me too!  I may try to get into the habit of doing that to get it working right away.

[EDIT]Disregard, as soon as I bring a window up, the menu stops working over conky, which is precisely when I need it to work wink .

Last edited by schwim (2018-04-20 23:05:25)


Schw.im! A social site with an identity crisis.

Offline

#6 2018-04-20 22:56:27

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

unklar wrote:

What happens if instead of

own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_hints undecorated,above,sticky,skip_taskbar,skip_pager

in the conky.

Are you sure you're registering with OB?
In the login screen of LXDE there is an extra selection option for this.

Hi there Unklar,  I've got the OB menu so I'm pretty sure it's in play.

Per instructions in this thread, own_window_hints is currently commented out.


Schw.im! A social site with an identity crisis.

Offline

#7 2018-04-20 23:39:28

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

If I replace my lines with yours, I can't get a menu over conky, regardless of what's going on in the desktop beside it.

Here's what's below:

TEXT
${font Denk One:normal:size=30}${alignr 5}${time %I:%M %p}
${font Denk One:normal:size=20}${alignr 5}${time %d} ${time  %B}
${alignr 5}${time %A}${font}

${font Denk One:bold:size=10}S Y S T E M    I N F O ${hr 2}
${font Liberation Sans:normal:size=8}Host:$alignr$nodename
Uptime:$alignr$uptime

${font Denk One:bold:size=10}P R O C E S S O R ${hr 2}
 ${cpubar cpu1}
 ${cpubar cpu2}
${font Denk One:bold:size=10}M E M O R Y ${hr 2}
${font Liberation Sans:normal:size=8}RAM $alignc $mem / $memmax $alignr $memperc%
$membar
SWAP $alignc ${swap} / ${swapmax} $alignr ${swapperc}%
${swapbar}
Disk usage:$alignr${fs_used /}/${fs_size /}

${font Denk One:bold:size=10}N E T W O R K ${hr 2}
${font Liberation Sans:normal:size=8}Internal IP: ${addr enp0s3}
External IP: 
DLS:
${downspeedgraph enp0s3 15,180 ff8000 ffffff}
Speed: ${downspeed enp0s3} $alignr Total: ${totaldown enp0s3}

ULS:
${upspeedgraph enp0s3 15,180 ff8000 ffffff}
Speed: ${upspeed enp0s3} $alignr Total: ${totalup enp0s3}

Schw.im! A social site with an identity crisis.

Offline

#8 2018-04-21 00:37:20

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,052

Re: conky on Lubuntu doesn't obey own_window_type

I'm getting some erratic behavior. With own_window_type set to either desktop or override, I can click on the conky window and get menus, but not all the time. Can't get a menu at all if I restart the conky (like when you edit the conkyrc and it restarts), have to kill it then start it again to get the menus back.

Your conkyrc is fine.

Last edited by PackRat (2018-04-21 00:38:01)


You must unlearn what you have learned.
    -- yoda

Offline

#9 2018-04-21 18:30:17

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

I just can't figure it out and I've run out of search terms to use.

I'm not married to Lubuntu, I just picked it because I wanted an OB based current Ubu install and it was the closest I could find. I've built what I wanted off of an Ubu minimal install and came close to my experience in #! but it took me quite a while and I was hoping for something close to an out-of-the-box experience.

Does anyone know of an OB centric Ubu install or should I just start from scratch to get something close to what BL provides?

Thanks for all your help!


Schw.im! A social site with an identity crisis.

Offline

#10 2018-04-21 19:10:41

martix
Kim Jong-un Stunt Double
Registered: 2016-02-19
Posts: 1,267

Re: conky on Lubuntu doesn't obey own_window_type

@schwim madbox and gobang come to my mind, but there are surely more.

I would not give up yet though as someone might figure it out in the end (it's not working properly for me either).

As a sidenote: XFCE has a dynamic menu on default in the desktop-right click menu (at least it had when I tried it).

Offline

#11 2018-04-21 20:57:18

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

martix wrote:

@schwim madbox and gobang come to my mind, but there are surely more.

I would not give up yet though as someone might figure it out in the end (it's not working properly for me either).

As a sidenote: XFCE has a dynamic menu on default in the desktop-right click menu (at least it had when I tried it).

Thanks a bunch martix.  GoBang looks dead and madbox is manaro based so I'll hold out to see what else is out there.  I'm definitely not hot to being hopping installs so if I can get this working the way I'd like, I'd be stoked.


Schw.im! A social site with an identity crisis.

Offline

#12 2018-04-21 21:28:35

hhh
Meep!
Registered: 2015-09-17
Posts: 7,916
Website

Re: conky on Lubuntu doesn't obey own_window_type

schwim wrote:

heya triple,

"desktop" causes conky to disappear when I right-click the desktop space.  Normal allows it to remain visible when right-clicking, but neither setting allows my menu to show up when I right-click inside conky's space.

This is incorrect behavior. From man conky...

own_window_type
    if own_window is yes, you may specify type normal, desktop, dock, panel or override (default: normal). Desktop windows are special windows that have no window decorations; are always visible on your desktop; do not appear in your pager or taskbar; and are sticky across all workspaces. Panel windows reserve space along a desktop edge, just like panels and taskbars, preventing maximized windows from overlapping them. The edge is chosen based on the alignment option. Override windows are not under the control of the window manager. Hints are ignored. This type of window can be useful for certain situations.

Setting own_window_type to desktop means conky should always be visible. Have you tried creating a fresh conky, or tried using the BL default one? Has anyone searched to see if a bug against LXDE or conky has been reported?

BTW, ohnonot answered the thread title's question early on page one, and I stupidly repeated it a few posts later (sorry, ohnonot!) OK with you if I split off the conky discussion and mark this thread solved? We're trying our best to make the info on the forums friendly to search engines, and thread title with conky/LXDE in it would help that.

Offline

#13 2018-04-21 23:14:08

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

hhh wrote:

BTW, ohnonot answered the thread title's question early on page one, and I stupidly repeated it a few posts later (sorry, ohnonot!) OK with you if I split off the conky discussion and mark this thread solved? We're trying our best to make the info on the forums friendly to search engines, and thread title with conky/LXDE in it would help that.

Feel free, and thanks for all the help!


Schw.im! A social site with an identity crisis.

Offline

#14 2018-04-22 00:21:54

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,052

Re: conky on Lubuntu doesn't obey own_window_type

Does anyone know of an OB centric Ubu install or should I just start from scratch to get something close to what BL provides?

It's not OB centric, but installing openbox to an Xubuntu base would be pretty close. You can also install jgmenu if you want something closer to the lxde menu.


You must unlearn what you have learned.
    -- yoda

Offline

#15 2018-04-22 00:36:03

hhh
Meep!
Registered: 2015-09-17
Posts: 7,916
Website

Re: conky on Lubuntu doesn't obey own_window_type

PackRat wrote:

Does anyone know of an OB centric Ubu install or should I just start from scratch to get something close to what BL provides?

It's not OB centric, but installing openbox to an Xubuntu base would be pretty close. You can also install jgmenu if you want something closer to the lxde menu.

Running Openbox in xfce is a great way to have a "real" DE that uses OB....

XFCE starts the window manager specified in /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml or, under xubuntu, in /etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml

In this file look for the Client0_Command property and edit its value: <value type="string" value="xfwm4"/> to <value type="string" value="kwin"/> (obviously, replace "kwin" with your window manager of choice -edit by hhh- value="openbox") You would need to go root. You could also copy and only edit that file in /home/user/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml if you want the changes to only affect your userspace.

Because in XFCE it is common for us to save our session while logging out, don't forget to clean your session: Settings Manager->Session and Startup->Session tab->Clear saved sessions

Now you can logout and back in.

To build-your-own, I'd use the minimal install...
https://help.ubuntu.com/community/Insta … /MinimalCD

Offline

#16 2018-04-22 01:17:47

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

PackRat wrote:

It's not OB centric, but installing openbox to an Xubuntu base would be pretty close. You can also install jgmenu if you want something closer to the lxde menu.

hhh wrote:

Running Openbox in xfce is a great way to have a "real" DE that uses OB....

Thanks guys.  I successfully made a nice OB experience using Xubu on my laptop that I still use but I saw that they weren't releasing a new version for another week or so so I figured I'd try Lubu instead.. How different could it be, right? smile

hhh wrote:

To build-your-own, I'd use the minimal install...
https://help.ubuntu.com/community/Insta … /MinimalCD

I've done it in the past but it's a lot of work to end up with what you want to have in terms of usability and convenience.  Also there were always a couple of things that I just wasn't happy with and never figured out how to fix.  I figured going with something like these would solve a lot of those problems but it looks at the introduction of others.


Schw.im! A social site with an identity crisis.

Offline

#17 2018-04-22 02:02:10

hhh
Meep!
Registered: 2015-09-17
Posts: 7,916
Website

Re: conky on Lubuntu doesn't obey own_window_type

schwim wrote:
hhh wrote:

To build-your-own, I'd use the minimal install...
https://help.ubuntu.com/community/Insta … /MinimalCD

I've done it in the past but it's a lot of work to end up with what you want to have in terms of usability and convenience.  Also there were always a couple of things that I just wasn't happy with and never figured out how to fix.  I figured going with something like these would solve a lot of those problems but it looks at the introduction of others.

Hence #! and now BL. Let me give an Ubuntu/BunsenLabs cross a try, I'll post back (maybe in a couple of hours, perhaps days or weeks!)

Offline

#18 2018-04-22 02:39:26

hhh
Meep!
Registered: 2015-09-17
Posts: 7,916
Website

Re: conky on Lubuntu doesn't obey own_window_type

That was easy! I had the newest Lubuntu on my USB stick because of this thread, so I used it to repartition my drive and then install Lubuntu.

There still was no wirelesss connection due to the lack of drivers, but I copied the Broadcom b43 driver folders (all 3 of them, to be sure) from /lib/firmware on BL to /lib/firmware on the Lubuntu file system and rebooted. And boom goes the dynamite, I'm dual-booting Lubuntu and helium/sid.

I'll let you know what I can find. BTW, RAM is the same, about 230MB in both Lubuntu and helium (upgraded to sid).

Offline

#19 2018-04-22 02:43:39

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: conky on Lubuntu doesn't obey own_window_type

Very much looking forward to hearing about your travels, triple H.  I've installed Ubu 18.04 server and will give a scratch build a shot.  I'm working with virtual machines, so worst case screw up, I just grab my backup.


Schw.im! A social site with an identity crisis.

Offline

#20 2018-04-22 03:26:09

hhh
Meep!
Registered: 2015-09-17
Posts: 7,916
Website

Re: conky on Lubuntu doesn't obey own_window_type

Well, after updating my new install (149 packages), I installed conky-all and added conky to the LXDE startup session. Black background, right-click caused it to disappear. I decided to Logout.

I saw that an LxQt session was listed, so I logged into it. Nothing but a wallpaper, I guess I needed to create an autostart file. I decided to Logout.

There's an entry for openbox, I booted to it. Just a wallpaper and a right-click menu. I created ~/.config/openbox/autostart with the following...

lxpanel &
conky &

This gave me a panel and a conky that looked correct (transparent background, didn't disappear on click) but still no right-click menu on it.

I'm posting from Bunsen now. Conclusion, LXDE sucks. smile

I'm going to strip LXDE out, see what LxQt is up to, and then add my own flair. I'll update you.

Offline

#21 2018-04-22 03:28:47

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 706

Re: conky on Lubuntu doesn't obey own_window_type

LXqt is still kind of rough, triple H...tried it myself in a test VM. Promising desktop though but still needs a LOT of work.

Just curious what is the version of Conky the person reporting the issue has installed. Maybe there's a bug that needs to be tracked down.

Last edited by DeepDayze (2018-04-22 03:29:56)


Real Men Use Linux

Offline

#22 2018-04-22 09:45:57

ohnonot
...again
Registered: 2015-09-29
Posts: 3,773
Website

Re: conky on Lubuntu doesn't obey own_window_type

schwim, as i stated earlier, if you succesfully prevent LXDE from managing the desktop, your problems can't be related to LXDE.
what you're left with in that case is openbox as a wm, plus a very simplistic session manager - very similar to bunsenlabs or my personal openbox setup.

so, with that assumption, i'd concentrate on conky.

a few thoughts:

- it could be a conky version thing. i think it has changed a little in more recent versions, and if you're using Lubuntu 16.04, that will definitely be a much older version than what archlinux or stretch uses.

- please try commenting out the own_window_argb stuff, and maybe also xftalpha, just for testing.

- own_window_type is supposed to be a short form for a particular list of own_window_hints, but sometimes both are still required. you have to play with the values.
what i have in one of my conky's, designed to work on "normal desktop environment installs":

own_window yes
own_window_transparent yes
##############################################
# Compositing and desktop environment tips:
# Conky can play strangely when used with
# different compositors. I have found the
# following to work well, but your mileage
# may vary. Comment/uncomment to suit.
# I have highlighted what i believe suitable
# for the major distros.
##############################################
## no compositor, no desktop manager (e.g. plain openbox)
# own_window_type override
# own_window_argb_visual no
#own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

## xcompmgr, but no desktopmanager
#own_window_type override
#own_window_argb_visual yes
#own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

## UBUNTU, LINUX MINT CINNAMON, XUBUNTU etc.
## desktop manager with compositing (e.g. unity)
own_window_type desktop
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
##################################################

## LUBUNTU, LINUX MINT MATE
## desktop manager without compositing (e.g. lxde, xfce)
#own_window_type desktop
#own_window_argb_visual no
#own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
###############################################

i've even seen

own_window_hints undecorated,below,above,sticky,skip_taskbar,skip_pager

somewhere.

Offline

#23 2018-04-22 14:25:34

martix
Kim Jong-un Stunt Double
Registered: 2016-02-19
Posts: 1,267

Re: conky on Lubuntu doesn't obey own_window_type

Does it work generally on #BĹ? Because it works for me only the way I mentioned (click somewhere else, right click on conky opens the menu). I have conky 1.10.6.

Offline

#24 2018-04-23 14:48:28

unklar
Member
Registered: 2015-10-31
Posts: 883

Re: conky on Lubuntu doesn't obey own_window_type

For testing I installed the siduction-lxde2018.2 in Qemu.

On the login screen I select OpenBox as desktop.

The upper Conky has the "above" option I mentioned earlier.

own_window_hints undecorated,above,sticky,skip_taskbar,skip_pager

lxde_ob1.th.png


The lower Conky has the option "below" (as usual)

own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

Both Conky windows do not disappear when I click on the desktop and show me the sparse OB menu when I right-click.
So Lubuntu does something different here or @schwim

lxde_ob2.th.png lxde_ob3.th.png

apt policy conky
conky:
  Installiert:           1.9.0-6
  Installationskandidat: 1.10.8-1
  Versionstabelle:
     1.10.8-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
 *** 1.9.0-6 100
        100 /var/lib/dpkg/status
unklarer@qlxde:~$ apt policy conky-std
conky-std:
  Installiert:           1.10.8-1
  Installationskandidat: 1.10.8-1
  Versionstabelle:
 *** 1.10.8-1 500
        500 http://deb.debian.org/debian unstable/main amd64 Packages
        100 /var/lib/dpkg/status

up

	own_window yes
	own_window_type normal
	own_window_transparent yes
        own_window_class conky
	own_window_hints undecorated,above,skip_taskbar,skip_pager   #sticky,
#own_window_colour 000000

down

	own_window = true,--eigenes Fenster
	own_window_type = 'normal',
--               override  
	own_window_transparent = true,
	own_window_hints = 'undecorated,below,skip_taskbar,skip_pager',--sticky,
	own_window_class = 'conky'
	own_window_argb_visual = true,
--own_window_argb_value 0 
--own_window_colour 000000  
--own_window_title  Teo-Weather 

Last edited by unklar (2018-04-23 15:08:17)

Offline

Board footer

Powered by FluxBB