You are not logged in.

#1 2018-01-16 21:02:06

mariojlhm
Member
Registered: 2016-04-27
Posts: 16

No volume icon; getting auth error with apt-get for bunsen repos

Hello,

I'm not getting a volume icon.

Here's an excerpt from .xsession-errors

systray window 16777231                                                                                                                                                                                                                        
^[[1;32mtint2 : systray started^[[0m                                                                                                                                                                                                           
^[[1;32mLoading icon theme cache...^[[0m                                                                                                                                                                                                       
launcher.c 216: Using icon /usr/share/icons/Faenza-Bunsen-common/categories/22/applications-internet.png                                                                                                                                       
launcher.c 216: Using icon /usr/share/icons/Faenza-Bunsen-common/apps/22/system-file-manager.png                                                                                                                                               
launcher.c 216: Using icon /usr/share/icons/Faenza-Bunsen-common/apps/22/accessories-text-editor.png                                                                                                                                           
launcher.c 216: Using icon /usr/share/icons/Faenza-Bunsen-common/apps/22/utilities-terminal.png                                                                                                                                                
/home/mario/.config/openbox/autostart: 68: /home/mario/.config/openbox/autostart: bl-start-pulseaudio-x11: not found                                                                                                                           
TUNSETIFF: Operation not permitted                                                                                                                                                                                                             
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused                                                                                                                                                         
                                                                                                                                                                                                                                               
volumeicon: alsa_backend.c:86: asound_get_volume: Assertion `m_elem != NULL' failed.

Here is my sources.list

deb http://deb.debian.org/debian stretch main non-free contrib                                                                                                                                                                                 
#deb-src http://deb.debian.org/debian jessie main non-free contrib                                                                                                                                                                             
                                                                                                                                                                                                                                               
deb http://security.debian.org/ stretch/updates main contrib non-free                                                                                                                                                                          
#deb-src http://security.debian.org/ jessie/updates main contrib non-free                                                                                                                                                                      
                                                                                                                                                                                                                                               
# jessie-updates, previously known as 'volatile'                                                                                                                                                                                               
deb http://deb.debian.org/debian stretch-updates main contrib non-free                                                                                                                                                                         
#deb-src http://deb.debian.org/debian jessie-updates main contrib non-free                                                                                                                                                                     
                                                                                                                                                                                                                                               
deb https://kelaino.bunsenlabs.org/~johnraff/debian helium main

Here is relevant portion of openbox/autostart:

## Start the tint2 session (the default tint2 will run if no sessions have been set)                                                                                                                                                           
bl-tint2-session                                                                                                                                                                                                                               
                                                                                                                                                                                                                                               
## Start PulseAudio                                                                                                                                                                                                                            
## (This replaces /etc/xdg/autostart/pulseaudio.desktop                                                                                                                                                                                        
## which is disabled by ~/.config/autostart/pulseaudio.desktop.)                                                                                                                                                                               
## NOTE: PulseAudio must be started before volumeicon                                                                                                                                                                                          
bl-start-pulseaudio-x11                                                                                                                                                                                                                        
                                                                                                                                                                                                                                               
## Volume control for systray                                                                                                                                                                                                                  
sleep 20; volumeicon &                                                                                                                                                                                                                         
                                                                                                                                                                                                                                               
## Start the Conky session (the default conkyrc will run if no sessions have been set)                                                                                                                                                         
bl-conky-session --autostart &                                                                                                                                                                                                                 
                                                                                                                                                                                                                                               
## Start the battery applet                                                                                                                                                                                                                    
#fdpowermon &

Here is relevant text for auth error from apt-get:

W: GPG error: https://kelaino.bunsenlabs.org/~johnraff/debian helium InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8FFD2CE993071671
W: The repository 'https://kelaino.bunsenlabs.org/~johnraff/debian helium InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Offline

#2 2018-01-16 21:44:43

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: No volume icon; getting auth error with apt-get for bunsen repos

mariojlhm wrote:
bl-start-pulseaudio-x11: not found

^ There's your problem smile

How exactly did you install helium-dev?

Please include as much detail as possible.

If the helium-dev repositories are not authorised then the helium-dev packages cannot be installed.

mariojlhm wrote:
W: GPG error: https://kelaino.bunsenlabs.org/~johnraff/debian helium InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8FFD2CE993071671
W: The repository 'https://kelaino.bunsenlabs.org/~johnraff/debian helium InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Try this:

wget -q https://kelaino.bunsenlabs.org/~johnraff/helium-dev.asc -O - | sudo apt-key add -

Then update & upgrade, that should pull in the missing packages (I think):

sudo apt update && sudo apt upgrade

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2018-01-17 18:44:32

dolly
Miss Mixunderstand
From: /lab1
Registered: 2015-10-03
Posts: 366

Re: No volume icon; getting auth error with apt-get for bunsen repos

Shouldn`t the source list point to "stretch" instead of "jessie" in this case?


Keep BunsenLabs #!yish please.

Offline

#4 2018-01-17 19:30:56

mrneilypops
The BL Scrot.Moe Guy
From: luxembourg
Registered: 2015-09-30
Posts: 553
Website

Re: No volume icon; getting auth error with apt-get for bunsen repos

I tried a 'shortcut' route to helium by upgrading an existing BunsenLabs install to Stretch.

From my notes at the time;
1. CAPS lock disabled by default
2. Volumeicon missing
3. blstart-pulseaudio-x11 not found
4. VLC theme messed up.
Most of these niggles were fixable but I decided to start again from the Debian Stretch base...no issues.

Offline

#5 2018-01-17 20:55:32

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: No volume icon; getting auth error with apt-get for bunsen repos

dolly wrote:

Shouldn`t the source list point to "stretch" instead of "jessie" in this case?

I think it does, doesn't it?

The jessie lines are all commented out, unless I've missed something?

@Neil, thanks, yes, I suspect that is what the OP has done.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#6 2018-01-18 17:47:54

dolly
Miss Mixunderstand
From: /lab1
Registered: 2015-10-03
Posts: 366

Re: No volume icon; getting auth error with apt-get for bunsen repos

Oooops i did it again!  ops


Keep BunsenLabs #!yish please.

Offline

#7 2018-01-18 18:25:37

mrneilypops
The BL Scrot.Moe Guy
From: luxembourg
Registered: 2015-09-30
Posts: 553
Website

Re: No volume icon; getting auth error with apt-get for bunsen repos

@mariojlhm

I would recommend that you install Helium from a fresh Debian Stretch net base install as per;
https://forums.bunsenlabs.org/viewtopic.php?id=3800

Last edited by mrneilypops (2018-01-18 18:27:19)

Offline

Board footer

Powered by FluxBB