You are not logged in.

#1 2017-05-31 07:34:26

Jorge_Alberto
Member
Registered: 2017-05-31
Posts: 9

Sound lagging on some wine and dosbox games

Hey guys, I stumbled upon the following problem: My sound is lagging on some wine and dosbox games (ocurred in Duke Nukem 3d Megaton Edition on wine and Dungeon Keeper Gold on dosbox, but Commandos 2 and Half-Life in wine are ok, and so are Anvil of Dawn and Dune 2 on dosbox). Here is the necessary terminal output:

lspci -k|grep -A2 Audio:

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
	Subsystem: QUANTA Computer Inc Device 0755
	Kernel driver in use: snd_hda_intel
aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CX20549 Analog [CX20549 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: CX20549 Digital [CX20549 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Well, back in the CB Waldorf era, I used to append the line

options snd-hda-intel model=generic

to /etc/modprobe.d/alsa-base.conf, to make sound work fine (it was scratchy and noisy without it), but when I went looking for this file, I could not find it. So, what should I do? Thanks in advance for any help.


EDIT: Just adding, these games worked flawlessly on CB Waldorf.

Last edited by Jorge_Alberto (2017-05-31 07:56:16)

Offline

#2 2017-05-31 07:43:38

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Sound lagging on some wine and dosbox games

Jorge_Alberto wrote:

when I went looking for this file, I could not find it. So, what should I do?

Make a new one yourself smile

sudo tee /etc/modprobe.d/lagfix.conf <<< "options snd-hda-intel model=generic"

I don't think that will have any effect though, that module is already loaded for the card.

A quick search brings up https://askubuntu.com/questions/149177/ … rough-wine

You can add that variable to ~/.xsessionrc then log out & back in again to test it.

echo "export WINENOPULSE=1" >> ~/.xsessionrc
Jorge_Alberto wrote:

Half-Life in wine

Half-Life is available in Steam for Debian and it works very well indeed, I have a copy smile

https://wiki.debian.org/Steam

EDIT: welcome to the forums!

smile

EDIT2: potential DOSBox solution: https://www.gog.com/forum/crusader_seri … _delay_lag

Last edited by Head_on_a_Stick (2017-05-31 07:47:00)


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2017-05-31 07:53:17

Jorge_Alberto
Member
Registered: 2017-05-31
Posts: 9

Re: Sound lagging on some wine and dosbox games

Thanks for the fast answer, but sadly, it didn't work. Any new ideas?

Last edited by Jorge_Alberto (2017-05-31 07:53:58)

Offline

#4 2017-05-31 18:44:09

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Sound lagging on some wine and dosbox games

Jorge_Alberto wrote:

it didn't work

I offered three suggestions, did you try them all?

Did you check that the module option was applied?

Did you check that the environmental variable was set correctly?

Finally, is there anything written to ~/.xsession-errors after you experience the lag?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2017-06-01 17:50:44

Jorge_Alberto
Member
Registered: 2017-05-31
Posts: 9

Re: Sound lagging on some wine and dosbox games

Yeah, I tried them all, but the issue in Duke Nukem persists. On the other hand, in Dungeon Keeper (DOSBox) I just had to set the variable cputype in dosbox.conf to 486_slow, and now the game is perfect. Tried again on Duke Nukem, no errors in ~/.xsession-errors.

Offline

Board footer

Powered by FluxBB