You are not logged in.

#1 2017-05-18 17:29:02

Registered: 2017-05-18
Posts: 14

Touchpad buggy - Right-click, single touch, etc

Edit: Sorry, @Head_on_a_Stick! I updated this post to correct my typo. I mistakenly wrote touchscreen throughout the original post. My problem is not with that, but with the touchpad. I never use the touchscreen, so I forgot my computer actually has that feature.

I recently put Bunsenlabs on my Acer E5-571P. Awesome distro! It has my old machine running very well! smile

However, I am having trouble with the touchpad. The touchpad worked fine with Elementary OS Loki 0.4 (I believe that was running on kernel 4.4.0-36-generic). I don't think there is anything wrong with the hardware.

Touchpad symptoms when running BL:
- right click does not work
- left click works
- in Chromium and Google Chrome, any touch (even very light single touch) selects the item below the cursor. So, if the cursor is on a browser tab, when I try to move the cursor from the tab, I end up grabbing and moving the tab. Also, any attempt to move the cursor within a website will select whatever is underneath the cursor.

Diagnostics so far:

$ xinput --list
⎜   ↳ ELAN0501:00 04F3:300B UNKNOWN           	id=14	[slave  pointer  (2)]
$ cat /proc/bus/input/devices

I: Bus=0018 Vendor=04f3 Product=300b Version=0100
N: Name="ELAN0501:00 04F3:300B UNKNOWN"
P: Phys=
S: Sysfs=/devices/pci0000:00/INT33C3:00/i2c-0/i2c-ELAN0501:00/0018:04F3:300B.0001/input/input7
U: Uniq=
H: Handlers=mouse1 event7

I used

 cat /dev/input/event7

Using that command, the terminal correctly displays gibberish when I operate or touch the touchpad, showing that it is receiving input from the touchpad. And, as I said, I can scroll and even left-click, but right-click is not working, and the touchpad single touch cursor movement is interpreted as if I have clicked down on whatever is below the cursor.

Any ideas on how to get my touchpad working correctly? Is it related to the fact that the devices list shows it as "Unknown"? Thanks!

Last edited by Aijalon (2017-05-19 04:07:06)


#2 2017-05-18 20:30:07

From: London
Registered: 2015-09-29
Posts: 8,759

Re: Touchpad buggy - Right-click, single touch, etc

Aijalon wrote:

The touchscreen worked fine with Elementary OS

Do you happen to know which kernel version Elementary was using?

Although you say your device is old, touchscreen support has improved markedly recently and it may be worth trying the 4.9-series kernel from the jessie-backports repository, guide here:

Unfortunately, I have zero experience of touchscreens so I may not be able to help directly, sorry.

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks


Board footer

Powered by FluxBB