You are not logged in.

#1 2017-03-04 23:03:56

bobhund
Member
Registered: 2016-10-25
Posts: 43

trying to make steam run [solved]

Ok, I think I am about the point where I admit I really do not know what I am doing. I have tried making steam run on my computer. It basically startsup runs and then crashes after a while. After it have crashed I am not able to make it run untill I have rebooted my computer, and it all starts up again.
My last try at fixing it, was to install nividia driver with command I found in Debian tutorial, after checking that my dell d630 is using nividia. However now it will not start at all just writing that openGL glx extension not supported by display.

But the error code in terminal is the same as before

Running Steam on bunsenlabs 8.7 64-bit
STEAM_RUNTIME is enabled automatically
[2017-03-04 23:56:11] Startup - updater built Jan 19 2017 01:22:13
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2017-03-04 23:56:12] Checking for update on startup
[2017-03-04 23:56:12] Checking for available updates...
[2017-03-04 23:56:13] Download skipped: /client/steam_client_ubuntu12 version 1484790260, installed version 1484790260
[2017-03-04 23:56:13] Nothing to do
[2017-03-04 23:56:13] Verifying installation...
[2017-03-04 23:56:13] Performing checksum verification of executable files
[2017-03-04 23:56:18] Verification complete

I am a bit lost

Last edited by bobhund (2017-03-08 17:08:25)

Offline

#2 2017-03-04 23:46:52

damo
....moderator....
Registered: 2015-08-20
Posts: 5,059

Re: trying to make steam run [solved]


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2017-03-05 15:45:45

bobhund
Member
Registered: 2016-10-25
Posts: 43

Re: trying to make steam run [solved]

Yes that is the instructions I have followed. Also now I tried the instructions of removing the different ubuntu files, and I get an error that the files do not exist.

Offline

#4 2017-03-05 15:54:28

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: trying to make steam run [solved]

Please post the output of:

dpkg --print-foreign-architectures
apt-cache policy steam libgl1-nvidia-glx:i386

Also, it is always better to post the full, exact error message (along with the command(s) that preceded it) rather than a vague description.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2017-03-05 19:36:39

bobhund
Member
Registered: 2016-10-25
Posts: 43

Re: trying to make steam run [solved]

Roger that on the exact error message. This my output and thanks for the help,

torbian@r2d2:~$ apt-cache policy steam libgl1-nvidia-glx:i386
steam:i386:
  Installeret: 1.0.0.49-1
  Kandidat:    1.0.0.49-1
  Versionstabel:
 *** 1.0.0.49-1 0
        500 http://httpredir.debian.org/debian/ jessie/non-free i386 Packages
        100 /var/lib/dpkg/status
libgl1-nvidia-glx:i386:
  Installeret: 340.101-1
  Kandidat:    340.101-1
  Versionstabel:
     375.26-1~bpo8+1 0
        100 http://httpredir.debian.org/debian/ jessie-backports/non-free i386 Packages
 *** 340.101-1 0
        500 http://httpredir.debian.org/debian/ jessie/non-free i386 Packages
        100 /var/lib/dpkg/status

Offline

#6 2017-03-06 07:20:59

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: trying to make steam run [solved]

bobhund wrote:

It basically startsup runs and then crashes after a while. After it have crashed I am not able to make it run untill I have rebooted my computer, and it all starts up again.

Is there anything in ~/.xsession-errors after Steam crashes?

Also, what exactly do you mean by "crashes"? Do you just lose the window?

Are there any error messages given if you try to start Steam from a terminal after the crash?

Finally, I think that the output posted in the OP is not an error message at all but is in fact printed when the program runs successfully.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#7 2017-03-07 04:30:31

bobhund
Member
Registered: 2016-10-25
Posts: 43

Re: trying to make steam run [solved]

~/.xsession-errors

Xsession: X session started for torbian at tir mar  7 05:08:50 CET 2017
localuser:torbian being added to access control list
export DBUS_SESSION_BUS_ADDRESS='unix:abstract=/tmp/dbus-HZxFdT7LVn,guid=3db70539c79ecba88629817f58be3253'
export DESKTOP_SESSION='lightdm-xsession'
export DISPLAY=':0'
export GDMSESSION='lightdm-xsession'
export HOME='/home/torbian'
export LANG='da_DK.UTF-8'
export LOGNAME='torbian'
export PATH='/home/torbian/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games'
export PWD='/home/torbian'
export QT_STYLE_OVERRIDE='GTK+'
export SHELL='/bin/bash'
export SSH_AGENT_PID='970'
export SSH_AUTH_SOCK='/tmp/ssh-Ou8GkDuqv5bV/agent.946'
export USER='torbian'
export XAUTHORITY='/home/torbian/.Xauthority'
export XDG_GREETER_DATA_DIR='/var/lib/lightdm/data/torbian'
export XDG_RUNTIME_DIR='/run/user/1000'
export XDG_SEAT='seat0'
export XDG_SEAT_PATH='/org/freedesktop/DisplayManager/Seat0'
export XDG_SESSION_ID='1'
export XDG_SESSION_PATH='/org/freedesktop/DisplayManager/Session0'
export XDG_VTNR='7'
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
/usr/bin/bl-tint2restart: no tint2 processes found
tint2 : nb monitor 1, nb monitor used 1, nb desktop 2
Loading Faenza-Dark-Bunsen. Icon theme : 'Faenza-Dark-Bunsen', 'Faenza-Bunsen-common', 'Faenza-Dark', 'Faenza', 'gnome', 'hicolor',
launcher.c 215: Using icon /usr/share/icons/Faenza-Bunsen-common/categories/22/applications-internet.png
launcher.c 215: Using icon /usr/share/icons/Faenza-Bunsen-common/apps/22/system-file-manager.png
launcher.c 215: Using icon /usr/share/icons/Faenza-Bunsen-common/apps/22/accessories-text-editor.png
launcher.c 215: Using icon /usr/share/icons/Faenza-Bunsen-common/apps/22/utilities-terminal.png
Failure: Module initialization failed
Conky: forked to background, pid is 1046

Conky: desktop window (61) is root window
Conky: window type - normal
Conky: drawing to created window (0x2000001)
Conky: drawing to double buffer
[1091:0307/050903:ERROR:browser_main_loop.cc(170)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
Xlib:  extension "GLX" missing on display ":0".
[1124:0307/050905:ERROR:gl_surface_glx.cc(352)] glxQueryVersion failed
[1124:0307/050905:ERROR:gl_surface_x11.cc(56)] GLSurfaceGLX::InitializeOneOff failed.
[1124:0307/050905:ERROR:gpu_child_thread.cc(146)] Exiting GPU process due to errors during initialization
[1091:0307/050908:INFO:CONSOLE(53)] ""Saving notification avatars at: /tmp/gitter-notification-avatars_"", source: /tmp/.org.chromium.Chromium.DL47WS/utils/notifier.js (53)
[1091:0307/050908:INFO:CONSOLE(98)] ""execPath:" "/opt/Gitter/linux64/Gitter"", source: app://gitter/index.js (98)
[1091:0307/050908:INFO:CONSOLE(99)] ""argv:"", source: app://gitter/index.js (99)
[1091:0307/050908:INFO:CONSOLE(100)] ""version:" "3.1.0"", source: app://gitter/index.js (100)
[1091:0307/050908:INFO:CONSOLE(115)] ""Are we going into update mode? No."", source: app://gitter/index.js (115)
[1091:0307/050908:INFO:CONSOLE(67)] ""Rebuilding tray menu"", source: /tmp/.org.chromium.Chromium.DL47WS/components/tray-menu.js (67)
[1091:0307/050909:INFO:CONSOLE(214)] ""checking" "https://update.gitter.im/linux64/package.json" "for app updates"", source: /tmp/.org.chromium.Chromium.DL47WS/utils/auto-update.js (214)
[1091:0307/050909:INFO:CONSOLE(217)] ""request for app update manifest failed"", source: /tmp/.org.chromium.Chromium.DL47WS/utils/auto-update.js (217)
[1091:0307/050909:INFO:CONSOLE(256)] ""trying app update again in 30 mins"", source: /tmp/.org.chromium.Chromium.DL47WS/utils/auto-update.js (256)

(openbox:946): GLib-CRITICAL **: Source ID 19 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 31 was not found when attempting to remove it
Starting Dropbox...
(openbox:946): GLib-CRITICAL **: Source ID 47 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 67 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 71 was not found when attempting to remove it
Dropbox isn't running!
Done!

(openbox:946): GLib-CRITICAL **: Source ID 75 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 79 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 108 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 116 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 142 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 156 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 174 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 188 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 196 was not found when attempting to remove it
[1091:0307/051040:INFO:CONSOLE(8)] ""Quitting app, app:quit"", source: /tmp/.org.chromium.Chromium.DL47WS/utils/quit-app.js (8)
[1091:0307/051040:INFO:CONSOLE(60)] ""App is quiting, cleanup avatars"", source: /tmp/.org.chromium.Chromium.DL47WS/utils/notifier.js (60)
[1132:0307/051040:WARNING:channel.cc(553)] Failed to send message to ack remove remote endpoint (local ID 1, remote ID 1)
Xlib:  extension "GLX" missing on display ":0".
[fresh] [error] tables_open_display, glXQueryVersion returned False
[fresh] [error] tables_open_display, glXQueryVersion returned False
Xlib:  extension "GLX" missing on display ":0".
NOT SANDBOXED
[fresh  1497] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh  1497] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh  1497] not implemented: PPB_BrokerTrusted;0.3
[fresh  1497] [PPB] {zilch} ppb_network_monitor_update_network_list
[fresh  1497] [PPB] {zilch} ppb_flash_set_instance_always_on_top instance=11, on_top=1
Xlib:  extension "GLX" missing on display ":0".
1488860024867	addons.productaddons	ERROR	Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]
1488860031197	addons.productaddons	ERROR	Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]

(xfce4-screenshooter:1923): Gtk-CRITICAL **: IA__gtk_icon_info_load_icon: assertion 'icon_info != NULL' failed

(xfce4-screenshooter:1923): Gtk-CRITICAL **: IA__gtk_icon_info_free: assertion 'icon_info != NULL' failed

(xfce4-screenshooter:1923): Gtk-CRITICAL **: IA__gtk_icon_info_load_icon: assertion 'icon_info != NULL' failed

(xfce4-screenshooter:1923): Gtk-CRITICAL **: IA__gtk_icon_info_free: assertion 'icon_info != NULL' failed

(openbox:946): GLib-CRITICAL **: Source ID 242 was not found when attempting to remove it

(openbox:946): GLib-CRITICAL **: Source ID 255 was not found when attempting to remove it

** (bl-text-editor:1970): WARNING **: Could not load Gedit repository: Typelib file for namespace 'GtkSource', version '3.0' not found

By crash I mean the application comes up and seems to work then closes for no reason and I am not able to start it up again. This was however was the behaviour before I installed the Nvidia driver. Not when it starts I just get the error message

OpenGL GLX extension not supported by display

But not in the terminal but in a separate window, a screenshot of it here https://cdn.scrot.moe/images/2017/03/07 … 051523.png

Last edited by Head_on_a_Stick (2017-03-07 07:32:54)

Offline

#8 2017-03-07 07:40:12

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: trying to make steam run [solved]

Curiouser and curiouser...

What is your graphics hardware?

lspci -knn | grep -iA2 'vga\|3d'

Are you using the backported video drivers or kernel?

bobhund wrote:

I tried the instructions of removing the different ubuntu files, and I get an error that the files do not exist

Have you tried https://wiki.debian.org/Steam#Variant:_ … se_runtime?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#9 2017-03-07 21:08:55

stevep
MX Linux Developer
Registered: 2016-08-08
Posts: 373

Re: trying to make steam run [solved]

There's been some threads lately where the poster was sure they installed the Nvidia driver, but it actually failed and they didn't catch that in the terminal stream of technical stuff.  That would lead to exactly your situation.

When you ran nvidia-detect first per the wiki instructions, which driver did it say was compatible with your card?

Offline

#10 2017-03-07 21:14:08

damo
....moderator....
Registered: 2015-08-20
Posts: 5,059

Re: trying to make steam run [solved]

And for gui configuration and information:

sudo apt-get install nvidia-settings

Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#11 2017-03-08 17:07:33

bobhund
Member
Registered: 2016-10-25
Posts: 43

Re: trying to make steam run [solved]

I took the que of Stevep and uninstalled and then installed everything again, and now it works. Do not know what when wrong, before....

Offline

#12 2017-04-15 09:49:45

peter007
New Member
Registered: 2017-04-15
Posts: 1

Re: trying to make steam run [solved]

Thanks guys.... had the same problem and thanks to this forum,problem solved.....

Offline

Board footer

Powered by FluxBB