You are not logged in.

#1 2015-10-18 17:20:03

JasonMehmel
Member
Registered: 2015-10-06
Posts: 76

leaving full screen takes me back to the primary (laptop) monitor

Hey all,

I've got a laptop connected to a second display with VGA.

Whenever I take a program full-screen, it will occupy the screen that it started in. (Either primary or secondary.) But when I leave the full-screen  option and go back into windowed mode, the window shifts to the primary (laptop) screen.

Is this a behaviour I can control?


Fortune favours the bold.
A BL-hopeful
Asus Zenbook UX330

Offline

#2 2015-10-18 18:18:31

twoion
一期一会
Registered: 2015-08-10
Posts: 3,399

Re: leaving full screen takes me back to the primary (laptop) monitor

It seems that this is an Openbox issue, see here. I have also found this thread. As I don't know Openbox personally though, I can't help with debugging this. Could be a bug or a misconfiguration in Xrandr, see the second link for this.

Offline

#3 2015-10-18 18:20:02

hhh
Meep!
Registered: 2015-09-17
Posts: 12,505
Website

Re: leaving full screen takes me back to the primary (laptop) monitor

I don't have 2 monitors, so I'm out.

Offline

#4 2015-10-18 18:31:26

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: leaving full screen takes me back to the primary (laptop) monitor

hhh wrote:

I don't have 2 monitors

Me neither but what the heck...

@OP: How have you set up your monitors?

Is there anything in /var/log/Xorg.0.log that looks relevant?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2015-10-18 23:37:44

JasonMehmel
Member
Registered: 2015-10-06
Posts: 76

Re: leaving full screen takes me back to the primary (laptop) monitor

I've got them next to each other. Laptop on the left, monitor on the right.

As for the log, maybe this is relevant:

[    21.788] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 13 12:40:45 2015
[    21.956] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    22.031] (==) No Layout section.  Using the first Screen section.
[    22.031] (==) No screen section available. Using defaults.
[    22.031] (**) |-->Screen "Default Screen Section" (0)
[    22.031] (**) |   |-->Monitor "<default monitor>"
[    22.057] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.

There's a lot in there!

As for the links; the first one was exhibiting my problem. They start to discuss it then close the topic because he's actually talking Openbox and not LXQt, the main goal of that project. I've sent an email to that user, we'll see if he responds!

The second seems to specifically have resolution issues with flash... that's not happening to me at all.


Fortune favours the bold.
A BL-hopeful
Asus Zenbook UX330

Offline

#6 2015-10-19 05:40:15

ohnonot
...again
Registered: 2015-09-29
Posts: 5,568

Re: leaving full screen takes me back to the primary (laptop) monitor

No monitor specified for screen "Default Screen Section".

that looks relevant, i'd research that.

i'm not saying this can't be solved here, but it's a good moment to point out the openbox mailing list.
they're very newbie-friendly there, even dana jansens replies to posts regularly.


Give to COVAX! Here or here. (explanation)
My Repos: notabug | framagit

Offline

#7 2015-10-19 06:35:49

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: leaving full screen takes me back to the primary (laptop) monitor

JasonMehmel wrote:

I've got them next to each other. Laptop on the left, monitor on the right.

lol

I meant: how have you set your system up to use the screens? Which configuration files do you use and what is the content?

EDIT: Also, what is your hardware?

EDIT2: I mean the graphics card(s), not the monitors tongue

Last edited by Head_on_a_Stick (2015-10-19 06:37:44)


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#8 2015-10-19 15:53:37

JasonMehmel
Member
Registered: 2015-10-06
Posts: 76

Re: leaving full screen takes me back to the primary (laptop) monitor

Aha!

Well, I'm using Openbox and XRandR (ARandR for the gui). All the config files are out-of-the-box Bunsen Labs. (This was a problem on Crunchbang, too.)

As for hardware, it's a Lenovo laptop that hasn't been modified as far as I know. Can anyone remind me of the command to check for the hardware listings?


Fortune favours the bold.
A BL-hopeful
Asus Zenbook UX330

Offline

#9 2015-10-19 17:57:20

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: leaving full screen takes me back to the primary (laptop) monitor

JasonMehmel wrote:

Can anyone remind me of the command to check for the hardware listings?

lspci -knn|grep -iA2 'vga\|3d'

See lspci(8) & grep(1)

Please post your xrandr configuration file or describe more fully how exactly you have configured your screens.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#10 2015-10-19 22:09:13

JasonMehmel
Member
Registered: 2015-10-06
Posts: 76

Re: leaving full screen takes me back to the primary (laptop) monitor

Okay, here's the responce from the lspci:

00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02)
	Subsystem: Lenovo Device [17aa:215a]
	Kernel driver in use: i915

As for xrandr, I can't find a config file for it. The closest thing that I've got is a script I wrote to basically activate the second monitor as an extended display

xrandr --output DP3 --off --output DP2 --off --output DP1 --off --output HDMI3 --off --output HDMI2 --off --output HDMI1 --off --output LVDS1 --mode 1440x900 --pos 0x0 --rotate normal --output VGA1 --mode 1600x900 --pos 1440x0 --rotate normal
nitrogen --restore

I'm figuring the --pos 1440x0 is the positioning of the second screen exactly as many pixels as the original display is long...

The Archwiki indicates that xrandr doesn't have a config file.

My hunch is that it's openbox.


Fortune favours the bold.
A BL-hopeful
Asus Zenbook UX330

Offline

#11 2015-10-20 06:39:33

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: leaving full screen takes me back to the primary (laptop) monitor

JasonMehmel wrote:

My hunch is that it's openbox.

Yes, probably.

Does the LXDE live ISO exhibit this behaviour?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#12 2015-10-20 07:46:46

ohnonot
...again
Registered: 2015-09-29
Posts: 5,568

Re: leaving full screen takes me back to the primary (laptop) monitor

try playing with xrandr's "--primary" option (shot in the dark).

also, if this really is openbox. maybe it matters whether you call xrandr before or after openbox starts?
(on my system, it's trivial to put it in ~/.xinitrc, and without a trailing '&'. not sure how this translates into display manager use cases).


Give to COVAX! Here or here. (explanation)
My Repos: notabug | framagit

Offline

#13 2015-10-20 17:53:43

JasonMehmel
Member
Registered: 2015-10-06
Posts: 76

Re: leaving full screen takes me back to the primary (laptop) monitor

Setting primary in xrandr didn't help...

Haven't tried changing the order in the config file yet.

Also, an update: this is happening on Sublime Text and Chrome, but not with VLC or Mirage. Not sure if that helps narrow it down...

Last edited by JasonMehmel (2015-10-20 18:03:31)


Fortune favours the bold.
A BL-hopeful
Asus Zenbook UX330

Offline

#14 2015-10-20 17:55:29

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: leaving full screen takes me back to the primary (laptop) monitor

JasonMehmel wrote:

this is happening on Sublime Text and Chrome, but not with VLC or Mirage

So it happens with two programs that are not installed from the official Debian repositories.

Perhaps you have installed them wrong or perhaps they are not compatible with Debian 8.2


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#15 2015-10-21 18:03:08

JasonMehmel
Member
Registered: 2015-10-06
Posts: 76

Re: leaving full screen takes me back to the primary (laptop) monitor

Ah, good idea!

Although it also happens on Chromium, which is actually what I'm using right now, exhibiting the same behaviour.


Fortune favours the bold.
A BL-hopeful
Asus Zenbook UX330

Offline

#16 2015-10-21 19:27:33

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: leaving full screen takes me back to the primary (laptop) monitor

Head_on_a_Stick wrote:

Does the LXDE live ISO exhibit this behaviour?

What about other window managers?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#17 2015-10-22 06:42:40

ohnonot
...again
Registered: 2015-09-29
Posts: 5,568

Re: leaving full screen takes me back to the primary (laptop) monitor

JasonMehmel wrote:

Although it also happens on Chromium

still, all applications mentioned have a sort of special deal with the window manager (i think it's apparent what i mean when you look at chrom/e/ium) and are really a little outside the normal gnu/linux desktop conventions.
maybe they just don't respect all these freedesktop recommendations.


Give to COVAX! Here or here. (explanation)
My Repos: notabug | framagit

Offline

#18 2015-10-22 15:57:41

JasonMehmel
Member
Registered: 2015-10-06
Posts: 76

Re: leaving full screen takes me back to the primary (laptop) monitor

That's an interesting point, ohnonot, maybe it's a matter of making exceptions for these programs.

Head_on_a_Stick I haven't tried LXDE yet, just haven't had the time in my day to get a live ISO up and going. I'm still in my semi-newb phase, so building an LXDE ISO, or installing LXDE inside a live ISO, would take me probably a good half-day or more!

(I'm producing a play that goes up in november, so I've got reduced time to tinker with my system right now.)


Fortune favours the bold.
A BL-hopeful
Asus Zenbook UX330

Offline

#19 2015-10-22 18:10:49

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: leaving full screen takes me back to the primary (laptop) monitor

JasonMehmel wrote:

Head_on_a_Stick I haven't tried LXDE yet, just haven't had the time in my day to get a live ISO up and going. I'm still in my semi-newb phase, so building an LXDE ISO, or installing LXDE inside a live ISO, would take me probably a good half-day or more!

Debian built some for you:
http://cdimage.debian.org/cdimage/unoff … onfree.iso


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#20 2015-10-22 18:58:32

JasonMehmel
Member
Registered: 2015-10-06
Posts: 76

Re: leaving full screen takes me back to the primary (laptop) monitor

You're a saint... you save me from my own laziness! I'll see if I can try this out on Sunday.


Fortune favours the bold.
A BL-hopeful
Asus Zenbook UX330

Offline

Board footer

Powered by FluxBB