You are not logged in.

#1 2017-01-03 00:52:27

dhalgren
Member
Registered: 2015-10-01
Posts: 84

[SOLVED] `alsactl init` required at every boot

Well, this fixed the problem for me, but it did not hold after turning off and rebooting.

Does anyone have any idea what I need to look at to try and make the solution permanent?

I did notice that the last update included various updates to alsa and various audio libraries, so I suppose these are the problem, but I have no idea what to do to try and fix it permanently.

Last edited by Head_on_a_Stick (2017-01-04 21:32:59)

Offline

#2 2017-01-03 01:14:11

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] `alsactl init` required at every boot

dhalgren wrote:

I did notice that the last update included various updates to alsa and various audio libraries, so I suppose these are the problem

That is highly unlikely, IMO.

Please describe your problem in full and post the output of:

aplay -l
cat /proc/asound/cards
amixer
apt-cache policy

Please use code tags when posting terminal output.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2017-01-03 01:21:45

dhalgren
Member
Registered: 2015-10-01
Posts: 84

Re: [SOLVED] `alsactl init` required at every boot

Head_on_a_Stick wrote:
dhalgren wrote:

I did notice that the last update included various updates to alsa and various audio libraries, so I suppose these are the problem

That is highly unlikely, IMO.

You may well be correct, I admit I did not go through the list of updates rigorously.

The results of your commands are:

bruce@debian:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC270 Analog [ALC270 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
bruce@debian:~$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7a10000 irq 34
bruce@debian:~$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 54394 [83%] [on]
  Front Right: Playback 54394 [83%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [on]
  Front Right: Capture 65536 [100%] [on]
bruce@debian:~$ apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://httpredir.debian.org/debian/ jessie-backports/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie-backports/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie-backports/contrib Translation-en
 100 http://httpredir.debian.org/debian/ jessie-backports/non-free i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/contrib i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/main i386 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/non-free amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/contrib amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin httpredir.debian.org
 100 http://pkg.bunsenlabs.org/debian/ jessie-backports/main i386 Packages
     release o=bunsenlabs,n=jessie-backports,l=bunsenlabs,c=main
     origin pkg.bunsenlabs.org
 100 http://pkg.bunsenlabs.org/debian/ jessie-backports/main amd64 Packages
     release o=bunsenlabs,n=jessie-backports,l=bunsenlabs,c=main
     origin pkg.bunsenlabs.org
 500 http://pkg.bunsenlabs.org/debian/ bunsen-hydrogen/main i386 Packages
     release o=bunsenlabs,n=bunsen-hydrogen,l=bunsenlabs,c=main
     origin pkg.bunsenlabs.org
 500 http://pkg.bunsenlabs.org/debian/ bunsen-hydrogen/main amd64 Packages
     release o=bunsenlabs,n=bunsen-hydrogen,l=bunsenlabs,c=main
     origin pkg.bunsenlabs.org
 500 http://ftp.us.debian.org/debian/ jessie-updates/main Translation-en
 500 http://ftp.us.debian.org/debian/ jessie-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/main i386 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.us.debian.org/debian/ jessie/non-free Translation-en
 500 http://ftp.us.debian.org/debian/ jessie/main Translation-en
 500 http://ftp.us.debian.org/debian/ jessie/contrib Translation-en
 500 http://ftp.us.debian.org/debian/ jessie/non-free i386 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie/contrib i386 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie/main i386 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie/non-free amd64 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie/contrib amd64 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin ftp.us.debian.org
 500 http://ftp.us.debian.org/debian/ jessie/main amd64 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin ftp.us.debian.org
Pinned packages:

I'll be annoyed with myself (but not necessarily surprised) if I have done something to cause this.

Thanks for looking at it for me.

Offline

#4 2017-01-03 01:31:53

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] `alsactl init` required at every boot

^ Well, that all looks normal enough.

So what *exactly* is the problem?

You have no sound until you `alsactl init` and you have to do this every boot, is that correct?

What is your hardware?

lspci -knn | grep -iA2 audio

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2017-01-03 01:40:17

dhalgren
Member
Registered: 2015-10-01
Posts: 84

Re: [SOLVED] `alsactl init` required at every boot

Head_on_a_Stick wrote:

So what *exactly* is the problem?

You have no sound until you `alsactl init` and you have to do this every boot, is that correct?

Yes, that is correct.

I have changed from volti to volumeicon, as per instructions in the tips section of the forum, and have a bl-start-pulseaudio-x11 file in ~/bin

Would that make any difference?

The results of the command are:

bruce@debian:~$ lspci -knn| grep -iA2 audio
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
	Subsystem: ASUSTeK Computer Inc. Device [1043:124d]
	Kernel driver in use: snd_hda_intel

Offline

#6 2017-01-03 01:45:20

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] `alsactl init` required at every boot

dhalgren wrote:

I have changed from volti to volumeicon, as per instructions in the tips section of the forum, and have a bl-start-pulseaudio-x11 file in ~/bin

Would that make any difference?

Yes, it should make everything work properly hmm

Have you tried using this command after `alsactl init`:

sudo alsactl store

Also, what is the exact terminal output after you use `alsactl init` & `alsactl store`?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#7 2017-01-03 01:56:24

dhalgren
Member
Registered: 2015-10-01
Posts: 84

Re: [SOLVED] `alsactl init` required at every boot

Terminal output is:

bruce@debian:~$ sudo alsactl init
[sudo] password for bruce: 
alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Found hardware: "HDA-Intel" "Realtek ALC270" "HDA:10ec0270,1043124d,00100100 HDA:80862806,80860101,00100000" "0x1043" "0x124d"
Hardware is initialized using a generic method
bruce@debian:~$ sudo alsactl store
bruce@debian:~$

I had not previously noticed, because I didn't bother to look,

alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Which I suspect must be the problem. Apologies for this failure on my part.

EDIT: I've done some research on this, but have found most of the information incomprehensible (especially on the debian forums). One person suggests the following:

mv /var/lib/alsa/asound.state{,-}
alsactl store
alsactl restore

But I have no idea what the command "mv /var/lib/alsa/asound.state{,-}" does, namely, where does it move asound.state to? If someone can tell me a bit more about this, I would be happy to try it.

Last edited by dhalgren (2017-01-03 02:41:24)

Offline

#8 2017-01-03 02:54:45

damo
....moderator....
Registered: 2015-08-20
Posts: 5,057

Re: [SOLVED] `alsactl init` required at every boot

dhalgren wrote:

....
But I have no idea what the command "mv /var/lib/alsa/asound.state{,-}" does, namely, where does it move asound.state to? If someone can tell me a bit more about this, I would be happy to try it.

It renames the file with a trailing "-", ie

/var/lib/alsa/asound.state-

(bash brace expansion)

Last edited by damo (2017-01-03 02:57:28)


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#9 2017-01-03 03:08:47

dhalgren
Member
Registered: 2015-10-01
Posts: 84

Re: [SOLVED] `alsactl init` required at every boot

Unfortunately, that altered nothing. I'll just keep putting the command in at startup, unless someone has some other idea I can try.

Cheers

Offline

#10 2017-01-03 11:47:58

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] `alsactl init` required at every boot

So, you have a problem with /syphilisfs sysfs then hmm

How is it mounted?

findmnt

This looks relevant:

https://bugs.debian.org/cgi-bin/bugrepo … bug=807032

Which kernel are you running?

sysctl kernel.version

Does the sound work if you load up the BunsenLabs ISO image and select the "live" environment?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#11 2017-01-03 12:25:16

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] `alsactl init` required at every boot

@dhalgren I have split your problem off into it's own thread.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#12 2017-01-03 22:42:53

dhalgren
Member
Registered: 2015-10-01
Posts: 84

Re: [SOLVED] `alsactl init` required at every boot

Here are the results of your commands.

bruce@debian:~$ findmnt
TARGET                                SOURCE      FSTYPE   OPTIONS
/                                     /dev/sda7   ext4     rw,relatime,errors=re
├─/sys                                sysfs       sysfs    rw,nosuid,nodev,noexe
│ ├─/sys/kernel/security              securityfs  security rw,nosuid,nodev,noexe
│ ├─/sys/fs/cgroup                    tmpfs       tmpfs    ro,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/systemd          cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/cpuset           cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/cpu,cpuacct      cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/blkio            cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/memory           cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/devices          cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/freezer          cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/net_cls,net_prio cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ ├─/sys/fs/cgroup/perf_event       cgroup      cgroup   rw,nosuid,nodev,noexe
│ │ └─/sys/fs/cgroup/pids             cgroup      cgroup   rw,nosuid,nodev,noexe
│ ├─/sys/fs/pstore                    pstore      pstore   rw,nosuid,nodev,noexe
│ ├─/sys/kernel/debug                 debugfs     debugfs  rw,relatime
│ └─/sys/fs/fuse/connections          fusectl     fusectl  rw,relatime
├─/proc                               proc        proc     rw,nosuid,nodev,noexe
│ └─/proc/sys/fs/binfmt_misc          systemd-1   autofs   rw,relatime,fd=22,pgr
│   └─/proc/sys/fs/binfmt_misc        binfmt_misc binfmt_m rw,relatime
├─/dev                                udev        devtmpfs rw,relatime,size=1024
│ ├─/dev/pts                          devpts      devpts   rw,nosuid,noexec,rela
│ ├─/dev/shm                          tmpfs       tmpfs    rw,nosuid,nodev
│ ├─/dev/hugepages                    hugetlbfs   hugetlbf rw,relatime
│ └─/dev/mqueue                       mqueue      mqueue   rw,relatime
├─/run                                tmpfs       tmpfs    rw,nosuid,relatime,si
│ ├─/run/lock                         tmpfs       tmpfs    rw,nosuid,nodev,noexe
│ ├─/run/rpc_pipefs                   rpc_pipefs  rpc_pipe rw,relatime
│ └─/run/user/1000                    tmpfs       tmpfs    rw,nosuid,nodev,relat
│   └─/run/user/1000/gvfs             gvfsd-fuse  fuse.gvf rw,nosuid,nodev,relat
├─/home                               /dev/sda8   ext4     rw,relatime,data=orde
└─/boot/efi                           /dev/sda1   vfat     rw,relatime,fmask=007
bruce@debian:~$ sysctl kernel.version
kernel.version = #1 SMP Debian 4.7.8-1~bpo8+1 (2016-10-19)

I don't know anything about this really, but to me it looks as though it's not mounted.

And yes, the sound works with the BL live image, and a variety of others which I've had a look at.

Offline

#13 2017-01-04 07:23:37

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] `alsactl init` required at every boot

/sys is mounted normally so it looks like this may be related to the linked bug.

Do you still have this problem if you boot with the non-backports kernel?

It should be an option in the "Advanced" GRUB sub-menu.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#14 2017-01-04 07:59:02

dhalgren
Member
Registered: 2015-10-01
Posts: 84

Re: [SOLVED] `alsactl init` required at every boot

The non-backports kernel had the same problem of no sound without running "alsactl init" after boot.

So: I looked at the bug report again and did the following:

bruce@debian:~$ sudo /usr/sbin/alsactl restore
bruce@debian:~$ sudo /usr/sbin/alsactl store

For some reason this seems to have fixed the problem, where "alsactl restore", by itself, did not, in as much as I now have sound on reboot, without having to take any further action.

I've rebooted twice with the same satisfactory result.

Thanks HoaS, for walking me through this.

Offline

Board footer

Powered by FluxBB