You are not logged in.

#1 2016-11-25 17:24:16

kama
Member
Registered: 2016-11-25
Posts: 10

Intel Skylake GPU problem

Not sure if I should start a new thread so I post it here.

apt-cache policy libegl1-mesa libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-video-intel firmware-misc-nonfree
libegl1-mesa:
  Installed: 12.0.4-2~bpo8+1
  Candidate: 12.0.4-2~bpo8+1
  Version table:
 *** 12.0.4-2~bpo8+1 0
        100 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     10.3.2-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
libgl1-mesa-glx:
  Installed: 12.0.4-2~bpo8+1
  Candidate: 12.0.4-2~bpo8+1
  Version table:
 *** 12.0.4-2~bpo8+1 0
        100 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     10.3.2-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
libgl1-mesa-dri:
  Installed: 12.0.4-2~bpo8+1
  Candidate: 12.0.4-2~bpo8+1
  Version table:
 *** 12.0.4-2~bpo8+1 0
        100 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     10.3.2-1+deb8u1 0
        500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
xserver-xorg-video-intel:
  Installed: 2:2.99.917+git20160706-1~bpo8+1
  Candidate: 2:2.99.917+git20160706-1~bpo8+1
  Version table:
 *** 2:2.99.917+git20160706-1~bpo8+1 0
        100 [url]http://httpredir.debian.org/debian/[/url] jessie-backports/main amd64 
firmware-misc-nonfree:
  Installed: 20160824-1~bpo8+1
  Candidate: 20160824-1~bpo8+1
  Version table:
 *** 20160824-1~bpo8+1 0
        100 http://httpredir.debian.org/debian/ jessie-backports/non-free amd64 Packages
        100 /var/lib/dpkg/status
lscpi -k
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
	Subsystem: Intel Corporation Skylake Host Bridge/DRAM Registers
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 510 (rev 07)
	Subsystem: Intel Corporation HD Graphics 510
	Kernel driver in use: i915
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
	Subsystem: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller
	Kernel driver in use: xhci_hcd
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
	Subsystem: Intel Corporation Sunrise Point-LP Thermal subsystem
	Kernel driver in use: intel_pch_thermal
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
	Subsystem: Intel Corporation Sunrise Point-LP CSME HECI #1
	Kernel driver in use: mei_me
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
	Subsystem: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode]
	Kernel driver in use: ahci
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
	Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
	Subsystem: Intel Corporation Sunrise Point-LP LPC Controller
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
	Subsystem: Intel Corporation Sunrise Point-LP PMC
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
	Subsystem: Device 1991:0269
	Kernel driver in use: snd_hda_intel
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
	Subsystem: Intel Corporation Sunrise Point-LP SMBus
	Kernel driver in use: i801_smbus
01:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
	Subsystem: Intel Corporation Dual Band Wireless AC 3160
	Kernel driver in use: iwlwifi
inxi -Gx
Graphics:  Card: Intel HD Graphics 510 bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)
           GLX Version: 3.0 Mesa 12.0.4 Direct Rendering: Yes
apt search linux-image | grep installed
linux-image-4.7.0-0.bpo.1-amd64/jessie-backports,now 4.7.8-1~bpo8+1 amd64 [installed,automatic]
linux-image-amd64/jessie-backports,now 4.7+75~bpo8+1 amd64 [installed]

I've done everything mentioned here but I'm still stuck with Gallium and LLVM. Is there anything else I can do?

---Mod Edit: use code tags please, not quote tags wink ---

Last edited by kama (2016-11-25 21:16:20)

Offline

#2 2016-11-25 20:55:21

damo
....moderator....
Registered: 2015-08-20
Posts: 6,600

Re: Intel Skylake GPU problem

Please don't add your own problem to a thread which is already [SOLVED]

To produce command output in English, put "LC_ALL=C" in front of each command. For example

LC_ALL=C apt-cache policy libegl1-mesa

This is for future reference BTW, because the output you posted is obvious in this case, even for non-Polish speakers smile

We can change the thread title to something more descriptive if you want.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2016-11-26 11:30:49

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Intel Skylake GPU problem

You have the backported kernel installed but are you actually booted up with it?

cat /proc/version

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#4 2016-11-26 12:34:25

kama
Member
Registered: 2016-11-25
Posts: 10

Re: Intel Skylake GPU problem

cat /proc/version
Linux version 4.7.0-0.bpo.1-amd64 (debian-kernel@lists.debian.org) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP Debian 4.7.8-1~bpo8+1 (2016-10-19)

Looks like it.

Offline

Board footer

Powered by FluxBB