You are not logged in.

#1 2016-11-25 00:48:14

kama
Member
Registered: 2016-11-25
Posts: 10

Forcing DPI diffrent than 96

Hi!
I'm sorry for my english but I'm not an english native speaker nor an experiened linux user. I've decided to install Bunsenlabs on my 13,3 inch laptop and everything went smooth like in none of the "ubuntu-like" distros I struggled with before. I amm truly impressed and really appreciate what you've done.

Right now I'm trying to fix the size of the fonts on my screen. They are so small that I can barely read them.  I've tried adding xrandr --dpi 120 to openbox autostart with little effect, entering it as a command in terminal then restarting openbox, tint2, conky and the browser with tint2 being immune to changes. What's the proper place I should add it so everything will get bigger?

Thanks for help in advance,
kama

Offline

#2 2016-11-25 01:45:46

cloverskull
Member
Registered: 2015-10-01
Posts: 323

Re: Forcing DPI diffrent than 96

Hi kama,

I think your best bet is reading the arch wiki on this issue: https://wiki.archlinux.org/index.php/xo … ze_and_DPI

In my experience, using xrandr to find a suitable font size and then setting it permanently in xorg.conf has been the most sustainable way of dealing with this. Good luck!

Offline

#3 2016-11-25 07:52:46

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Forcing DPI diffrent than 96

kama wrote:

What's the proper place I should add it so everything will get bigger?

Try uncommenting and changing this line in ~/.Xresources:

!Xft.dpi: 96

https://github.com/BunsenLabs/bunsen-co … sources#L7


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#4 2016-11-25 09:56:20

kama
Member
Registered: 2016-11-25
Posts: 10

Re: Forcing DPI diffrent than 96

Thanks! The problem looks solved. However tint2 doesn't seem to care about it. What should I do to make it look a little bigger?

Offline

#5 2016-11-25 20:44:04

damo
....moderator....
Registered: 2015-08-20
Posts: 6,114

Re: Forcing DPI diffrent than 96

kama wrote:

Thanks! The problem looks solved. However tint2 doesn't seem to care about it. What should I do to make it look a little bigger?

Change the font settings in your tint2 config: "Menu -> Preferences -> Tiint2 -> Edit Tint2s"


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#6 2016-11-29 02:10:48

cloverskull
Member
Registered: 2015-10-01
Posts: 323

Re: Forcing DPI diffrent than 96

I seem to recall making this change in a handful of places:

  1. /etc/X11/xorg.conf.d/90-monitor.conf

  2. ~/.xinitrc

  3. /etc/lightdm/lightdm.conf

Setting these three to a sane and consistent value resulted in the best X experience.

Offline

#7 2016-11-29 07:04:26

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,122
Website

Re: Forcing DPI diffrent than 96

I would recommend setting your dpi to the correct value for your monitor. That way you're less likely to hit other strange issues later.

You can set GTK font size for all gtk apps in Menu>Preferences>Appearance>Default Font
BL default is "Sans 11" but choose any size you want.
("Sans" is an alias set in ~/.config/fontconfig/fonts.conf to "Droid Sans" but you can edit that file for a desktop-wide default font face.)

Unfortunately, some other places need adjusting too. Menu>Preferences>Openbox>Gui Config Tool for the various openbox font sizes, Tint2 as Damo posted, ~/.Xresources for urxvt (if you use it) and Menu>Preferences>Conky>Edit Conkys  for conky fonts.

You can also usually adjust each application's font size individually, if it seems to be too big/small compared with the others.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

Board footer

Powered by FluxBB