You are not logged in.

#1 2015-10-10 09:16:08

dmac0o1
New Member
Registered: 2015-10-03
Posts: 4

[SOLVED] Darkened Screenshots?

Hey all,
I've noticed that when I take a screenshot using the "select a region" option on BL's default screenshot software, the .png file that comes out will always be shaded/darker than the original. To illustrate my problem:

A screenshot using the "entire screen" option:
screenshot-10102015-051436pm.php

A screenshot using the "active window" option:
screenshot-10102015-050912pm.php

A screenshot using the "select a region" option (notice the difference in colour):
screenshot-10102015-051044pm.php


How do I fix this (i.e. make "select a region" screenshots not shaded)?

[edit: typo]

Last edited by dmac0o1 (2015-10-12 00:42:26)

Offline

#2 2015-10-10 11:00:53

nore
>2⁹
From: squirrels' nest
Registered: 2015-09-29
Posts: 474

Re: [SOLVED] Darkened Screenshots?

It's compositing (compton) drawing a shadow behind the selection. Try disabling compositing and take a scrot. If it's bright, you know where the problem lies. Someone will soon come up with a clever solution, but meanwhile you can capture whole screen and crop the image afterwards with Gimp or another tool you prefer.

See: https://wiki.archlinux.org/index.php/Compton

Offline

#3 2015-10-10 12:16:56

damo
....moderator....
Registered: 2015-08-20
Posts: 5,253

Re: [SOLVED] Darkened Screenshots?

Yes, it is xfce4-screenshooter not behaving properly with compositing on.

Meanwhile - "clever solution" is

scrot -s

smile


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#4 2015-10-12 00:37:57

dmac0o1
New Member
Registered: 2015-10-03
Posts: 4

Re: [SOLVED] Darkened Screenshots?

Thanks for the replies!

Damo's suggestion works. For the time being I'll use this command to save my screenshots:

scrot -s ~/Pictures/screenshots/%Y-%m-%d-%T-screenshot.png

I'd really like to get that PrtSc button working, though...! How do I change the settings of my screenshooter so that I can make it behave properly?

Offline

#5 2015-10-12 00:41:22

dmac0o1
New Member
Registered: 2015-10-03
Posts: 4

Re: [SOLVED] Darkened Screenshots?

Seems I've got it working now: there are no problems after I disable compositing!

Offline

#6 2015-10-12 01:06:23

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: [SOLVED] Darkened Screenshots?

The relevant keybinds can be found in ~/.config/openbox/rc.xml. Here is the portion you would need to edit:

<keybind key="Print">
      <action name="Execute">
        <command>xfce4-screenshooter</command>
      </action>
    </keybind>
    <keybind key="A-Print">
      <action name="Execute">
        <command>scrot '%Y-%m-%d--%s_$wx$h_scrot.png' -e 'mv $f ~/Pictures/screenshots/ ; bl-image-viewer ~/Pictures/screenshots/$f'</command>
      </action>
    </keybind>

As you can see, scrot is bound to alt-print and xfce4-screenshooter to print. You could swap those if you wanted. Be sure to replace the command in there with the one you supplied above for scrot.

Offline

#7 2017-01-06 18:38:52

9219k
New Member
From: Chicago
Registered: 2017-01-06
Posts: 1
Website

Re: [SOLVED] Darkened Screenshots?

Had the same issue. Found very simple solution.

You need to add xfce4-screenshooter to the shadow-exclude parameter in compton.conf

1. Right click on a desktop (call menu) and go to Preferences -> Compositor -> Edit Composition Settings. Or just open ~/.config/compton.conf in text editor.

2. In the #Shadow section there is a parameter shadow-exclude. By default it looks like this:

shadow-exclude = [ "i:e:Conky" ];

3. Add xfce4-screenshooter in it:

shadow-exclude = [ "i:e:Conky", "i:e:xfce4-screenshooter" ];

4. Restart the compositor.

The screen will still go darker when you'll make screenshots, but selected area will be "unshadowed".

Offline

#8 2017-01-06 19:49:13

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Darkened Screenshots?

Excellent stuff 9219k, thanks for sharing!

And welcome to the forums smile


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#9 2017-01-06 20:18:21

damo
....moderator....
Registered: 2015-08-20
Posts: 5,253

Re: [SOLVED] Darkened Screenshots?

I  think this bug (or a similar one anyway) has been fixed, so it shouldn't happen in the next release - but I could be wrong about that of course. It probably won't hurt to have it as a default setting in compton.conf though.

I remember trying the fix on another machine, and it didn't work, so perhaps there are idiosyncracies with compton and the graphics setup.


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#10 2017-01-07 01:21:31

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 6,065
Website

Re: [SOLVED] Darkened Screenshots?

@9219k welcome to BunsenLabs, and thanks for the fix!

That's a good method to know for compton shadowing issues in general, but in this case I agree with Damo. I think the bug must already have been fixed upstream because it fails to appear on my system, even without editing compton.conf.

Are you using an up to date BunsenLabs system? If so, and you still get the darkening issue, then maybe we should put the fix in compton.conf anyway, as it should do no harm.


John
--------------------
( a boring Japan blog, idle Twitterings and GitStuff )
In case you forget, the rules.

Offline

#11 2017-01-29 09:43:49

imp2021
Member
Registered: 2015-10-02
Posts: 31

Re: [SOLVED] Darkened Screenshots?

bump, i ran into the same issue. (im running an up to date bl)
im wild guessing its from using another theme. (default aint dark enough)
im using 'Bunsen-Blackish' from ObMenu->Preferences->Openbox->GUI Config Tool
AND
'Bunsen-Blue-Dark' from Obmenu->Preferences->Appearance

I'd suggest to add 'scrot' to the topic line, i was searching for that first. (even that its wrong guessed/searched)

however, 9219k's solution works like a charm for me too smile

Last edited by imp2021 (2017-01-29 09:44:33)

Offline

#12 2017-01-29 10:52:43

damo
....moderator....
Registered: 2015-08-20
Posts: 5,253

Re: [SOLVED] Darkened Screenshots?

^ Nothing to do with themes, it is a xfce4-screenshooter bug not dealing with the compositor properly.


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#13 2017-02-24 17:22:59

Black84
Member
Registered: 2017-02-17
Posts: 7

Re: [SOLVED] Darkened Screenshots?

9219k wrote:

Had the same issue. Found very simple solution.

You need to add xfce4-screenshooter to the shadow-exclude parameter in compton.conf

1. Right click on a desktop (call menu) and go to Preferences -> Compositor -> Edit Composition Settings. Or just open ~/.config/compton.conf in text editor.

2. In the #Shadow section there is a parameter shadow-exclude. By default it looks like this:

shadow-exclude = [ "i:e:Conky" ];

3. Add xfce4-screenshooter in it:

shadow-exclude = [ "i:e:Conky", "i:e:xfce4-screenshooter" ];

4. Restart the compositor.

The screen will still go darker when you'll make screenshots, but selected area will be "unshadowed".

So I need change code from point two by using code from point 3  ?

Last edited by Black84 (2017-02-24 17:23:45)

Offline

#14 2017-02-24 17:51:25

hhh
Meep!
Registered: 2015-09-17
Posts: 8,722
Website

Re: [SOLVED] Darkened Screenshots?

Yes.

Offline

Board footer

Powered by FluxBB