You are not logged in.

#1 2015-10-04 05:36:49

pvsage
Internal Affairs
Registered: 2015-09-29
Posts: 1,433

[solved] grub-probe error when installing updated kernel.

Setting up linux-image-3.16.0-4-amd64 (3.16.7-ckt11-1+deb8u4) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-3.16.0-4-amd64
/etc/kernel/postinst.d/zz-update-grub:
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-3.16.0-4-amd64
Found initrd image: /boot/initrd.img-3.16.0-4-amd64
grub-probe: error: unknown filesystem.
Found Debian GNU/Linux (8.2) on /dev/sda1
Found Debian GNU/Linux (8.1) on /dev/sda2
Found Debian GNU/Linux (8.1) on /dev/sda3

What's this "grub-probe: error: unknown filesystem"?  All my internal drive partitions are ext4; perhaps it's reporting my NTFS external drive?

EDIT:  Apparently this has happened with zfs filesystems, so I'm guessing it does have something to do with the NTFS drive.
https://github.com/zfsonlinux/grub/issues/19
Marking thread [solved].

Last edited by pvsage (2015-10-04 06:01:54)


Be excellent to each other, and...party on, dudes!
BunsenLabs Forum Rules
Tending and defending the Flame since 2009

Offline

Board footer

Powered by FluxBB