You are not logged in.

#1 2016-04-17 07:05:45

AndyMender
Member
From: Reincarnated in the UK :)
Registered: 2016-04-01
Posts: 49
Website

[SOLVED] Preventing nonexistant devices from auto-mounting

I have a legacy Asus Pundit PH-P1 with a slew of various input and output ports. For whatever reason BunsenLabs is trying to access all mountable devices, even though they're empty (USB, SD, CF extension) or don't exist at all (fd0 and fd1 floppy drives).

In good old time I would just go into /etc/fstab and ammend the redundant lines. However, now that we have such inventions as udisks, udevil, udev, etc. I am utterly flabbergasted as to where the changes should be introduced. Help anyone? smile

Last edited by AndyMender (2016-04-17 20:19:31)


In a GNU/Linux daze since forever. Hail to Debian and Arch!

Offline

#2 2016-04-17 09:10:53

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Please post the content of /etc/fstab and the output of:

findmnt

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2016-04-17 10:16:13

AndyMender
Member
From: Reincarnated in the UK :)
Registered: 2016-04-01
Posts: 49
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

/etc/fstab content:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=69eb1900-5452-4bae-be24-05d488a0b011 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda2 during installation
UUID=f34c9b56-67ea-4be1-acc4-5945cd8c8f3f none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0

findmnt output:

TARGET                                SOURCE     FSTYPE          OPTIONS
/                                     /dev/sda1  ext4            rw,relatime,errors=remount-ro,data=ordered
├─/sys                                sysfs      sysfs           rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/security              securityfs securityfs      rw,nosuid,nodev,noexec,relatime
│ ├─/sys/fs/cgroup                    tmpfs      tmpfs           ro,nosuid,nodev,noexec,mode=755
│ │ ├─/sys/fs/cgroup/systemd          cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=sy
│ │ ├─/sys/fs/cgroup/cpuset           cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,cpuset
│ │ ├─/sys/fs/cgroup/cpu,cpuacct      cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,cpu,cpuacct
│ │ ├─/sys/fs/cgroup/devices          cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,devices
│ │ ├─/sys/fs/cgroup/freezer          cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,freezer
│ │ ├─/sys/fs/cgroup/net_cls,net_prio cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,net_cls,net_prio
│ │ ├─/sys/fs/cgroup/blkio            cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,blkio
│ │ └─/sys/fs/cgroup/perf_event       cgroup     cgroup          rw,nosuid,nodev,noexec,relatime,perf_event
│ ├─/sys/fs/pstore                    pstore     pstore          rw,nosuid,nodev,noexec,relatime
│ ├─/sys/kernel/debug                 debugfs    debugfs         rw,relatime
│ └─/sys/fs/fuse/connections          fusectl    fusectl         rw,relatime
├─/proc                               proc       proc            rw,nosuid,nodev,noexec,relatime
│ └─/proc/sys/fs/binfmt_misc          systemd-1  autofs          rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct
├─/dev                                udev       devtmpfs        rw,relatime,size=10240k,nr_inodes=216050,mode=755
│ ├─/dev/pts                          devpts     devpts          rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000
│ ├─/dev/shm                          tmpfs      tmpfs           rw,nosuid,nodev
│ ├─/dev/mqueue                       mqueue     mqueue          rw,relatime
│ └─/dev/hugepages                    hugetlbfs  hugetlbfs       rw,relatime
├─/run                                tmpfs      tmpfs           rw,nosuid,relatime,size=362188k,mode=755
│ ├─/run/lock                         tmpfs      tmpfs           rw,nosuid,nodev,noexec,relatime,size=5120k
│ ├─/run/user/108                     tmpfs      tmpfs           rw,nosuid,nodev,relatime,size=181096k,mode=700,uid=108,gid=116
│ └─/run/user/1000                    tmpfs      tmpfs           rw,nosuid,nodev,relatime,size=181096k,mode=700,uid=1000,gid=1000
│   └─/run/user/1000/gvfs             gvfsd-fuse fuse.gvfsd-fuse rw,nosuid,nodev,relatime,user_id=1000,group_id=1000
└─/etc/machine-id                     tmpfs[/machine-id]
                                                 tmpfs           ro,relatime,size=362188k,mode=755

I wasn't aware of the findmnt command before.


In a GNU/Linux daze since forever. Hail to Debian and Arch!

Offline

#4 2016-04-17 10:21:16

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

AndyMender wrote:

BunsenLabs is trying to access all mountable devices

What exactly do you mean by "trying to access"?

findmnt(8) doesn't seem to show any extraneous devices.

Does anything show up in dmesg(1) when the devices are being accessed?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2016-04-17 14:19:28

AndyMender
Member
From: Reincarnated in the UK :)
Registered: 2016-04-01
Posts: 49
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Head_on_a_Stick wrote:
AndyMender wrote:

BunsenLabs is trying to access all mountable devices

What exactly do you mean by "trying to access"?

findmnt(8) doesn't seem to show any extraneous devices.

Does anything show up in dmesg(1) when the devices are being accessed?

I mean that BunsenLabs is trying to mount fd0 and fd1 floppy drives, though they obviously don't exist. It's a barebone system without space for a floppy drive. Below the dmesg output for fd0 and fd1:

abear@pundit-p1:~$ dmesg | grep fd0
[    0.110124] pci 0000:00:12.0: reg 0x18: [io  0xfd00-0xfd07]
[    1.258223] Floppy drive(s): fd0 is unknown type 15 (usb?), fd1 is unknown type 15 (usb?)
[   26.263413] end_request: I/O error, dev fd0, sector 0
abear@pundit-p1:~$ dmesg | grep fd1
[    1.258223] Floppy drive(s): fd0 is unknown type 15 (usb?), fd1 is unknown type 15 (usb?)
[   49.619570] end_request: I/O error, dev fd1, sector 0

I checked an older Manjaro Openbox i686 .iso and it too detects non-existant floppy drivers fd0 and fd1, though does not try to mount them on boot. The kernel in that Manjaro version was 3.12.

Thanks a lot for your assistance. At this point I would simply like to prevent BunsenLabs from mounting drives that don't exist during boot time as that stalls booting sad.


In a GNU/Linux daze since forever. Hail to Debian and Arch!

Offline

#6 2016-04-17 14:28:53

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

AndyMender wrote:

I would simply like to prevent BunsenLabs from mounting drives that don't exist during boot time as that stalls booting sad.

You can try adding them to /etc/fstab with the "nofail" option applied.

`man 5 systemd.mount` wrote:

       nofail
           With nofail, this mount will be only wanted, not required, by local-fs.target or remote-fs.target. This means that the
           boot will continue even if this mount point is not mounted successfully.

Alternatively, we can try masking any systemd unit files that may be activating the drives automatically.

For the second option, look at the output of:

systemctl --type device | grep 'fd0\|fd1'

If there are any .device units for those drives, try using:

sudo systemctl mask dev-fd0.device dev-fd1.device

See systemd.device(5)

Last edited by Head_on_a_Stick (2016-04-17 14:33:20)


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#7 2016-04-17 14:42:21

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Also, have you tried using `thunar-settings` → Advanced → Configure the management of removable drives and media?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#8 2016-04-17 18:55:19

AndyMender
Member
From: Reincarnated in the UK :)
Registered: 2016-04-01
Posts: 49
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Indeed, there were two .device units for fd0 and fd1 each. I masked them, unfortunately no success sad. I completely forgot that fstab allows the noauto option, which should take precedence over any means of auto-mounting through either udev or systemd. Will update post if this works smile.

EDIT: Still no go. I wrote the fstab rules very explicitly and yet something is still trying to mount those devices:

# Additional devices:
/dev/fd0        /media/fd0      auto    noauto,nofail,x-systemd.device-timeout=1        0       0
/dev/fd1        /media/fd1      auto    noauto,nofail,x-systemd.device-timeout=1        0       0
/dev/sdb        /media/usb0     auto    user,noauto,nofail,x-systemd.device-timeout=1        0       0
/dev/sdc        /media/usb1     auto    user,noauto,nofail,x-systemd.device-timeout=1        0       0

Per your previous question, I removed Thunar in favor of SpaceFM, though the latter also allows setting additional mount options for devices. I set everything to noauto, but the devices are still being mounted. I have no idea what is going on anymore...

Last edited by AndyMender (2016-04-17 19:13:41)


In a GNU/Linux daze since forever. Hail to Debian and Arch!

Offline

#9 2016-04-17 19:25:06

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Please post the output of:

systemctl --all --no-pager | grep 'fd0\|fd1'

You could also try adding the x-systemd.automount option in /etc/fstab


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#10 2016-04-17 19:49:29

AndyMender
Member
From: Reincarnated in the UK :)
Registered: 2016-04-01
Posts: 49
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Output of systemctl --all --no-pager | grep 'fd0\|fd1':

● dev-fd0.device                                                                                        masked    active   plugged   /dev/fd0
● dev-fd1.device                                                                                        masked    active   plugged   /dev/fd1
● sys-devices-platform-floppy.0-block-fd0.device                                                        masked    active   plugged   /sys/devices/platform/floppy.0/block/fd0
● sys-devices-platform-floppy.1-block-fd1.device                                                        masked    active   plugged   /sys/devices/platform/floppy.1/block/fd1

Two new .device units were discovered (dev-fd0.device and dev-fd1.device) and masked. Still, no progress.


In a GNU/Linux daze since forever. Hail to Debian and Arch!

Offline

#11 2016-04-17 19:54:45

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Well, I'm flummoxed hmm

How about:

dmesg | grep `fd0\|fd1'

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#12 2016-04-17 20:18:26

AndyMender
Member
From: Reincarnated in the UK :)
Registered: 2016-04-01
Posts: 49
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Head_on_a_Stick wrote:

Well, I'm flummoxed hmm

How about:

dmesg | grep `fd0\|fd1'

That just outputs the I/O read errors on both devices. Luckily, I found a solution. The fact that the kernel checks for Btrfs drives, though I have none, was a good pointer. I blacklisted all modules related to btrfs and floppy. This sped up the boot process by ~1 min and removed the offending boot messages in dmesg smile.

The remaining devices that are treated as connected, but empty are in fact my combo flash memory port and the CompactFlash (CF) port.

Again, thank you very much for your assistance. It seems I will stay with BunsenLabs a bit longer big_smile. Case closed!


In a GNU/Linux daze since forever. Hail to Debian and Arch!

Offline

#13 2016-04-17 20:26:17

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

I say sir, good work!
smile


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#14 2016-04-25 04:03:55

paxmark1
Member
Registered: 2015-10-02
Posts: 45

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

Per chance did you have kernel 4.5.0?  I was getting error messages about fdO  I blacklisted, disabled in bios but going to 4.5.1 fixed.  As I found out for my non-existent backlight -  systemctl disable can be undone by parts of systemd   If you really want  a non-existant device to not be accessed, systemctl mask sends it to /dev/null.  I would check more, but my hdd died and I am going to seriously upgrade, mobo, etc, 8 y.o.system.  My problem was not in stable however. 

Thank you , I will probably blacklist btrfs another excess line in my journal.

Offline

#15 2016-04-25 05:19:45

AndyMender
Member
From: Reincarnated in the UK :)
Registered: 2016-04-01
Posts: 49
Website

Re: [SOLVED] Preventing nonexistant devices from auto-mounting

As HoaS suggested, I masked the devices via systemctl, but that did not help. Also, I see I did not write this earlier, but the same problems occurred on an old Manjaro Openbox LiveCD (kernel 3.12), on current Manjaro JWM install (kernel 4.5) and on BunsenLabs stock install (kernel 3.16).

Most likely the floppy kernel module had some issues with my mobo and blacklisting it solved the problem smile.


In a GNU/Linux daze since forever. Hail to Debian and Arch!

Offline

Board footer

Powered by FluxBB